3 Replies Latest reply on Jan 2, 2010 5:30 AM by Attila Polinger

    MQM 6: cannot connect to database

    Attila Polinger

      Hello,

       

      we have a valid and working MQM 6 installation, using EWS 5.1-es, on a virtual Windows 2003 server.

      We would like to establish a Windows 2008 Standard (non-R2) system and reinstall MQM 6 on this, but still wish to remain with the current database.

       

      Installation goes well on Windows 2008 (a virtual machine) Standard. However, when we would like to configure the database, it fails to connect (when Test-ing). We opened a Wireshark live capture and retried connecting. We see no relevant packets that would tell us, that the request went out towards the database.

      We tried installing DB Utilities and the same problem occurs, connection failed.

      (We stopped the working MQM installation before trying this).

      Database is on a remote server. MS SQL 2005.

       

      MQM was installed on the standard HTTP port (80). No other tweaking has yet been performed.

       

      I would appreciate any useful information for troubleshooting. We searched the KB but has found no relevant article.

       

      Attila

        • 1. Re: MQM 6: cannot connect to database
          Attila Polinger

          Just a quick note that in the meantime we could overcome this issue. The reason was similar than that is outlined in KB article KB 51455. Only a different .DLL had to be set rights upon (DynamicPageDB.DLL).

          • 2. Re: MQM 6: cannot connect to database

            Hi Attila,

             

            I am assuming that you are using default port 1433 on SQL server and that you can connect to that port from the Virtual machine. 

             

            Ensure that the Username or the password specified doesn't have any special characters. A known issue is that, MQM 6.0 doesn't accept special characters while connecting to the SQL Server.  This is being addressed in an upcoming Patch.

             

            We'll need to install Microsoft SQL Server Native Client on the MQM server. This can be installed from the Microsoft SQL Server 2005 CD or can be downloaded from the following link.

             

            http://download.microsoft.com/download/4/4/D/44DBDE61-B385-4FC2-A67D-48053B8F9FA D/sqlncli.msi - (x86 Package)

             

            http://download.microsoft.com/download/4/4/D/44DBDE61-B385-4FC2-A67D-48053B8F9FA D/sqlncli_x64.msi (x64 Package)

             

            Also verify the username and the password being specified is the Database Owner's username and password.

             

             

            Verify if there are any connectivity issues with SQL or any of the parameters that is being used in connectivity. Best way to check if there are any issues with connectivity is to create a DSN and pass the parameters you are passing from MQM.  Please follow the steps below.

             

               a) After installing SQL Server Native Client, Data Sources ( ODBC) in the Administrative Tools from Control Panel

               b) Create a DSN, and fill the Name, Description, Server fields respectively.  ( Just specify the IP address, Do not enter the port number along with the Server IP)

               c) click "Next" and choose "With SQL Server Authentication usin a Login ID and Password" and check "connect to SQL server to obtain settings...."

               d) Enter the Database owner's username and Password  and click "Next"

             

            If the test fails, then this may indicate that we may need to tweak few settings on the SQL server.

             

            Hope this helps.

             

            Regards,

            Om

            • 3. Re: MQM 6: cannot connect to database
              Attila Polinger

              Hi Om,

               

              thank you for your exthaustive response. I got the previous information from a third party making the actual troubleshooting.

              they might or might not fulfill al the steps in your description on the first run, though, thus resulting in the issue.

               

              Thank you again.

               

              Attila