7 Replies Latest reply on May 14, 2010 8:02 PM by yusoff

    Question re EPO 4.5 on vmware esx3.5

      Our new EPO 4.5 server is running on vmware 3.5.

      As part of some tests I wanted to clone the server to use on a different domain.

       

      Having cloned the machine I switched it over to the test network and booted up.

      When I try to open the epo console I get a load of errors as follows: Seee atatched image

       

      Is this a result of cloning the server or adding it to a new domain? - the server name and ip stay the same.

       

      Thank you

      Andrew

        • 1. Re: Question re EPO 4.5 on vmware esx3.5
          Reiner

          Hi ajf_2009 ,

           

          ePO cannot get to your SQL database (the last lines indicate what is happening) . Where is the SQL database located?

           

          Reiner

          • 2. Re: Question re EPO 4.5 on vmware esx3.5

            It is on the local server, so should have been in the clone.

            I saw that but I thought it might have been a permissions issue related to the new domain name.

            • 3. Re: Question re EPO 4.5 on vmware esx3.5
              Reiner

              Hi ajf_2009 ,

               

              Open the config page ( https://servername:port/core/config-auth) where servername and port reflect your settings  and re enter the correct credentials. Then click on test connection, then appy and restart the services.

               

              Reiner

               

               

              Message was edited by: Reiner Herbst on 12/18/09 5:18:48 AM CST
              1 of 1 people found this helpful
              • 4. Re: Question re EPO 4.5 on vmware esx3.5

                Thank you.

                That at least got me in the right direction. I think the cloning had messed up though as I couldn't even authenticate locally to the epo console to get to that page!

                I eventually did another clone and edited the page successfully.

                All up and running on the test domain.

                 

                Thanks again

                Andrew Farmer.

                • 5. Re: Question re EPO 4.5 on vmware esx3.5

                  Hello All

                   

                  I have been searching through the Mcafee forum and KB for a day now and so far this thread is the closest I could find to my problem.  My current environment is the following.

                   

                  VMware esx3.5 Guest: Windows 2008

                  Mcafee ePO 4.5

                  SQL 2008 Express SP2 / instance name MSSQLSERVER

                   

                  At the time of install I selected use system account to run the DB server and enabled Windows Authentication.  The install is also synced with my AD.  I have just completed the rollout of this server about a week ago and had all my agents up to date and reporting correctly.  Yesterday I wanted to login to verify everything is still working properly and can no longer login to the admin console.

                   

                  When I go to login to the admin console I get the following that you can see in the screencap.

                  Picture 11.jpg

                   

                   

                  I have tried to access the core/config page and there I see this regardless I am running the page from localhost or else where.  One thing to note, do to the layout of the install I am doing all configuration / installation over RDP and the server is remote to me, I have no access to the VMware console due to security measures.  I am however accessing the server using the RDP switch /admin.  ( /console has been deprecated in 2008 for whatever reason.)

                   

                  Picture 12.jpg

                  and when I try the /core/config-auth page I see this

                   

                  Picture 13.jpg

                  I have also verified the following:

                  SQL ports are static and the same in both the db.properties file and the SQL server configuration.  TCP/IP is an enabled protocol with named pipes second in the list under the SQL network config applet.

                  The DB name and server name are both present in the db.properties file and the servers name has not recently changed.  One thing to note the instance name in the db.properties file is and was blank when I first checked it.  I assume this is because I'm using the default instance however I have taken a copy of the file and entered the instance name in both upper and lower cases and cycled sql and the three main Mcafee services each time with no effect.

                   

                  I have also created user and system DSN connections via the ODBC utility and varified that I can connect to the DB with my Windows account.

                   

                  Also client machines continue to download updates from the ePO server so I at least know the server is functioning at some level but of course cannot verify my threat level / Dat info etc...

                   

                  Now these errors are the same for both remote and local connections. Can anyone tell me what else I can try to resolve this error before I do a full reinstall.  What can cause it to happen from one day to the next so if I need to reinstall I can avoid this in the future. With thanks,

                   

                  Regards,

                   

                  Chris

                  • 6. Re: Question re EPO 4.5 on vmware esx3.5
                    GWIRT

                    Try testing with a SQL account in the db.properties file to see if you get anything else. I would also make sure Windows Firewall is disabled on the SQL server and the ePO server.

                    • 7. Re: Question re EPO 4.5 on vmware esx3.5

                      I am on EPO 4.5 which run on ESX 3.5. I have an issue with ESX 3.5 to ESX 4.0 migration. After migrating successfully, the EPO will keep reinstalling onthe side eventhough i can login successfully to the webbase console and see all clients. I tried again with EPO services shutdown but problem return upon enabling it after migrating. I tick on the install VMWARE Tools during migratig.

                       

                      Any other suggestions other then reinstalling EPO on a new VM?