5 Replies Latest reply on Dec 16, 2009 9:18 AM by krmason

    DAT check -in error  (--2147467259)

    krmason

      Hi,

       

      We are getting this error when we try to manually check in the latest DAT file, 5832.  We are currently sitting at 5826.  the process works all the way to the save page, then when we click on SAVE, we get this error.

       

      I have tried to delete the old DAT our of the repository but when the screen refreshes, it is still there.  I also noticed that my DAT directory, which was full, is suddenly empty.  I can import the DAT into my previous or evaluation folder, but it does not show up in EPO under the Master Repository tab.

       

      Has anyone else experienced this?

       

      Ken Mason

        • 1. Re: DAT check -in error  (--2147467259)
          jstanley

          What version of EPO?

           

          Do you get an error when trying to check in a different package (such as an agent package or a patch for VSE)?

           

          What is exact name of the file you are attempting to check in?

           

          You may need to rebuild your master repository.

          • 2. Re: DAT check -in error  (--2147467259)
            krmason

            It is EPO 4.5 and I have no problem adding other packages to the repository.  It just seems like the DAT files are stuck in never never land and I cannot upgrade them, or delete the existing ones.  the file's name is epo5832dat.zip

            • 3. Re: DAT check -in error  (--2147467259)

              Krmason,

               

              Take a look at the epoapsrv.log in the following directory. <install path>\mcafee\epolicy orchestrator\db\logs. It may show the error or more details on why its failing. You may see something similar to the following log excerpt.

               

              I     #1668    SIM_InetMgr    Download file datinstall.mcs failed in session 1, nainet ret=0
              X    #1668    DAL    CConxIndex: Current used conx=1
              X    #1668    DAL    ~CConxIndex: Current used conx=0
              X    #1668    DAL    CConxIndex: Current used conx=1
              X    #1668    DAL    ~CConxIndex: Current used conx=0
              e    #1668    SiteMgr    CheckInMirrorPackage: Download file datinstall.mcs from site McAfeeFtp::Current\VSCANDAT1000\DAT\0000 failed, hr=-2147467259

               

              The link below will instruct you on rebuilding the master repository. This could resolve the problem as well.

               

              https://kc.mcafee.com/corporate/index?page=content&id=KB53736&actp=search&search id=1260897128739

               

              Hope this help.

              William

              • 4. Re: DAT check -in error  (--2147467259)
                jstanley

                My apologies I missed where you had said that you could not delete the existing DAT package from the repository. This is going to be a problem because if you cannot delete the existing DAT package then you won't be able to check a new one in (because EPO must remove the existing DAT package first and then replace it with the new one). In all likelyhood the catalog.z file for the master repository is corrupt so you will need to rebuild the master repository.

                • 5. Re: DAT check -in error  (--2147467259)
                  krmason

                  Thanks,

                   

                  Rebuilding the repositiry worked.

                   

                  Ken Mason