1 2 Previous Next 12 Replies Latest reply on Apr 28, 2010 3:40 PM by dwhaley

    Problems with On Demand Scan

      Hi All,

       

      I'm having trouble getting On Demand scan to run on my network client machines (XP, Vista and 7). I'm running Windows Server 2008, ePO 4.5 and VSE 8.7. I successfully deployed the agent and VSE to all client machines, and the updates are getting done on all machines, but the scheduled scan is not starting. The scan log is showing an authentication failed message.

       

      I disabled the firewall on one machine and was able to get the scan to run via a client task from ePO (also able to ping the machine with the firewall off). I checked the firewall settings, and Mcafee Framework is in the exception list. I even tried adding On Demand Scan with no luck.

       

      Any advice on where to look next is greatly appreciated.

        • 1. Re: Problems with On Demand Scan
          GWIRT

          moving to VSE community.

          • 2. Re: Problems with On Demand Scan

            Have you tried specifying the credentials the scan runs under? In the task this is under the task tab.

            • 3. Re: Problems with On Demand Scan

              Hi,

               

              is VSE 8.7 patch 2 installed? What's CMA version? What's VSE 8.7 extension version in EPO?

               

              Cheers

              Davide

              • 4. Re: Problems with On Demand Scan

                I tried specifying the user credentials in the task but that didn't help.

                 

                As for versions, VSE = 8.7.0.570. Does this include patch 2, or is that a separate d/l?

                I didn't originally d/l the CMA separately as it didn't specify a requirement for that with VSE 8.7. Earlier today I downloaded it and deployed it to a test machine. No joy.

                 

                I also deployed Agent 4.5 (was running 4.0) and no luck there either.

                 

                It's frustrating that most tasks run fine, but I can't ping any machines and the scan fails with the firewall on. I can ping the server with the firewall on, so I'm thinking it must be a local client issue.

                 

                Thanks for the replies so far.

                 

                 

                Message was edited by: dwhaley on 12/10/09 12:22:48 PM CST
                • 5. Re: Problems with On Demand Scan

                  With regard to VSE 8.7i, the latest Patch for VSE is "Patch 2 REPOST", however, it is necessary to use the NAP file supplied with the earlier VSE "Patch 2" version.

                   

                  Cheers

                  • 6. Re: Problems with On Demand Scan

                    I'm unclear on how to go about using the NAP file from the earlier release.

                     

                    I tried scheduling a scan locally on a test machine via the Virusscan Console (instead of using ePO) and I got the same results. I can start a scan manually (scan now). Just can't set up a scheduled scan.

                     

                     

                    • 7. Re: Problems with On Demand Scan

                      You would only use the .NAP files for EPO 3.6x. Actually, according to the technote for VSE Patch 2 repost and problems with the NAP files, the problem with older version of Extensions posted only applies to v3.6x versions of EPO. https://kc.mcafee.com/corporate/index?page=content&id=KB67312

                       

                      But here's how you would install the latest extensions from the VSE 8.7 Patch 2 download:

                       

                      Locate the VSE Patch 2 install (Not the Patch 2 repost of VSE 8.7i). It should be available either throught Mysupport portal, or the downloads section with your grant number.

                       

                      In the zip file, you should find the EPO 4 extensions in 2 zip files called VirusScan8700.zip and VirusScanReports.zip.

                       

                      From the Readme for the Patch 2 (same information should be available from the EPO help)

                       

                      Installation steps via ePolicy Orchestrator 4.x

                      1. On the computer where the ePolicy Orchestrator 4.x console resides, place the Patch archive VSE87P2.zip in a temporary folder on your hard drive.
                      2. <removed stuff to ignore>
                      3. <removed stuff to ignore>
                      4. From the top menu of the ePolicy Orchestrator console, click "Configuration."
                      5. From the menu tabs, click Extensions, then click Install Extensions in the lower left of the window.
                      6. Click Browse and locate the VIRUSCAN8700.zip extension update from the temporary folder created in Step 1.
                      7. Click OK to begin the extension update.
                      8. Repeat the checkin process for the VIRUSCANREPORTS.zip reports extension
                        NOTE: Once the extensions are updated, the version can be verified in the ePolicy Orchestrator Extensions list (see About this release for version information).

                       

                       

                      on 11/12/09 18:52:40 GMT
                      • 8. Re: Problems with On Demand Scan

                        So the issue with the older files in the Repost patch only effect ePO 3.x, correct?

                         

                        I would install the newer version of the files from the older patch since I don't guess it would hurt anything, but I can't find it. My grant download page only has 1 file, the repost patch. I can't find it anywhere in the mysupport pages.

                         

                        Also, I looked at the current extensions that were installed and there were some in there for VSE8.5. Could that be causing a conflict of some sort? Is it safe to remove them?

                         

                        Thanks again for all the help.

                        • 9. Re: Problems with On Demand Scan

                          From my understanding, yes only 3.X is affected.

                           

                          Patch 2 is on the Mysupport site, you need to log in, select "Download Software Updates", then sort the updates by date. It should be on the first page as it's pretty recent.

                           

                          8.5 can happily co-exist with 8.7, so that shouldn't be a concern.

                          1 2 Previous Next