1 2 3 Previous Next 229 Replies Latest reply on Jun 1, 2010 5:25 AM by Peter M

    Updated "Not Protected" thread

    Peacekeeper

      Ok summarised all "things" to check for and closed the other threads dealing with this issue. The Not protected issue has been with us for ages firstly it was a System Guard disabled issue which was fixed in 9:15 or so now it affects other areas as well. The big issue is it only affects some users the majority are not affected so we need to look at what can cause this issue. Below is a summary of causes and some workarounds. In the follow post I will be placing a file to run that could help alleviate this issue till Mcafee fixes it permanently. Note I will post the files in a day or so plus instructions who should use it.

       

      Things to check if you get the "not protected" red bar issue

      Warning be wary of using Registry cleaners they can cause more issues than they fix.

       

      1. Try to clean up mcafee by uninstalling and reinstalling the programs

      http://service.mcafee.com/FAQDocument.aspx?lc=1033&id=TS100507

      Download and run the preinstall tool before reinstalling Mcafee

      http://download.mcafee.com/products/licensed/cust_support_patches/McPreInstall.e xe

      Reboot the PC

       

      2. Run the MVT program and see if it can fix Mcafee

      http://service.mcafee.com/TechSupportHome.aspx?lc=1033&sg=TS

       

      3. McAfee relies heavily on a working and up to date Internet Explorer. Go to IE Tools/Internet Options/Advanced and click "Reset", OK any prompts and click Apply and OK. Close and reopen IE, go to Tools/Manage Add-ons and re-enable all the add-ons.
      (This is assuming IE7 or 8 which you should have). Whether or not you use IE this still applies.

       

      4. Select Run and type in services.msc
      Scroll down to McAfee’s services and start any that are stopped excect scan.
      Once started check to see if problem is fixed give it a couple of seconds for service to start.
      THIS IS NOT A PERMANENT FIX TO PROBLEM.

       

      5. Ensure all your dates are correct IE the PC clock and time zone is set correctly

       

      6. It might be a corrupted Mcsubdb.dat file maybe find that file and the .bak version of it, are they not there try a reinstall after removal and copy the .bak file to another drive. When you get the issue boot into safe mode and close down mcafee and copy the .bak to the MSC folder as a .dat file. IE delete the Mcsubdb.dat old version first.

      File positions here but may vary depending on operating system

      Corrupted McSubDb.Dat file Location (Windows XP)
      C:\Documents and Settings\All Users\Application Data\McAfee\MSC
      (Windows Vita and Windows 7)C:\program data\McAfee\MSC.

      If there is no McSubDb.Dat file, then check whether you have McSubDb.bak file under C:\Documents and Settings\All Users\Application Data\McAfee\MSC\Cache
      (Windows Vista and Windows 7) C:\program data\McAfee\MSC\Cache and copy and rename it to the mcsubdb.dat area

       

      7. Ensure you do not have another AV installed . If you do remove it and mcafee via the relevant uninstall tools and reinstall mcafee (after a reboot). If you had 1 installed previously you would have needed to uninstall it completely (via its removal tool) before you installed Mcafee.

       

      8. Sometimes bad sectors can cause corruption so open a command prompt (with admin access) and run chkdsk c: /r ( will require a reboot)

       

      9.Type or copy the URL below into your web browser and press ENTER:

      http://us.mcafee.com/apps/agent/tools/ts/ts_getemail_new.asp

      This website will provide a list of the McAfee products installed on your computer and the account (email address) that used when installing these products.

       

       

       

      10.Your Pc might be infected soscan your PC with these free programs. This assumes you already tried scanning with virusscan in safe mode.

      Malwarebytes free version

      http://www.malwarebytes.org/

      and Superantispyware

      http://www.superantispyware.com/

      They are a good backup as all scanners are not 100% effective

       

      11. Try Technical support chat that will register the issue as an issue.

      http://service.mcafee.com/TechSupportHome.aspx?lc=1033&sg=TS

       

      Posters in all initial posts in this thread can you provide PC specs (cpu, brand if not generic, ram and OS along with service pack number)

       

       

       

       

       

       

       

      Message was edited by: Peacekeeper on 10/12/09 5:05:31 AM

       

       

      Message was edited by: Peacekeeper on 10/12/09 5:16:07 AM

       

       

      Message was edited by: Peacekeeper on 10/12/09 5:21:49 AM
        • 1. Re: Updated "Not Protected" thread
          Peacekeeper

          See Jason's post

          http://community.mcafee.com/message/103365#103365

           

           

           

           

           

          on 10/12/09 5:09:09 AM
          • 2. Re: Updated "Not Protected" thread

            I had posted (on the previous locked thread) certain steps that I planned to take (a controlled application of updates, disabling certain services, etc.).

            All was performed as per the prior post, and, at re-boot, up came the "Not Protected" message, which promply cleared!  After checking the Windows Event logs, and the status of the McAfee services, it seemed to be the "timing" issue I brought up earlier.

             

            Thanks to the "Redmond Rescue Rangers" (aka "Microsoft Update"), I was forced (aka "requested") to re-boot.  Following "carpe diem", I checked all McAfee services before, during and after the re-boot.  As the re-boot progressed, the familiar "Not Protected" message appeared, indicating that "real time scanning" was disabled.  Upon inspection, the Windows service "McAfee Real-time Scanner" (program "McSheld") was "starting".  The event logs showed:

             

            Information message for McAfee SiteAdvisor

             

            Image1.jpg

            (Provided as possible information for the SiteAdvisor problem threads, which may or not be related to the "Not Protected" problem(s))

             

            Next,

             

            Image2.jpg

            Followed by:

             

            Image3.jpg

             

            This FAILURE was followed by:

             

            Image4.jpg

             

            And all was once again well.

             

            Going back to a harder failure, the same items appeared, and the reason may be the Service's "Recovery" options:

             

            Image5.jpg

            After the third FAILURE, no recovery action is taken.

             

            It seems that the failure to respond in 90000 ms (a not-unreasonable interval) leads to a cascade of failure/recoveries.  I am curious if the 90000ms (90 seconds) is a hard and fast number, or modified by the processor used and/or Windows version in operation.

             

            I hope this assists in resolution of this problem.  The intermittent nature of the "Not Protected" message(s) makes for difficult problem determination.

            • 3. Re: Updated "Not Protected" thread

              Interestingly (or not), up until yesterday, the messge I was seeing when it went rogue (Not Protected) was a whole slew of things, including Real Time Scanning..

               

              Yesterday, the two times it did it, it was just Systems Guards, and not the other things

               

              Also, is there a list of other party SW that McA does't play well with ????

               

              When you say "other AV" products, would that include SpySweeper for instance ?

               

              Peacekeeper's original post may have an extra ")" at the end of this link:

               

              http://download.mcafee.com/products/licensed/cust_support_patches/McPreInstall.e xe)

               

               

              Message was edited by: saty on 12/9/09 9:33:25 AM CST
              • 4. Re: Updated "Not Protected" thread

                I am not surprised at the "System Guards" part of this problem.  The Windows service "McAfee SystemGuards" is set up somewhat differently from the other services.

                 

                Image11.jpg

                Note that the "Startup type" is "Manual", and it must be started by another task (or a person!) at several times: at boot, during maintenance and during recovery.  I omitted a disturbing finding in my earlier post:  McAfee SystemGuards status is "Disabled" during the daily update process.

                 

                When I set the "Startup type" to "Automatic", NO problems occurred at re-boot (9 re-boots)!  However, subsequent daily maintenance reverted the startup type to "Manual", and, sure enough, the next re-boot exhibited the "Not Protected" message, with (drum roll .....) "System Guards disabled".

                 

                I am aware that the SystemGuards service is "supposed to be" "Manual".  If a program stops an automatic start service, Windows recovery may become temporarily confused and attempt recovery restart.  To avoid this, McAfee maintenance should 1) alter the startup type to "Manual", 2) stop the service (if such is necessary), 3) perform any maintenance/update actions, 4) re-start the service and 5) alter the startup type to "Automatic".

                 

                :::: possible "rant on" :::::

                I expect that different views might be held on this problem, but one thing is certain:  it continues, now seems to be getting more prevalent (or the users more vocal), and little corrective information or solutions have been forthcoming.  The "usual" recovery actions (uninstall, cleanups, re-install), anti-malware, disk checks and the like can apply in isolated occurences.  In such a more frequent manifestation, the problem(s) are unlikely to start from pandemic disk problems or simultaneous installed program corruption(s).  While there is malware that can and does target McAfee vulnerabilities, the reliable tools (such as Malwarebytes) have turned up nothing.

                ::::: possible "rant off" :::::

                • 5. Re: Updated "Not Protected" thread

                  Here is the file that Peacekeeper was talking about.

                   

                  This needs to be run as Administrator from the command prompt.

                   

                  There is also an undo option, which you run like this;    mcshieldaws.exe /u

                   

                   

                  If you use this, please post back with your results.

                   

                  Thanks!

                   

                   

                  Message was edited by: Brookz on 09/12/09 11:35:07 EST AM
                  • 6. Re: Updated "Not Protected" thread

                    Brookz wrote:

                     

                    "This needs to be run as Administrator from the command prompt."

                     

                    Just verifying:  run actually logged in as "Administrator", or can a user with full administrator priveliges perform this function (from the command prompt) ?

                    • 7. Re: Updated "Not Protected" thread

                      With admin rights in vista\7, so right click command prompt, run as administrator.

                      • 8. Re: Updated "Not Protected" thread

                        Tried reinstalling without success...same error within hours.

                         

                        I take it a reintall (follow complete removal) will address any corrupted .dat file?

                         

                        I am down to contacting support!!  Great!! :-(

                        • 9. Re: Updated "Not Protected" thread
                          Peacekeeper

                          Any1 try the file jason posted above?

                          1 2 3 Previous Next