9 Replies Latest reply: Dec 17, 2009 2:52 PM by bofh4321 RSS

    epo 4.5, agent 4.5, agent to server comm port

      Hi,

       

      I installed EPO 4.5 on a windows 2003 SP2 server.  This server already had IIS installed so ports 80 and 443 were in use.  When I installed EPO I changed the
      agent to server port to 8098 and the agent to server secure port to 8099.  I manually installed the Mcafee agent 4.5 on a XP SP3 PC and did a cmdagent /p to which I get

      C:\Program Files\McAfee\Common Framework>CmdAgent.exe /p

       

      Error:***Agent is not available to enforce policy.
      Error:***Failed to send command to McAfee Agent ***

       

      cmdagent /s says the agent service is now running.  However if I send events I get "agent failed to send events".

       

      So is the problem seems that the agent is trying to communicate with the EPO over port 80 and not getting a response.  How do I change the communication port on the client so the agent uses 8098 and 8099?

       

      Thanks,

        • 1. Re: epo 4.5, agent 4.5, agent to server comm port
          Sailendra Pamidi

          Hi,

            The port information is stored in sitelist.xml - if you changed the port numbers, you can copy the updated sitelist.xml from the ePO server and update the sitelist used by the agent from the command line.

           

          frminst /install=agent /siteinfo=C:\sitelist.xml
          • 2. Re: epo 4.5, agent 4.5, agent to server comm port

            I copied c:\program files\mcafee\epolicy orchestrator\db\sitelist.xml from the EPO server to my local c:\ drive.

            I then ran:

            frminst /install=agent /siteinfo=c:\SiteList.xml

            from q:\mcafee\ma450win\

            which is the folder holding the agent 4.5 which I downloaded with my grant number.

            When I run the above command I get:

            The specified sitelist is invalid.  McAfee Agent Setup will not continue.

            and setup aborts.

             

            What is wrong?

             

            Thanks,

            • 3. Re: epo 4.5, agent 4.5, agent to server comm port
              Sailendra Pamidi

              Sorry, forgot to add, you will need to copy two additional files srpubkey.bin and reqseckey.bin from the ePO master repository (...\<epo_installation_directory>\DB\Software\Current\EPOAGENT3000\Install\0409\)
              to the folder where you are running the frminst.exe command from. These two files need to be present for the command to work.

               

              Also refer to KB53874, which is related.

              • 4. Re: epo 4.5, agent 4.5, agent to server comm port

                I copied srpubkey.bin and reqseckey.bin from the EPO directory you specified into the MA450WIN folder, overwriting the existing files.  I have the sitelist.xml with the new port numbers on the c:\ drive.  I ran cmd, q:, cd \mcafee\ma450win\, frminst /install=agent /siteinfo=C:\sitelist.xml, and I still get

                The specified sitelist is invalid.  McAfee Agent Setup will not continue.

                What is wrong?

                 

                Thanks,

                • 5. Re: epo 4.5, agent 4.5, agent to server comm port
                  jstanley

                  Rebuild the agent package in the master repository so it has the correct sitelist then forceinstall it on a client:

                  1- Stop all 3 EPO services

                  2- Navigate to this directory: <EPO Install directory\DB\Software\Current\EPOAgent3000\install\0409\

                  3- Delete framepkg.exe and framework.z

                  4- Start all 3 EPO services

                  5- Wait a while for the framepkg.exe to get rebuild (sometimes it takes a few minutes)

                  6- Forceinstall that agent on a client and it should start communicating (framepkg.exe /install=agent /forceinstall)

                   

                  If that fixes it on one you should be able to push the agent from EPO with the "forceinstall" option selected to get the rest of the clients communicating.

                   

                  If your still having a problem then you may want to check this log file and see if the message at the bottom is "The ePolicy Orchestrator server has stopped.":

                  <EPO Install Directory>\DB\Logs\server.log

                  • 6. Re: epo 4.5, agent 4.5, agent to server comm port

                    That gets me agent 4.0 on the PC.  Which is a step in the right direction.  How do I get 4.5 installed?

                     

                    Thanks,

                    • 7. Re: epo 4.5, agent 4.5, agent to server comm port
                      JoeBidgood

                      Assuming that the newly-installed agent is communicating with the server correctly, all you need to do now is to check in the MA 4.5 package and then schedule a deployment task to install it. See "Using the Product Deployment task to deploy products to managed systems" in the ePO 4.5 Product Guide for more info.

                       

                      Regards -

                       

                      Joe

                      • 8. Re: epo 4.5, agent 4.5, agent to server comm port
                        jstanley

                        If you want to test the 4.5 agent out on a few machines prior to pushing it out to your clients then check it into the evaluation branch and manually install it on a few. Here are some steps:

                         

                        First make sure you can check packages into a branch other than current:

                        1- Logon to EPO

                        2- Navigate to Server Settings

                        3- Select Repository Packages and click edit

                        4- Select Yes in the radial selection here (Allow package check-in for any repository branch)

                        5- Click Save

                         

                        Then check MA 4.5 into the evaluation branch:

                        1- Logon to EPO

                        2- Check the MA 4.5 extension in (it is backward compatible with MA 4.0)

                        3- Check the MA 4.5 install package into the evaluation branch of the repository (option will be available during the checkin wizard)

                         

                        Then grab a copy of the framepkg.exe from the evaluation branch for manual install. The install package should be here:

                        <EPO install directory\DB\Software\Evaluation\EPOAGENT3000\Install\0409\framepkg.exe

                         

                        I hope that helps!

                        • 9. Re: epo 4.5, agent 4.5, agent to server comm port

                          Yes.  The information helped.  I now have EPO 4.5 working.  The clients are getting patch 2 for 8.7 and the 4.5 agent.  They even get their dat updates from EPO.

                           

                          Thanks,