5 Replies Latest reply on Apr 19, 2010 2:07 PM by April Jacobs

    ePO 4.5 extensions problem

      Hi all,

       

      After having talked a lot to the support about my issue without receiving a non-standard answer, I would like to discuss my problem with you - probably to hear if one of you experienced a similar issue or at least to share my problem with you.

       

      I have several ePO 4.5 servers running. During the check-in of an extension (for SAE+) the server crashed (memory leak somewhere, machine was running since a long time even under load and was robust until that date) and had to be rebooted manually.

       

      The machine came back normally, but when I wanted to log into the ePO console, I was welcomed with an error message, telling me that the extensions for "Rogue System Detection" and the extension for "ePO Migration" couldn't be started. Besides that, everything works like expected.

      I found out that both extensions depend on the extension "Notification". The last one was installed as well, but not in the "running" state.

       

      I'm now assuming that I could repair the system in the following way:

      - uninstall "Rogue System Detection" extension,

      - uninstall "ePO Migration" extension,

      - uninstall "Notification" extension

       

      - install "Notification" extension,

      - install "ePO Migration" extension,

      - install "Rogue System Detection" extension

       

      I'm just not sure what the "ePO Migration" extension is doing and what happens if I uninstall and reinstall it.

      The last thing I want to experience is a server that is unable to talk to several thousand machines or policies that are rendered useless and pushed to the clients.

       

      Therefore I am asking you, if you ever encountered something similar and how you resolved it. There is probably a different solution, like getting this "Notification" extension repaired or run in a different way. I just can't believe the sole option the support proposed (to restore a backup of the server).

       

       

      All your ideas are welcome.

       

      Best regards,

      r.

        • 1. Re: ePO 4.5 extensions problem
          JeffGerard

          The ePO MIgration extension does not appear to be required by anything else so chances of it causing problems are likely slim to none.

           

          However, that being said, I would be sure to do a DB backup before doing this and stop the ePO server service so that clients are unable to connect to it. Once convinced all is good, restart the server service.

          • 2. Re: ePO 4.5 extensions problem

            Hi,

             

            Did you find a solution to your problem because I've exactly the same one and Mcafee support cannot help at the moment. I've even tried to restore database as they told me but it didn't solve the problem.

             

            Thanks for your aswer.

             

            Francois.

             

             

            Ce message a été modifié par: pantxoa on 08/04/10 19:03:30 CDT
            • 3. Re: ePO 4.5 extensions problem

              Hello,

               

              Sorry for not replying to this thread earlier.

               

              I applied the procedure highlighted in the initial post and it solved my problems.

               

              And I don't understand why McAfee support is not giving proper advise how to solve problems.

              I found the advise they gave ridiculous. The Engineers at McAfee design the software in such a modular way

              that it is possible to uninstall and re-install almost all components, but support has nothing better to propose than

              restoring the database rather than using the designed mechanisms to solve such an issue.

               

              Hope this helps you,

              r.

              • 4. Re: ePO 4.5 extensions problem

                Thanks for your answer.

                I've already tried to remove rsd and epomigration extensions. It worked but when I tried to reinstall them it was not possible I got an error message. I took the zip modules in the installer folder so I don't understand why I couldn't reinstall those modules.

                I will try to do it once again with also notification extension and see what happens because the last E-mail I received from the support is to do the recovery procedure of ePo console which is quite hard.

                • 5. Re: ePO 4.5 extensions problem

                  I'm not a product expert but I've moved this thread to our ePO area. Hopefully someone can help you soon.