1 2 Previous Next 14 Replies Latest reply on Jan 19, 2010 3:10 PM by SafeBoot

    intended use of sbadmcl?

      (I'm guessing the answer here is that I'm not using it in it's intended fashion)

       

      Can the local machine id ever be changed (or slightly more useful, can the associated ID or a machine on the server be changed)?

       

       

      Im in the works of tracking down what is going wrong with some Windows7 machines where they don't appear to get created properly (or something)

      Running IsCurrentlyActive may result in: ExistsInDB:true |  IsCurrentlyActive:false

       

      if I run GetLocalMachineName with IDOnly:true, ...it will return the ID which i find is not the ID listed for the machine on the server. Hence, i believe to be part of the issue. 

       

      I know I'm doing something wrong, but I'm not entirely sure of the appropriate use that should address this situation.

       

       

      I don't believe the scripting tool has a means to say "You client..are this server object....now sync" (or does it?)

       

      using client: 5.2.2.4 of the AbAdmCli.dll (if thats of any usefulness)

        • 1. Re: intended use of sbadmcl?

          no, there's no api to change the ID of a machine, but you are right - it CAN be changed.

           

          just export a machine object, delete it, then re-import it - it will get a new ID. The next time that machine syncs it will first look up it's current ID (which won't work), then it will look up its network name - if it finds a matching object and the keys are all good, it will pick up that new ID.

           

          to confirm ID's the best place is to look at the recovery page in the pre-boot - it will give you the machines current ID and database ID.

          1 of 1 people found this helpful
          • 2. Re: intended use of sbadmcl?

            I'll give that a shot, thanks Simon.

            • 3. Re: intended use of sbadmcl?

              I thought I had this issue resolved, however i have a test client (XP) that reports its ID as "00000001" (in the event that has some internal meaning)

              The machine name is in the DB, however the ID is not matched up properly.

               

              Could you clarify

              "..and the keys are all good.."
              I'm guessing this is the problem.
              I've ensured that this name doesn't appear in any active groups or the Deleted Items groups.

              • 4. Re: intended use of sbadmcl?

                sounds like it's either the first machine ever installed, or was an offline install?

                 

                It can't possibly be syncing well if there is no database object for it.

                • 5. Re: intended use of sbadmcl?

                  The machine isn't syncing.

                   

                  In further review I noticed the SCM.ini and SDMCFG.INI are slightly different than my previous test machines (the guy who does the deployments changed some things around).

                  The SDMCFG.ini refers to a local DB (SBXFERDB.dll as a local DB) for the referenced item within SCM.ini.

                   

                  SCM.ini on the new one contains (under [install])

                  DatabaseID=2

                   

                  Where the previous ones had nothing listed under [install] for DatabaseId

                   

                   

                  Checking the DatabaseID's under pre-boot recovery confirms that these are not the same.

                   

                   

                  Is there a way to change the DB a machine is pointed to post install?

                  • 6. Re: intended use of sbadmcl?

                    looks like he made an offline install set rather than an online install set, so treat the machine like that (import the sdb file back to the master).

                     

                    best to also ask him why he made such a dramatic change to your deployment strategy - the two are VERY different ways of working.

                    • 7. Re: intended use of sbadmcl?

                      I believe this deployment was not intended to be local, rather it was an oversight.

                      • 8. Re: intended use of sbadmcl?

                        My apologies for poking an older post, however I'm running into an issue with another machine that is fairly related.

                         

                        GetLocalmachine generates: an object ID of 00000aa0

                         

                        command line "hostname" returns the same machine name as seen in an object in the DB (with a different ID).

                         

                        A search for a machine of ObjectID "00000aa0" returns no results in both the Endpoint Encryption Machine Groups (under the Machines tab) and Deleted Items (under the System tab)

                         

                         

                        When I run the sync on the client I receive a message "Object not found". I've tried the export, delete (w/ permanently delete option selected). import approach...with no success.

                         

                        I've been pouring through the Scripting tool manual to see what commands I might try to help troubleshoot this situation (with no success).

                         

                        Any additional tricks to try?

                        • 9. Re: intended use of sbadmcl?

                          What did you try to delete permanently?

                           

                          What Machine ID is being reported in pre-boot, when you empty user name and click on Cancel, Options, Machine Recovery?

                          1 2 Previous Next