6 Replies Latest reply on Nov 20, 2009 2:29 AM by kthomas

    CMA 3.6.0.569 -> Agent 4.5.1270 Problem

      Hi,

      I've upgraded from ePO 4.0 P5 to ePO 4.5.

       

      About 175 clients so far have automatically updated to the 4.5 agent after it was checked in to the repository but about 10% of them are giving issues.

      Specifically the agent is installing but users are then getting these error messages which they cancel but then reappear regularly.

       

      Error 1706. No valid source could be found for product McAfee Agent. The Windows Installer cannot continue.

      The feature you are trying to use is on a network resource that is unavailable.

      MFEagent.msi

      c:\documents and settings\all users\application data\mcafee\common framework

       

      MFEAgent.msi IS present in the folder

       

      I checked the uninstall registry entry for the agent which other posts say may be significant.

      It is pointing to C:\WINDOWS\TEMP\mfeBF4.tmp\ as install source.

       

      Any thoughts?

       

      Thanks

      Neill

        • 1. Re: CMA 3.6.0.569 -> Agent 4.5.1270 Problem
          JoeBidgood

          Hi Neill...

           

          This sounds very much like the issue addressed in KB66758 (hopefully that link will work.)

           

          Regards -

           

          Joe

          • 2. Re: CMA 3.6.0.569 -> Agent 4.5.1270 Problem

            Hi Joe,

             

            That did indeed seem to be the answer.

            Bypass traverse checking was set only for administrators for all systems.

             

            Although why it only affected 10% of the systems that got upgraded I still can't work out.

             

            Also sucks that repeated searches in knowledge base didn't turn up that article. :-(

             

            Thanks

            Neill

            • 3. Re: CMA 3.6.0.569 -> Agent 4.5.1270 Problem
              JoeBidgood

              Hi Neill...

               

              Glad it worked    Sorry you couldn't find it in the knowledgebase, though. Can I confirm that the error 1706 message you mention is from the application event log? I'll get the article updated so that it should hopefully be easier to find...

               

              Regards -

               

              Joe

              • 4. Re: CMA 3.6.0.569 -> Agent 4.5.1270 Problem

                Correct.

                Various errors in event log actually.

                11706

                Product: McAfee Agent -- Error 1706.No valid source could be found for product McAfee Agent. The Windows Installer cannot continue.

                1001

                Detection of product '{B639A4DE-A375-47D3-89C3-DDCF98D992F7}', feature 'Main' failed during request for component '{E9CC57F0-E5EA-41B6-B449-2C67AD7A429B}'

                1004

                Detection of product '{B639A4DE-A375-47D3-89C3-DDCF98D992F7}', feature 'Main', component '{244CC183-BB6D-44FE-81ED-BAA49F33B253}' failed. The resource 'C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\agentDefault.ini' does not exist.

                 

                Also saw this one on a couple of them

                Product: McAfee Agent -- Error 2318.File does not exist: C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\LastProp.xml.

                 

                Thanks

                Neill

                • 5. Re: CMA 3.6.0.569 -> Agent 4.5.1270 Problem
                  JoeBidgood

                  That's great, thanks. I'll get the article updated accordingly - hopefully it should be easier to find in future

                   

                  Regards -

                   

                  Joe

                  • 6. Re: CMA 3.6.0.569 -> Agent 4.5.1270 Problem
                    kthomas

                    Just to let everyone know the task of updating the article has been completed. The article has been updated with more symptoms obtained from this thread and confirmed from other sources. The key edits to the KB now reference the additional Application Event errors listed below. Thank you to all those who participated in providing additional information to resolve this issue.

                     

                    Event ID: 1004
                    Event ID: 1001
                    Event ID: 11706

                     

                    Go to the McAfee ServicePortal (http://mysupport.mcafee.com) and search for KnowledgeBase article

                     

                         KB66758– McAfee Agent 4.0/4.5 MSI pop-up displays when restricted users log on to computer


                    NOTE:You can access the KnowledgeBase anonymously, but some articles are available only to logged in users

                     

                    All the best,

                     

                    Kevin

                     

                    Knowledge Analyst (Global Online Services)
                    Web: http://mysupport.mcafee.com

                     

                    http://mysupport.mcafee.com