1 2 Previous Next 12 Replies Latest reply: Nov 9, 2009 1:34 AM by looper RSS

    VirusScan Enterprise 8.5.0i AutoUpdate Problem

      Hello!

       

          We have VirusScan Enterprise 8.5.0i working in our enterprise. One of our Domain Controllers (WS2003) is not updating its DAT files because AutoUpdate is not working. I get a message into the VirusScan console showing that AutoUpdate has failed. The only info I get into the log file is:

       

      05/11/2009    17:45:33    XXXX\administrador    Iniciando tarea: AutoUpdate (Starting task: AutoUpdate)

       

      No errors, no more info....

       

      I tryed re-installing VirusScan without result. I forced one DAT file update using a SuperDAT exe getting it updated but AutoUpdate still remains broken. How can I mend AutoUpdate option of my VirusScan?

       

      Regards

        • 1. Re: VirusScan Enterprise 8.5.0i AutoUpdate Problem

          The agent log should give us more data. In the meantime, let's create a new update task in the VSE console and see how that goes. May just be the task is corrupted.

           

          Agent log located - c:\docs and settings\all users\app data\mcafee\commonframework\DB\agent_machinename.log

           

          Also, what agent version are you running?

           

          What patch level are you at with VSE 8.5?

           

          Has the system ever updated properly?

           

          If you switch the update task to update via ftp instead of http is it successful?

           

          Look for the task.ini associated with your update task and attach to thread:  c:\docs and settings\all users\app data\mcafee\commonframework\Task

          Open the txt files and locate the TaskType=update (that's the one we need to see) Also be sure to attach the agent log

          • 2. Re: VirusScan Enterprise 8.5.0i AutoUpdate Problem

            Hello!


            -Creating a new AutoUpdate task still fails


            -I have following entries into my agent.log

             

            ...

            ...

            20091105191801    I    #4412    FrmSvc    User SID is S-1-5-21-2092975734-2324585347-3546528387-500 and SessionID is 1
            20091105191801    I    #4412    Logging    StartReadingMessages (\\.\mailslot\VSECMA-{BC715240-E4B0-499D-9140-70CDBC3278E6}, 0x1c, 4)
            20091105191801    I    #4412    Logging    - using empty 2
            20091105191801    I    #4412    Updater    RunUpdateScript UPDATE
            20091105191801    I    #4412    Updater    Script SubSystem is not started correctly by framework service.
            20091105191801    I    #4412    Updater    OnDemand update failed to start
            20091105191803    I    #328    FrmSvc    User SID is S-1-5-21-2092975734-2324585347-3546528387-500 and SessionID is 1
            20091105191803    I    #4412    IPLock    readLock - providing read lock
            20091105191803    I    #4412    IPLock    readUnLock - unlocking the read lock successful

             

            -Where can i see agent version?


            -Complete version of VSE is 8.5.0.781


            -No problems on AutoUpdate until now


            -Task.ini content (newer one):

             

            [Task]
            TaskName={A14CD6FC-3BA8-4703-87BF-E3247CE382F5}
            Platforms=*
            TaskPriority=99
            SoftwareName=VIRUSCAN8600
            TaskID={A14CD6FC-3BA8-4703-87BF-E3247CE382F5}
            CreatorSoftwareID=VIRUSCAN8600
            TaskType=UPDATE
            TaskVersion=
            UserName=
            DomainName=
            Password=
            [Settings]
            StopAfterMinutes=0
            Enabled=1
            Duplicated=0
            DialupTriggerEnabled=0
            [Schedule]
            Type=0
            GMTTime=0
            RunIfMissed=1
            RunIfMissedDelayMins=5
            StartDateTime=20020903170000
            StopDateValid=0
            StopDateTime=00000000000000
            TaskRepeatable=0
            RepeatOption=0
            RepeatInterval=1
            UntilOption=0
            UntilTime=00000000000000
            UntilDuration=1
            RandomizationEnabled=1
            RandomizationWndMins=60
            EnableRunTaskOnceADay=0
            AtStartupDelayMinutes=5
            RepeatDays=1
            RepeatWeeks=1
            MaskDaysOfWeek=0
            MonthOption=0
            DayNumOfMonth=0
            WeekNumOfMonth=0
            DayOfWeek=0
            MaskMonthsOfYear=0
            IdleMinutes=0
            [VSE7_SchedulerSection]
            VSE7_UserName=
            VSE7_DomainName=

            • 3. Re: VirusScan Enterprise 8.5.0i AutoUpdate Problem

              Ok, it seems that the agent has been corrupted. You will need to do the following:

               

              Log into the product download site with your Grant #  https://secure.nai.com/apps/downloads/my_products/login.asp?region=us&segment=me dium

               

              Once logged in go locate the MA 4.0

              Under the MA 4.0 download the following package MA400P3Win.zip

              Extract the zip

              Locate the FramePkg_UPD.exe file and run that on the local system as follows

               

              Open the "Run" line

              Drag and drop the FramePkg_UPD.exe  into the "Run" line

              Use the following switch /install=updater

              Example: c:\FramePkg_UPD.exe /install=updater

               

              After the install is complete. reboot and try your update.

               

              Ron

              • 4. Re: VirusScan Enterprise 8.5.0i AutoUpdate Problem

                Perfect solution,

                 

                Done and now working ok again!

                 

                Thank you very much

                Regards

                • 5. Re: VirusScan Enterprise 8.5.0i AutoUpdate Problem

                  Excellent! Thanks for the feedback. Keep in mind if you are using EPO you will need to deploy a new agent to the system now. If not, you are good to go.

                   

                  Have a great weekend,

                  Ron

                  • 6. Re: VirusScan Enterprise 8.5.0i AutoUpdate Problem

                    What was what we updated then? I thought that I had installed a new version of the agent...

                    • 7. Re: VirusScan Enterprise 8.5.0i AutoUpdate Problem

                      We did but we used the standalone agent and not the managed agent. Are you using EPO?

                      • 9. Re: VirusScan Enterprise 8.5.0i AutoUpdate Problem

                        Sorry, maybe I should have asked this before. Go ahead and deploy a new agent to the system. Try to reproduce the issue. If the issue still does not take place then we are good. If the issue comes back then we will need to target the agent package in the EPO server as the issue and we can fix that with no problem.

                        1 2 Previous Next