4 Replies Latest reply on Sep 5, 2009 11:53 AM by bsohn

    McAfee Registry Bug Causes Problems

      Contrary to what I was told by two McAfee technicians in the last 2 days, I do not have a virus on my system. I am now back up and running and McAfee reports no problems.

      The root of the problem has been isolated to a McAfee registry problem that was interacting with System Mechanic 9 in Vista 64. The issue is caused by a registry key at HKEY_LOCAL_MACHINE\Software\McAfee which is a link to HKEY_LOCAL_MACHINE\Software\Wow6432Node\McAfee. When ANY utility attempts a registry compacting or a backup of registry files, the registry link will become broken.

      It would be most helpful if McAfee would resolve this issue.

      Thank you,
      -b
        • 1. do we have the same problem?
          I have the same configuration: Vista 64 + sytsem mechanic + Mcafee suite and everytime I defrag the registry Mcafee is screwed up, some services not available so I have to reinstall the whole thing:mad:
          Re-install is furthermore a pain in the neck .... download the whole program every time .... arggg:mad:
          I hope they find a solution.
          I'm seriously thinking to stop renewing my licence. I had a virus in the past Mcafee could not remove:(
          • 2. RE: do we have the same problem?
            Peter M
            Stop using registry cleaners/compactors or whatever. They are pretty well guaranteed to screw something up, in this case McAfee.

            They are waste of time and money.
            • 3. McAfee Registry Bug Causes Problems
              Unfortunately, it is McAfee that is messing things up this time.
              -b
              • 4. RE: McAfee Registry Bug Causes Problems
                Registry cleaners and registry defrag are some good pc overhauling techniques, but as you have discovered they cause severe problems with McAfee, than you should stop using them..I know after awhile windows becomes slow little bit and these defrag utilities bring it to life..But dude..u have to stop using them. I also faced same problem, well this thing happens with McAfee only. No Norton or Kaspersky issue i have seen by using these utilities..May be McAfee people will resolve this in McAfee 2010 product line up. McAfee 2010 products that are soon be releasing are really damn good in every case...