1 Reply Latest reply on Mar 22, 2009 5:24 AM by Peter M

    SecurityCenter 9.x ... no 9.3 version for Vista SP1 64bit?

      I have three PC's I use, all set up the same way (connectivity to the network, firewall setup, automatic software updates, etc etc).

      The one which runs XP SP3 (32bit) shows that SecurityCenter got updated to v9.3 last month or so, and so does the one that runs Vista SP1-32bit. However, my PC running Vista SP1-64 bit shows that it's still running SecurityCenter v9.0.

      I compared some of the available options under SecurityCenter 9.0 and 9.3, and indeed v9.3 added a couple of extra features (such as buffer overflow protection, etc). I tried a manual update of SecurityCenter on the Vista SP1-64bit unit (by clicking on the "update" link), but it just told me all my McAfee Total Protection 2009 products were up to date.

      What gives? I didn't think McAfee would be releasing diff't subrelease of SecurityCenter for 32bit vs. 64bit... or am I wrong?
        • 1. RE: SecurityCenter 9.x ... no 9.3 version for Vista SP1 64bit?
          Peter M
          It is intended for both x86 and x64, but the release of 9.3 is still going on. The servers are throttled back still as far as I know so it will eventually happen.

          The only way to hasten the process is to completely uninstall via the Control Panel, use the MCPR removal tool, reboot and reinstall from the online account but I can't guarantee that. I know it worked for me.

          I see that you are using Comcast and their servers, so we are told, are still not carrying version 9.0, let alone 9.3, a matter that would have to be taken up with them.

          If, however, you get your products from McAfee directly, then the above will apply, you'll get 9.3, hopefully soon.