1 2 Previous Next 15 Replies Latest reply on Jan 13, 2009 7:39 PM by stebie

    An error occurred while updating

      My PC (Dell running XP) recently needed to be fixed; it was overheating and needed dusting and a new graphics card. When I got it back I found that McAfee now won't update its files - I get the message "An error occurred while updating. Please reinstall these programs 3-user Mcafee Internet Security". It seems that the new file is detected, then it says its updating before stopping with this error message.

      I tried Virtual Technician which detected the out of date files and said it had fixed them but in fact I got the same error message again.

      Using the support search I found document TS100217 that suggests that the RunOnce key could be missing, but when I look at the registry this key seems to be there, showing as
      Default REG_SZ value not set

      Can you please help me to fix this? I will of course reinstall McAfee if necessary but I'm not clear whether this is really necessary and I'm finding the instructions for this very confusing too. I can see that other people have had similar problems and apologise if this is a repeat post - I guess the real question is do I have to reinstall the whole thing in order to solve this problem or is there any quicker way to fix it? I bought the software online from McAfee and my license doesn't expire until next September.

      Many thanks
        • 1. RE: An error occurred while updating
          hi,

          if you ran the MVT, by any chance did you get the session ID? if yes, please post it here...

          also, can you try this steps:

          - click Start, then Run
          - type in CMD
          - on the Command Prompt, type in "ping download.mcafee.com" (without the quotes)
          - please post here the results

          keep us updated...
          • 2. RE: An error occurred while updating
            Many thanks for getting back so fast - much appreciated.
            The ping looked fine - I would have expected this to work as the initial connection to update looks fine and when I hover over the icon it says it's checking for updates then updating, THEN stops with the error.
            I've just run MVT again - the session ID is 14208417.
            • 3. RE: An error occurred while updating
              hi,

              based on the session ID, the MVT did fixed the DAT files that were outdated.

              when you pinged download.mcafee.com, what is the IP address that it showed?

              can you please check the time/date/year/timezone of the computer if it is correct? also, try to check the Content Advisor (Start -> Control Panel -> Internet Options -> Content). It must show "Disable".

              keep us posted
              • 4. RE: An error occurred while updating
                Yes, I know that VT said it had 'fixed' the problem. Unfortunately what it actually does is to initiate the update but it doesn't check whether the update completes successfully - which it doesn't. I can run VT over and over again and it will continue to tell me that it has solved the problem - but it hasn't!

                The time and date are both correct and Content Advisor was already disabled.

                The ping IP address is 92.122.209.211

                Many thanks again.
                • 5. RE: An error occurred while updating
                  There might be no other way but to uninstall/reinstall your software. You can try and contact Tech Support Chat and see what they have to say.

                  if you decided to uninstall/reinstall it, try this:

                  - run the McAfee removal tool here.
                  - do a search of all McAfee files and folders (including hidden ones) and delete them
                  - reinstall your products from your account

                  hope it works
                  • 6. RE: An error occurred while updating
                    Thanks.

                    Anybody else wanna jump in with any bright ideas before I try a complete reinstall??
                    • 7. sorry to butt in
                      if you are considering other troubleshooting steps before uninstalling and reinstalling mcafee please download the file below... it's a program that tries to fix issues regarind updating through proxy...

                      http://download.mcafee.com/products/licensed/cust_support_patches/MSCPRXFIX.exe

                      after downloading the program run it... after it completes restart the computer... then try manually updating mcafee...

                      hope it helps...
                      • 8. I had similar problem solved
                        hi I had similar problem solved from a thread I found for Security Centre 8
                        http://forums.mcafeehelp.com/showthread.php?t=226249
                        I dont know if its relevant to you I am not very computer literate but symptoms sound similar and the advice given there worked for me. best wishes, gorf.
                        • 9. Having same issue
                          Saturday was the first day I received an error message trying to update the definition file. I eventually got it to update by delaying the download by 30 minutes. (When I was notified the update was available, I chose remind me in 30 minutes.) However, I cannot update Spamkiller now, which doesn't bother me as much since I don't use it.

                          I heard back from a tech this morning asking me to add two IP addresses and download.mcafee.com to my hosts file. When I tried pinging download.mcafee.com, I got "Destination host unreachable". I don't think adding them to my hosts file will work, and why it worked last night after waiting 30 minutes and not before has me baffled. McAfee recently upgraded my product to 9.0. I wonder if that's the reason. I really wish they left things alone and let me decide whether to upgrade or not.

                          I'm not uninstalling and reinstalling anything. If I have to uninstall McAfee, I will be reinstalling something else.

                          Joan

                          Forgot to mention that I ran Lavasoft's Ad-Aware SE and it found adware on my computer, which I removed and THEN I was able to update the definitions file.
                          1 2 Previous Next