2 Replies Latest reply on Oct 29, 2008 4:13 PM by Peter M

    2009 series (Virusscan Plus) resource hogging

      With McAfee 2008 and 2007, resources were usually used at startup and when updates were taking place. During regular internet use at most a few % of CPU (Windows XP), negligible.

      Not anymore. Although it's still true for most of the time, occasionally a significant % of my CPU is used by McAfee software, most notably mcupdmgr.exe (or something like that), sometimes different processes, and svchost.exe (!). Not related to any actual updating taking place. I did not put new security software on my computer.

      I'm not pleased with that. What's going on ? Some 'in the cloud' computing ? Or just pointless resource hogging ?

      Note: I have the SiteAdvisor uninstalled.
        • 1. McAfee hogging CPU usage
          Riddlez,

          Join the club -- we're still waiting on a functional answer to a related CPU usage problem.
          http://forums.mcafeehelp.com/showthread.php?t=224840

          I've been experiencing the issue for about a month. The only solution that proven even minimally effective so far has been to delete the offending file. In my case, it was mcsync.exe. Sure, I'm getting all sorts of "you need to update now" messages from the Security Center, but at least I'm able to use my computer until McAfee fixes this or I switch to another anti-virus program.
          • 2. RE: McAfee hogging CPU usage
            Peter M
            It could be just about anything causing something like that, but I can assure you that it isn't normal behaviour.

            It could be infection, check for spyware using the free version of this tool: http://www.superantispyware.com/superantispywarefreevspro.html

            It could be shortage of available memory or hard drive space. The minimum is stated as 128mb of RAM but we recommend 256mb or more as the bare minimum. HDD space should be at least 75mb free.

            It could be competing software, see this list: http://service.mcafee.com/FAQDocument.aspx?id=307274&lc=1033&partner=10005&type= TS

            It could be the practice of operating two of anything, firewalls, pop-up blockers etc.

            The installation could be corrupted in which case do the following:

            1. Uninstall all McAfee programs through "Add or Remove Programs" in Windows "Control Panel".

            2. Use the MCPR tool, see this article: How to remove supported McAfee consumer products using the McAfee Consumer Products Removal tool (MCPR.exe). This will remove all McAfee remnants from your computer. (you must have Windows Vista, XP or 2000 SP4 to use this tool)

            3. Launch Windows Explorer and delete all McAfee files in "Program Files" but especially in "C:\Document and Settings\<user>\Application Data" and "C:\Document and Settings\All Users\Application Data". You have to set Windows Explorer to show all hidden files and folders (Tools > Folder Options > View tab). Just delete the McAfee folders even if they are empty in all the "Application Data" folders. Can be more than one!
            In Vista: C:\Program Files, C:\ProgramData and C:\Users\yourname\AppData\Roaming

            4. Reboot and redownload/reinstall your McAfee products directly from your account at the McAfee web site, not from any CD that you may have.


            Or a combination of any of the above.

            Your best bet is to contact Technical Support who can escalate the case and even go into your machine if necessary.

            Link at top left of the page or in my signature.