3 Replies Latest reply on Mar 24, 2009 5:28 PM by Peter M

    9.3 Missing Firewall Options

      I want to connect to a remote desktop. I have searched the McAfee FAQ and believe I need to Allow Traffic on Port 3389 to do so. The problem is, I can not get to the firewall feature in my security center (the 9.3).

      I have searched help and found instructions, but it says to open McAfee and click on Internet & Network, but I do not see that option. I see only "Manage Network."

      I do not see firewall anywhere on the various menus. I did at one point - months ago. I was able to look at the firewall and choose the level of protection at that time. I do not know why that menu is no longer available to me - I'm thinking it disappeared when I updated to 9.3.
        • 1. RE: 9.3 Missing Firewall Options
          Peter M
          It would appear that somehow the firewall part of your protection got uninstalled or otherwise corrupted.

          I don't know what system you are using but in XP or Vista please enable Windows Firewall a.s.a.p. until all this is finished.

          1. Uninstall all McAfee programs through "Add or Remove Programs" in Windows "Control Panel".

          2. Use the MCPR tool, see this article: How to remove supported McAfee consumer products using the McAfee Consumer Products Removal tool (MCPR.exe). This will remove all McAfee remnants from your computer. (you must have Windows Vista, XP or 2000 SP4 to use this tool)

          3. Launch Windows Explorer and delete all McAfee files in "Program Files" but especially in "C:\Document and Settings\<user>\Application Data" and "C:\Document and Settings\All Users\Application Data". You have to set Windows Explorer to show all hidden files and folders (Tools > Folder Options > View tab). Just delete the McAfee folders even if they are empty in all the "Application Data" folders. Can be more than one!
          In Vista: C:\Program Files, C:\ProgramData and C:\Users\yourname\AppData\Roaming
          If you can't find these files don't worry. It just means that MCPR has done its job.

          4. Reboot and redownload/reinstall your McAfee products directly from your account at the McAfee web site.

          If you are McAfee direct customer, go to https://home.mcafee.com/Secure/Protected/Login.aspx and log in to download your McAfee products.

          If you received your McAfee products from your service provider, please use the list below to download your software.

          Comcast users should go to http://security.comcast.net/ and log in to download your software.

          DELL users should go to https://us.mcafee.com/root/login.asp?affid=105 and log in to download your software.

          Gateway users should go to https://us.mcafee.com/root/login.asp?affid=370 and log in to download your software.

          eMachines users should go to https://us.mcafee.com/root/login.asp?affid=365 and log in to download your software.

          MSN users should go to http://membercenter.msn.com/ and log in to download your software.

          AOL users should go to http://daol.aol.com/safetycenter and log in to download your software.
          • 2. Firewall restored!
            That was the problem. I followed your instructions, uninstalled everything McAfee and reinstalled it. When I opened it - Bam - there was the firewall protection. Plus, I got my remote desktop to work. Many, many thanks. I was so frustrated with McAfee help and not being able to contact anyone without paying, I was close to canceling my subscription. Now, I'm glad I didn't.
            Thanks again.
            • 3. RE: Firewall restored!
              Peter M
              Glad you're up and running now. Support is always available here and via Technical Support Chat free of charge.

              Moving this to the solved section.