8 Replies Latest reply on Aug 3, 2010 3:05 PM by martinigruppo

    McShield uses 99% of CPU

      Hello everybody,

      Sorry for my English that is not very good ! (I'm French ;))
      I search several forums and threads to find a solution to my problem

      During last month, I got very strange things with my Win XP SP3 computer with McAfee Viruscan Plus (up to date). My config is stable for at least 2 years. (plus or minus applications of course!)
      From time to time, and the first time I right clic in Windows Explorer, my computer froze for 1 to 2 minutes! :mad:
      From time to time I obtain two abnormal events :

      1. McAfee said "your computer is not protected" (Buffer overflow detection disabled and McShield disabled). :confused:
      2. McAfee blocked Buffer Overflow


      I scan for viruses - Nothing
      I scan for Rootkits - Nothing

      I tried to repair Win XP, with the CD
      When the reinstallation of files is done, the computer restart, and the full install process restart, again and again. Clearly, it loops! Win XP cannot start!

      Hopefully, I got a full Acronis Backup of my System disk, and I restore it, with the problems listed above of course :(

      I made more systematic approach.

      I start McAfee Virtual Technician that found eveything is OK

      Now, I describe a very reproductible sequence :

      • Cold start of Win XP,
      • wait for 2 minutes
      • Launch Task manager - everything OK
      • Launch Windows explorer - OK
      • Open one folder of my disk - OK
      • Right click on a file in a folder.
      • Windows Explorer hangs (no contextual menu)
      • In task manager, McShield uses 99% of CPU for 1min 30sec !
      • contextual menu appears, McShield uses 0% of CPU
      • few second after contextual menu, McAfee tells me: "your computer is not protected" (Buffer overflow detection disabled and McShield disabled).
      • I correct the problem


      After that explorer works as usual for some time

      I am loosing the latin I never learn!

      Thank you in advance for any help or idea
        • 1. Re: McShield uses 99% of CPU

          Up ????

           

          I think my problems appeared with the last version of Mcshield.exe on september 16th.

          Any Idea ?

          • 2. Re: McShield uses 99% of CPU

            Hi

            plz try this first...

            start a system restore to the last good known configuration.

            if it fails >

            run 'stinger1001624' (S.T.I.N.G.E.R551 ) or

            download KKiller from here:

            http://www.kaspersky.com/technews?id=203038750

            and follow the prompts.

            Install 'HijackThis' ( Trend Micro ), run a scan and copy/paste the log in your next reply.

            Sincere

            Raziel

             

             

            Nachricht geändert durch Raziel.van.Nosgoth on 11/5/09 7:13 AM

             

             

            Nachricht geändert durch Raziel.van.Nosgoth on 11/5/09 7:19 AM
            • 3. Re: McShield uses 99% of CPU

              You may also want to try McAfee's free scan service which can be located here. http://home.mcafee.com/downloads/freescan.aspx

               

              Odds are that you may need to change a couple policy settings in your current McAfee install.

              • 4. Re: McShield uses 99% of CPU

                Repeat: Problem found, work around below.

                 

                Problem: McShield.exe consumes 100% of CPU for long periods of time (>1 hour).

                 

                Work around:
                a. Invoke McAfee Security Center to feed McShield a "cookie" aka cookie monster. (This work around is less than optimal as it degrades over time.)
                b. Search for McAfee anti-spam file error logs, (there are four of them). When found, delete the error logs in these files.( Over time, repeat as necessary.)

                 

                C:\Documents and Settings\All Users\Application Data\McAfee\MCLOGS
                Install
                mcinst
                mcmscsvc
                MskSrver

                 


                Comments: On inspection the logs are "forever logs" that accumulate reports on all errors  encountered by the various McAfee modules. Four modules have log files, these log files appear to "carry over" when an upgrade or a relicense is performed. Inspection of the dates on the logged errors show dates from the first installation up to the current run time. Note that the three machines I have examined all have the same symptoms of 100% CPU consumption and all three cleared up when the files in question were eliminated. The files appear to be diagnostic in nature and would be used by programmers to determine what failed, when it failed and in what module it failed for the McAfee modules.

                 

                It appears that McShield processes these logs on every system startup and on every system return from standby. This effect is what causes the consumption of 100% of CPU for extended periods.

                 

                A suggestion for a rapid work around would be a simple program that downloads to the user computer, targets these files and moves or deletes them from the error logging that is being processed by McShield.exe.
                -------------------------------------------------------------------------------- -------------------------------------
                Note that the Customer Service does not understand this problem and denies it exists.

                 

                Intake Tier wanted to re-install McAfee.
                Tier 2 claims my machines are virus impaired and wanted me to visit the McAfee Virus Removal team.
                Tier 1 wants to educate me on how viruses get onto machines.

                 

                Everything recommened by Customer Service avoids addressing the McShield.exe problem...actions just work to cover it up. This is a systemic McAfee Organizational problem reflected in the inablilty to admit a problem and fix same.

                 

                sasnakra1949

                 

                delete the contents of the McAfee "error log" files

                 

                C:\Documents and Settings\All Users\Application Data\McAfee\MCLOGS
                Install
                mcinst
                mcmscsvc
                MskSrver

                • 5. Re: McShield uses 99% of CPU

                  Many thanks to all of you.

                  I am running stinger, and to morrow I will see the other ideas if that first one does not work

                  I'll come back to report

                  Thanks again

                  • 6. Re: McShield uses 99% of CPU
                    Dinz

                    Hi,

                    Are you still facing the issue, If so please let me know the status.

                     

                     

                    Regards,

                    Dinesh K

                    Mcafee Online Community Moderator

                    • 7. Re: McShield uses 99% of CPU

                      Hello,

                      Here is the new status of my problem:

                      1st step

                      I ran s.t.i.n.g.e.r_v10.0.1.551 (few hours) that does not say if it found something or not, at the end.

                      after that, the problem described in my first post was still there.

                      2nd step

                      I deleted the content of the McAfee "error log" files:

                      C:\Documents and Settings\All Users\Application Data\McAfee\MCLOGS
                      Install
                      mcinst
                      mcmscsvc
                      MskSrver

                      The problem was the same

                      3rd step

                      I put the default values in services.msc and the problem was still there, it was November 8th

                      4th step

                      I do nothing , but use my computer normally, and from time to time I faced the problem.

                      Since a date I can't precise (few days), everything is fine, and the problem cannot be reproduced anymore!

                      Why? that is the question!

                      I do not change anything in my configuration. The only things that have changed were McAfee Updates! Has something changed in these updates that fixed the problem? I am prone to believe that!

                      Many thanks for your time and for your prayer

                      • 8. Re: McShield uses 99% of CPU
                        martinigruppo

                        Thank you very much!

                        With this we have solved our problems on Windows 2000 Server SP4 w/VSE 8.5 or VSE 8.7 (same problem).

                        Just unistall VSE, remove LOG present in
                        C:\Documents and Settings\All Users\Application Data\McAfee\MCLOGS\mcinst (just this dir for us)

                        and reinstall VSE

                         

                        All OK!

                        Thank you