7 Replies Latest reply on Jul 22, 2009 5:55 PM by Peter M

    How to disable automatic loading on startup

      I am running VirusScan as part of SecurityCenter with XP on a Mac running Bootcamp (which enables running Windows on a Mac). Sometimes when Windows is starting up the computer re-boots just as the desktop is establishing itself, just before the McAfee splash screen comes up and it loads. Usually Windows loads okay after the first re-boot but occasionally this develops into a re-boot loop which keeps repeating.

      My research has suggested that perhaps McAfee Scanner or some other aspect of VirusScan could be responsible for this as it is loading or scanning or whatever during the boot process. So I would like to disable it from automatically loading or from any sort of activity on startup and manually launch it instead once Windows has loaded successfully, if that is possible.

      So I am wondering how to do this. I cannot find any option in the programme itself to disable this under Scheduled Scan or anywhere else. The only entry I can find that is associated with McAfee in the msconfig Startup list is mcagent. Would disabling that work?

      I'd appreciate it if someone could let me know how to do this and also if anyone has come across this before perhaps they could shed some light on it.

      Some of my specs are: Windows XP SP3, Intel iMac late 2006 with 2.5 GB ram, SecurityCenter 9.3, VirusScan 13.3.

      Thanks.
        • 1. RE: How to disable automatic loading on startup
          Peter M
          There is no way of doing that without disabling the protection altogether, in other words, why bother using it in the first place.

          The setup on a virtual machine, which I gather is basically what you have, isn't really supported as it isn't quite the same as an actual self-contained operating system.

          I'm going to ask regarding use in such an environment.
          • 2. RE: How to disable automatic loading on startup
            Thanks for your reply. I obviously don't want to disable the protection altogether; I just want to launch it manually myself once Windows has loaded properly, if that is possible.

            It is not a virtual machine, which would run under Parallels rather than Boot Camp, it is a completely self-contained OS which is installed and runs just as a normal Windows installation would. It is installed in a separate partition from OSX so it can be booted into as an alternative to OSX; you simply choose which OS to boot when the computer is turned on.

            So it should more or less obey the same rules as a PC running Windows. There are various Apple drivers involved for running the keyboard etc. but nothing much else apart from that.
            • 3. RE: How to disable automatic loading on startup
              Peter M



              I understand, but am not familiar with either MAC or Bootcamp so I was just surmising there. If what you say is the case then it shouldn't be a problem at all and your issue may be caused by something else. I guess the only way to tell is completely uninstall, then run the MCPR removal tool in my signature and then see what happens.

              I did flag the issue but no-one has responded yet.
              • 4. RE: How to disable automatic loading on startup
                Peter M
                To quote one of our level 3 technicians;

                 

                I don't see why it wouldn't work, its not a VM.

                As far as I know it's just like dual booting on a PC.
                I wonder if McAfee is having problems with the Mac filesystem on the same\other partitions?

                • 5. RE: How to disable automatic loading on startup

                   

                  If what you say is the case then it shouldn't be a problem at all and your issue may be caused by something else. I guess the only way to tell is completely uninstall, then run the MCPR removal tool in my signature and then see what happens.



                  Yes, it may well be caused by something else. I may try what you suggest if I can't find another way round it, although this would not necessarily be conclusive because I can get no re-boots for a week or two and then suddenly it will start up again. That's the problem with intermittent faults. I suppose I could simply disable VirusScan before shutting the machine down and then enable it again when Windows is up and running. If I do that though I would presumably compromise its ability to detect any malicious activity at the boot or startup level.

                   

                  I wonder if McAfee is having problems with the Mac filesystem on the same\other partitions?



                  A very good point. I must look into that some more with Apple. The only thing I would say though is that when Windows is running normally McAfee (and everything else) works fine. I do my scans, updates etc. without any hitches. So the problem with the Mac filesystem would surely have to be taking place only during the boot process if it was causing this anomaly. Is it likely to look at other partitions on the disk while (presumably) scanning during booting? The Windows partition is NTFS.

                  Thanks again for your help with this.
                  • 6. RE: How to disable automatic loading on startup
                    Peter M
                    You're welcome. I'll leave it open in case.