1 2 Previous Next 13 Replies Latest reply on Jul 23, 2009 9:44 PM by mnalep

    Error in MCods.exe, scan never completes, memory could not be read

      Hello,

      I just installed McAfee Security Center v9.11, which comes with Virus Scan v 13.11 on my Dell Dimension L1000r. It is Win 2000 based, 7 year old system, with 512 MB RAM, and 120GB hard drive.

      The virus scanner will not complete an FULL SCAN, or LET ME CHOOSE SCAN on demand. Every time I try to DEMAND a scan the application, of either MC COMPUTER, or the C DRIVE, etc., the scan ends with an ERROR:

      MCODS.exe Application error:

      "mcods.exe - Application Error : The instruction at "0x016d3237" referenced memory
      at "0x7bf2a4f6". The memory could not be "read
      ".

      If I click on my CANCEL button on the pop up dialog error box, it opens the C++ debugger i have on my PC and that shows me another error message:
      " unhandled exception occured in mcods.exe(MCS300UP.001)".

      The C++ debugger points to the following instruction in that program:
      02003237 movzx edx,word ptr [ebx+edi*2]

      I noticed yesterday that a couple of times when the scan stopped running, it the file being displayed in the scanner window was vlc-0.8.6c-win32.exe, or winamp55_full_emusic-7plus_en-us.exe
      , so I decided to try to scan either of these files, but just one at a time - so I opened Windows Explorer (File Manager) and highlighed the one file, and right clicked on it to highlight it, and a windows pop up menu opened, that allowed me to choose to run McAffe SCAN, on just that ONE file.

      Twice that scan, of just that ONE file, caused the exact same error as the FULL ON DEMAND SCAN had.

      But then I tried a few other scans on indivdual files - and they scanned OK, so I went back to scan vlc-0.8.6c-win32.exe again - and that time it SCANNED fine, and did not cause an ERROR!

      What is going on with this software MCods.exe? Sometimes it errors out, othertimes it runs just fine - on the same file ???

      I chatted with someone online yesterday, amd they had me run something called IEregfix.bat and McPreIintalle.exe and then uninstall and reinstall the McAfee Security Center and Antivirus - but that did not work to eliminate the APPLICATION ERROR.

      I should also add, that a few times when the McAfee window stayed open I did see a message that the Scanner "got an error it could not recover from - Error getting SCAN PROGRESS" - but I'm not sure that error came simultaneously with the APPLICATION ERROR i've detailed above.

      I was hoping someone here has already solved this problem?

      Thanks,
      Matt
        • 1. RE: Error in MCods.exe, scan never completes, memory could not be read
          BalaSGS
          Hi,
          Please clarify,
          How old is the computer?
          What is the version of OS (Operating system) you use?
          What is the version of internet explorer (IE) you use?
          Did you made any recent changes to the computer
          Steps:
          Perform the windows update including the patch and optional update
          • 2. RE: Error in MCods.exe, scan never completes, memory could not be read
            Hello Balla,

            The computer is about 7 years old, Dell Dimension, Pentium 3.

            It is running Windows 2000 SP4. I have use Windows update to keep critical updates applied. I may not have all optional updates installed

            I have IExplorer version 6.02.2800 SP1. I have reecntly been using Mozilla Firefox v 3.0.11 more often -as it is faster than IE.

            The big change recently was uninstalling CA AntiVirus. I was also unable to run a complete scan with that software, and it kept freezing, or crashing (in vetmsg.exe, or in caaisdt.exe), so I thought I'd change over to McAfee. But it is not able to run a complete scan either, as it gets a error mcods.exe.

            I would bet that the problem lies in the software, mcods.exe. An 'unhandled exception' is mostly likely a program error.

            Thanks for helping me with this.

            Matt
            • 3. RE: Error in MCods.exe, scan never completes, memory could not be read
              BalaSGS
              run the MVT and post the Session ID {http://mvt.mcafee.com/mvt/default.asp} here let me review and we will update you
              • 4. RE: Error in MCods.exe, scan never completes, memory could not be read
                Balla,

                I just finished installing the Microsoft Updates that I had not done prior to today. There were about 4 updates, having to do with XML, media player, etc., all were optional, but are now installed. The mandatory ones have been installed on an ongoing basis.

                I Downloaded that Mcafee virtual assistant, and ran it (with REPAIR selected).

                OK, I ran it twice, and got 2 session IDs. The first was 19023723, the second was 19023862. The message from the tool said something about the "Mcafee Virtual Assistan tool can't check Mcaffe, as it can't find Mcafee on your system" Makes no sense to me, because McAfee is running on my system!

                (I ran the Virtual Assistant ICON that was on my desktop from 2 days ago, when the lady on the chat service tried to help me. She also had me run something called ieregfix.bat, and Mcpreinstall.exe. today I think I tried downloading Virtual Assistant too many times, and got a Installer error 1316 after I ran the Virtual assistant on my desktop. I thought that was the one I just installed a few minutes ago, but it was more likey the one installed a few days ago - I'm not sure if this even matter to you - but I thought I'd mention it.)

                Thanks,
                Matt
                • 5. RE: Error in MCods.exe, scan never completes, memory could not be read
                  Hi Balla,

                  Are you still looking at this?

                  Thanks,
                  Matt
                  • 6. RE: Error in MCods.exe, scan never completes, memory could not be read
                    BalaSGS
                    Hi
                    Sorry for the delayed response Matt, I’m not able to get a find any major issue with the McAfee product. And you don’t have to save the MVT file each time when you run. You can run the MVT from the desktop shortcut icon. Please clarify

                    Did you removed the CA Antivirus from the add and remove program or did you used any removal tool

                    Did you tried to perform the McAfee schedule scan (click on computer and files – click on configuration button on the right hand panel-click on the advance option under the virus protection is enabled-click on the scheduled scan in the left had panel from the next pop-up menu- and create the schedule scan)
                    How old is the computer?
                    • 7. RE: Error in MCods.exe, scan never completes, memory could not be read
                      Peacekeeper
                      Have you checked the hard disk for bad sectors ie run chkdsk /r on your c drive. Wonky sectors can cause the scanner to lock on files and not lock other times.

                      Worth a check as well. How old is the 120Gb drive I know you can still get these so I wondered on its age.

                      To run Checkdsk as cut from a post from Ex_brit

                       

                      It depends on your operating system.

                      In XP you can simply go to Start/Run and type in the following chkdsk /r (with the space) and hit Enter. (The /r option will repair any problems, hopefully).

                      If you have multiple drives (partitions) you can specify which one as in chkdsk C: /r (with the spaces).

                      It will throw up an error that the volume is in use try at next reboot Y/N? Hit Y and the Enter key. Reboot and it should hopefully start. It takes quite a while sometimes, depending on the size of the drive.

                      In Vista/Win 7 go to Start/All Programs/Accessories and right-click Command Prompt and select "Run as Administrator".

                      In that window proceed as with XP typing in the same commands.

                      Chkdsk checks the hard drive for read/write errors and corrupted data.

                      • 8. RE: Error in MCods.exe, scan never completes, memory could not be read
                        Bala,

                        Sorry for the delay responding, but I've had car problems taking up my free time for over a week now.

                        To answer your question, I did uninstall CA AV using the ADD/REMOVE programs in my Windows 2000 system tools.

                        I have once tried running a scheduled scan, and it did no work. I can try again later if you think I should.

                        I am not sure what your are asking me to verify about the MVT. I did run it from my desktop.


                        PEACEKEEPR, Hi, and thanks for advice. I have run the Chkdsk several times, mostly when rebooting after I crashed with an Application error - "memory could not be read" error. Sometimes it finds a bad file, usually it does not. The drive is only a few years old.


                        Thanks,
                        Matt
                        • 9. RE: Error in MCods.exe, scan never completes, memory could not be read
                          Peacekeeper
                          CAAV removal steps here
                          http://forums.comodo.com/comodo_antiviruspyware_cavs/manual_steps_to_uninstall_c omodo_antivirus-t887.0.html

                          I take it this is the product you installed if so check the steps in case something is left over and clashing with the mcafee install.
                          1 2 Previous Next