8 Replies Latest reply on Jul 25, 2009 2:01 PM by Vinod R

    msconfig problems

      Recently when tryint to use the msconfig startup tab to uncheck some programs that i did not want to run i got the message "an access denied error was returned while attempting to change a service. you may need to log on using an administrator account to make the specified changes". There is no administrator accouint, I am the only one using this computer. Msconfig has worked using the startup tab to disable programs until recently. I havent installed any new programs, etc. I have run several spyware programs, and an online virus scanner. Nothing. Someone told me that they had heard that McAfee could be "protecting" msconfig. This also happens when running in safe mode. Any suggestions, help?
        • 1. RE: msconfig problems
          BalaSGS
          Hi
          Sorry for the inconvenience caused, please let us know if you still have the issue with Computer and clarify,
          What is the version of operating system you use (Vista / XP)?
          • 2. RE: msconfig problems



            As for me, based on experience, i think that this is quite just "normal". After that msg appears, you will just click "ok", then, i think the message will come up again, click "ok" again, and then you'll get a msg saying you need to restart the computer.

            After restarting, just check on the box that says something like "don't show this msg again"..

            Hopefully someone can shed us a light on this..:confused:
            • 3. RE: msconfig problems
              My computer did this in the past. I would just click ok, then restart and the items that I had unchecked stayed unchecked. but that is not the case now, They stay checked. I am using xp sp3.
              • 4. msconfig problem - I get same error
                I'm also running XP with SP3. I've verified that McAfee is causing this problem by uninstalling it and running msconfig. It works fine. I re-install McAfee and when I change something with msconfig, I get the "An Access Denied error was returned while attempting to change a service. You may need to log on using an Administrator account to make the specified changes." message. I AM THE ADMINISTRATOR! Even though I get this error, msconfig still makes the change and gives me the message a second time, asking me to reboot. If I ignore the message, it works. I only have to reboot to make the change take effect (and I don't get a message saying "Don't show this message again"). It is just annoying to get it.

                I would think there is a solution, but since I rarely do this, I won't worry. It was just a pain the first time I got it since I didn't know where it came from and had to try all kinds of stuff to isolate the source.:cool:
                • 5. RE: msconfig problem - I get same error
                  This is a known issue with msconfig and all Virus Scanners.

                  It doesn't actually stop you from making changes to msconfig, so you can ignore the popup message.
                  • 6. RE: msconfig problem - I get same error
                    I can ignore the pop-up. X it out. But I still cannot make changes in msconfig. Any other suggestions??
                    • 7. RE: msconfig problem - I get same error
                      Vinod R


                      If you are logged in to the Administrator it must work.... bypass the error message and reboot and verify that the changes has applied.. ( on reboot cancel the request to revert the changes)
                      • 8. RE: msconfig problem - I get same error
                        Vinod R


                        Please understand that it is not McAfee's intention to prevent you from changing your startup items. But, the goal here is to protect users from malware/viruses which tries to disable McAfee's Real time protection without the user's knowledge.

                        'McAfee Real-time Scanner' service has special protection to disable malware from changing it's configuration. When you click ok, 'msconfig' tries to open/save the service configuration and thus results in an 'Access Denied' error.

                        'msconfig' is incorrectly trying to modify every service setting when 'OK' button is pressed which is triggering the error dialog. It probably shouldn't do that if you haven't changed the specific McAfee service.(To my understanding MSCONFIG by design resets the whole startup items whenever you change one or more of them.)

                        MSCONFIG is for troubleshooting, not for controlling startup processes, although many techs/ tech gurus/forums have advised customers to use it that way so they don't have to teach them to learn how their programs work. happy