8 Replies Latest reply on Mar 27, 2009 7:56 AM by exbrit

    I can't run VirusScan in Vista 64 SP1

      Hello,

      I'm using McAfee SecurityCenter 9.3 at PCs of home. Recently I updated VirusScan at Vista 64 when the SecurityCenter popped up to update, but VirusScan doesn't work at all. Even I can't see the menu for VirusScan.


      Vista 32bit at home shows Scan Menu, but Vista 64 doesn't show correctly. To make matters worse, manual scan doesn't work. I don't know the difference of OS version causes this problem or there something else is.



      I doubt I run "Vista Manager" for registry defragmentation. So, I decided to reinstall SecurityCenter. I followed the removal of McAfee Software from http://service.mcafee.com/FAQDocument.aspx?lc=1033&id=TS100507, then reinstall the McAfee SecurityCenter. However, It still has a problem.:(

      As you see the screenshot below, it goes back to Protection Status when I click on Scan.



      If you have same problem and fixed this issue before, please reply me.

      Thank you,
      spark.
        • 1. RE: I can't run VirusScan in Vista 64 SP1
          exbrit
          No screenshot but I'll guess. If You are running any of the beta versions of IE8 uninstall it. If you are running Internet Explorer 7 or 8 (final) go to Tools/Internet Options/Advanced and click the Reset button. OK and exit, Restart IE and re-enable all the add-ons under Tools/Manage Add-Ons.
          Go to Windows Update and make sure you are up to date with both critical and non-critical updates.

          McAfee is totally compatible with both Vista types.
          • 2. RE: I can't run VirusScan in Vista 64 SP1


            Thank you for the answer,

            Somehow, the screenshot was not enabled but now it work. Well, I also tried that, but it doesn't succeed. I don't have IE8, IE7.
            I don't have much add-on, it was done quickly to reset. I also patched the latest updates. No Luck!!.
            • 3. RE: I can't run VirusScan in Vista 64 SP1
              exbrit
              I just checked your profile, you had it set NOT to show signatures and images, I altered that.

              However, the screenshots are still not displaying, to me at least.

              Can you try hosting them at somewhere such as Photobucket and then post the images using the bbcodes ?

              The blogsot you are using may not allow remote access.
              • 4. RE: I can't run VirusScan in Vista 64 SP1


                Thank you,

                Can you come to my blog site. linuxsw.blogspot.com

                I don't know why it doesn't show the images for you, but I can see the images correctly from Firefox now.
                IE 7 doesn't show the images correctly when I checked it with my IE 7.0.

                Thank you,
                • 5. RE: I can't run VirusScan in Vista 64 SP1
                  exbrit
                  I don't even see the image placeholders in my Firefox 3.0.7, but I at least see those in IE8 (final), this is in Vista SP1. However if I go to properties on each one and then display their URLs separately I can see the images....very weird.

                  Anyway, from what you show the first ones look normal to me - I thought that you were getting blank Security Center images.

                  The last one is an issue that I will have to research more. But I would imagine that McAfee was corrupted in the change from x86 to x64?

                  Try the following after having temporarily enabled Windows Firewall:

                  1. Uninstall all McAfee programs through "Add or Remove Programs" in Windows "Control Panel".

                  2. Use the MCPR tool, see this article: How to remove supported McAfee consumer products using the McAfee Consumer Products Removal tool (MCPR.exe). This will remove all McAfee remnants from your computer. (you must have Windows Vista, XP or 2000 SP4 to use this tool)

                  3. Launch Windows Explorer and delete all McAfee files in "Program Files" but especially in "C:\Document and Settings\<user>\Application Data" and "C:\Document and Settings\All Users\Application Data". You have to set Windows Explorer to show all hidden files and folders (Tools > Folder Options > View tab). Just delete the McAfee folders even if they are empty in all the "Application Data" folders. Can be more than one!
                  In Vista: C:\Program Files, C:\ProgramData and C:\Users\yourname\AppData\Roaming
                  If you can't find these files don't worry. It just means that MCPR has done its job.

                  4. Reboot and redownload/reinstall your McAfee products directly from your account at the McAfee web site NOT from any CD that you may have.
                  • 6. RE: I can't run VirusScan in Vista 64 SP1


                    Well, I followed your direction, and I run MCPR as an administrator. When I checked the folder C:\Program Files(X86) Still there are two folders named McAfee.com and McAfee. McAfee.com has some agent program is runnning, so I kill the process then I can delete the folder. For McAfee folder, I can't delete it so I reboot and delete it. I think I delete every files to reinstall the McAfee SecurityCenter, and reinstalled it.

                    By the way, when I install it with DMSetup.exe which I downloaded after login, First, it download 54MB file and then It also downloaded 24MB and installed software such as SecurityCenter, VirusScan, Firewall, SiteAdvisor.

                    When I click "Scan", it still has same problem. :mad:
                    • 7. RE: I can't run VirusScan in Vista 64 SP1
                      exbrit
                      I just realised you tried that. Try contacting Technical Support Chat linked in my signature.
                      • 8. RE: I can't run VirusScan in Vista 64 SP1
                        exbrit
                        I found this from searching the forums and it fixed it for an XP person, not sure it will help here.

                        1. Check if MSXML3 and MSXML 4 is installed in the add/remove programs.
                        2. Run IEREGFIX.BAT: http://download.mcafee.com/products/...s/IERegfix.bat
                        3. Have you downloaded the latest Windows update?