1 2 Previous Next 14 Replies Latest reply on Mar 16, 2011 2:23 AM by amitk

    c:\windows\system32\safeboot.sys missing or corrupted

      Hi,

      I have a laptop (running EEPC v5.1.7) which have the safeboot.sys error message after a reboot. The same error occurred again after decrypt and reinstallation of EEPC. Appreciate some advice here. Thanks in advance:)
        • 1. RE: c:\windows\system32\safeboot.sys missing or corrupted
          is it missing (or corrupt)? or is Windows confused about the fact?

          perhaps you have some naughty software removing drivers, like system restore wink
          • 2. RE: c:\windows\system32\safeboot.sys missing or corrupted
            The error message indicates that safeboot.sys (should be c:\windows\system32\drivers\safeboot.sys) is corrupted or missing, and Windows cannot be started.
            • 3. Same issue for one of our users this morning....
              Windows boot manager

              File: \windows\system32\drivers\safeboot.sys

              Status: 0xc00000e9

              Info: windows failed to load because a critical system driver is missing, or corrupt


              ---------

              We can get past pre-boot screen, but windows won't boot normally. Blank screen, no further errors.

              When booting into Safe Mode, that's when we're presented with the above error message.
              System Restore is switched off on all of our machines, so I think we can eliminate that. We've never seen anything like this before. We have SafeTech and WinTech disks in case we need to perform a recovery. Not sure that this will help though from what the gentleman above said.

              Just let me know if you need any further infomation.

              Thanks in advance for any advice or suggestions. :)

              Paul
              • 4. Resolution
                Well, we have a resolution... even though it is a bit of a mission to complete.

                This is how we done it...

                1. You'll need to get the safeboot.sys file off a working system onto a USB stick. (we used a file from the same version of SafeBoot... not sure if it'd work with a newer or older version.)

                2. Use the SafeTech CDs to boot up on the affected machine. (Go->Programs->SafeBoot WinTech)

                3. Authorize using the Daily Code.

                4. Authenticate yourself against SBFS. (Or however you want really, that's just how I did it.)

                5. Mount the USB drive. (Disk->Mount Drive)

                6. Copy the file across to c:\windows\system32\drivers etc... (may be different if you're on different OS. We're using Vista.)

                7. Reboot


                I appreciate I've been very brief there, so if you need any elaboration on any of the above points just let me know and I'll go into further detail.

                Thanks,

                Paul
                • 5. RE: Resolution
                  it would indicate from your fix that windows was right - the file was missing (or corrupt) - did you check which before copying the file over?

                  you might want to get the client log from this machine to see if the client decided to remove the .sys file for some reason.
                  • 6. It was corrupt, rather than missing....
                    Yeah, the file was still there when we copied the new one across so there'd obviously been some corruption to the safeboot.sys file.

                    Not sure why this occured... any thoughts?

                    Paul
                    • 7. RE: It was corrupt, rather than missing....
                      you'd need to diff the file with the original and see what had actually changed. The client log though is a good place to start looking.
                      • 8. RE: Resolution


                        hey congrats!
                        I'm a bit puzzled on point 2 - what are these safetech CDs of which you speak? On our safeboot server theres a "programs/safeboot admin tools" , but no mention of wintech.
                        Is this an optional extra or something?
                        • 9. RE: Resolution



                          I asked my tech guys to try this, but no go. The weird thing is after they reinstall the OS on the laptop, the same error occurred. The laptop getting this error has the error "e0030009 - Error creating Endpoint Encryption File System host file" appearing in the log file as well.
                          1 2 Previous Next