7 Replies Latest reply on Apr 22, 2009 10:11 AM by mwalter

    Keyboard layout in pre-boot environment

      For some reason, the keyboard layout in the pre-boot environment on my EE clients was set to US which caused users no-end of problems logging in as they were using secure(ish) passwords with symbols in them (it's so annoying when users actually listen to the .

      My first thought was that I'd bogged up somewhere and not deployed the English language pack but a quick check showed that I had. Looking at the locale.ini on a client revealed that there were no defaults for keyboard or language. Nothing I tried could fix this until I created a new file group which was a copy of the english language group and edited the locale.ini file to add the necessary entries. As I didn't want ot mess about any more, I set the file type to 'INI File' rather than 'Merge INI'. I assigned the file group to a test machine, synchronised and rebooted and finally I got a UK keyboard.

      So, I've got a work around but what is the correct method of doing this? And why wasn't it working properly in the first place? Obvioulsy, I don't want to rely on this workaround because sooner or later it's going to break something :)

      Mike
        • 1. RE: Keyboard layout in pre-boot environment
          changing the file type was not good - you just wiped out all the other settings.

          did you change the theme by any chance? That would wipe the locale settings as well.

          What you should have done is just opened the language pack locale.ini file, and clicked apply - this would increment the revision number and force the settings to be re-applied on the local machine.

          A theme change is the most likely cause of this though?
          • 2. RE: Keyboard layout in pre-boot environment

            Care to be a bit more explicit about this? Which locale.ini, where? What exactly should I have done? As far as I can see, unless you export the contents of a file group, there is no way to look at the current files or to amend them.

            Mike
            • 3. RE: Keyboard layout in pre-boot environment


              OK, I've figured out what you mean. Tried it. No good :(

              Mike
              • 4. RE: Keyboard layout in pre-boot environment
                the locale.ini for English is much more than USA..

                here it is (from the 0009.DELanguage directory)

                ;English (United Kingdom/International) Stub

                [Languages]
                0809=Lang.0809

                [Keyboards]
                0809=Keyboard.0809
                20409=Keyboard.20409
                11009=Keyboard.11009
                0452=Keyboard.0452
                10409=Keyboard.10409
                11809=Keyboard.11809
                1809=Keyboard.1809

                [LanguageIDMap]
                0809.Language=0809
                0809.Keyboard=0809
                20409.Keyboard=20409
                11009.Keyboard=11009
                0452.Keyboard=0452
                10409.Keyboard=10409

                [Lang.0809]
                Name=English (United Kingdom)
                ID=0809
                StringFile=0809.str
                FontSection=Fonts.LatinAscii

                [Keyboard.0809]
                Name=English (United Kingdom)
                Mapfile=0809_E.map
                OSK=0809_OSK.XML

                [Keyboard.20409]
                Name=English (US International)
                Mapfile=20409_E.MAP
                OSK=20409_OSK.XML

                [Keyboard.11009]
                Name=Canadian Multilingual Standard
                Mapfile=11009_E.MAP
                OSK=11009_OSK.XML

                [Keyboard.0452]
                Name=United Kingdom Extended
                Mapfile=0452_E.MAP
                OSK=0452_OSK.XML

                [Keyboard.10409]
                Name=US Dvorak
                Mapfile=10409_E.MAP
                OSK=10409_OSK.XML

                [Keyboard.11809]
                Name=Gaelic
                Mapfile=11809_E.MAP
                OSK=11809_OSK.XML

                [Keyboard.1809]
                Name=Irish
                Mapfile=1809_E.MAP
                OSK=1809_OSK.XML
                • 5. RE: Keyboard layout in pre-boot environment
                  Well, that's more the sort of thing I expected but a) that's definitely not what was in the file I exported and b) where's the bit that would set the default keyboard and language?

                  Just for reference, here is the locale.ini file I created/amended
                  ;B5200
                  ;Theme 201 Default

                  [Settings]
                  DefaultLanguage=0809
                  DefaultKeyboard=0809

                  [Languages]
                  0409=Lang.0409
                  0809=Lang.0809

                  [KeyBoards]
                  0409=Keyboard.0409
                  0809=Keyboard.0809

                  [LanguageIDMap]
                  0809.Language=0809
                  0809.Keyboard=0809
                  0409.Language=0409
                  0409.Keyboard=0409
                  0009.Keyboard=0409
                  0009.Language=0409

                  [Lang.0409]
                  Name=English (United States)
                  ID=0409
                  FontSection=Fonts.LatinASCII

                  [Keyboard.0409]
                  Name=English (United States)
                  MapFile=<US>

                  [Lang.0809]
                  Name=English (United Kingdom)
                  ID=0809
                  StringFile=0809.str
                  FontSection=Fonts.LatinAscii

                  [Keyboard.0809]
                  Name=English (United Kingdom)
                  Mapfile=0809_E.map
                  OSK=0809_OSK.XML


                  I just bolted in the stuff for 0809 and set up the default behaviour.

                  Mike
                  • 6. RE: Keyboard layout in pre-boot environment
                    looks good. Are you saying you don't see the UK language listed in the pre-boot options page still?

                    if so, then it's not getting deployed to the machine - check the copy of locale.ini is good in the client directory/locale dir, and check there's an entry in the clientlog to show it's been moved into SBFS.
                    • 7. RE: Keyboard layout in pre-boot environment


                      No, once I removed the English language pack and added my custom file group - where the only change is the locale.ini file - and synchronised, everything worked they way it should :)

                      Mike