1 Reply Latest reply on Apr 16, 2009 9:13 AM by Corki

    Upek Fingerprint reader - Thinkvantage Fingerprint software

      It is my understanding that McAfee Endpoint Encryption is supported for Upek fingerprint readers/Protector QL suite and Thinkvantage Fingerprint software is the QL equivalent from Lenovo.

      I have followed the instructions closely from the Admin guide and still not able to get it running. Below are the steps of what I have done.


      I did a reset of my user token (fingerprint) so that I can start with ground zero. I also deleted all users in Thinkvantage Fingerprint software.

      1. At PBA, key in my username (maddie) and default password 12345
      2. Upon successful authentication, it prompts me to change password and I key in my domain password.
      3. Windows try to authenticate me.
      4. I key in my domain username (maddie), choose logon to my domain (maddomain), and key in my domain password (qwerty).
      5. SbUpekAFIS.exe detects my username as maddie instead of maddomain\maddie.
      6. It starts ThinkVantage Fingerprint software to enroll maddie instead of maddomain\maddie.
      7. It asks me to register one or more of my fingerprints.
      8. Successfully capture my fingerprint.
      9. Reboot.
      10. At PBA, leave username blank, password blank and swipe my finger.
      11. Authentication successful and proceed to start windows
      12. Login to windows fail because it presents my username as maddie (wrong! It should present as maddomain\maddie) and password is correct.

      So my question is does SbUpekAFIS.exe detect a proper windows AD username as domain\username?
      If not, this should be the problem and how can I proceed to ensure that it does.

      To further prove my theory that SBUpekAFIS.exe is the culprit, I did the following again.
      1. Create a local user call maddie with password abcdef
      2. Reset my user token (fingerprint) and deleted all users in Thinkvantage Fingerprint software.
      3. At PBA, key in my username (maddie) and default password 12345
      4. Upon successful authentication, it prompts me to change password and I key in my local password abcdef.
      5. Windows try to authenticate me.
      6. I key in my domain username (maddie), choose logon to my domain (maddomain), and key in my domain password (qwerty).
      7. SbUpekAFIS.exe detects my username as maddie instead of maddomain\maddie.
      6. It starts ThinkVantage Fingerprint software to enroll maddie instead of maddomain\maddie.
      7. It asks me to register one or more of my fingerprints.
      8. Successfully capture my fingerprint.
      9. Reboot.
      10. At PBA, leave username blank, password blank and swipe my finger.
      11. Authentication successful and proceed to start windows
      12. Login to windows successful.

      Anybody has any idea?
        • 1. RE: Upek Fingerprint reader - Thinkvantage Fingerprint software
          Seems the fingerprint reader is working, authentication with fingerprint at pre boot works. It's SSO that isn't working with domain. Does the Thinkvantage have any settings for SSO? What SSO settings are enabled in EEPC in the machine's General tab?

          If XP, there are settings in the sbgina.ini that can affect how the domain is compared/used if you have SSO enabled in EEPC and use a UPN username. Have you tried with a EEPC user name maddie@maddomain.com ?