6 Replies Latest reply on Dec 22, 2007 3:25 PM by ms7

    error message

      I had some computer problems a couple of weeks ago. I contacted Dell, and I had to fix my operating system. Some of the files were lost because of the process that I had to go through. One program that stopped working was this one. First, I had to reinstall the .net Framework. I got that installed, but now I get this error message every time I try to get into it. Unable to read objects of type Arbus.Client.PersonalArchiveEngine.Base.ArchivalJob It will launch the program then with this error message coming up in a seperate window a few times. Then, nothing in the program will work. I click on things, but nothing happens. I am then forced to end the program using task manager. Does anyone know how to fix this?
        • 1. RE: error message
          Peter M
          Try this:
          1. Uninstall all McAfee programs through "Add or Remove Programs" in Windows "Control Panel".

          2. Use the MCPR tool, see this article: How to remove supported McAfee consumer products using the McAfee Consumer Products Removal tool (MCPR.exe). This will remove all McAfee remnants from your computer. (you must have Windows Vista, XP or 2000 SP4 to use this tool)

          3. Launch Windows Explorer and delete all McAfee files in "Program Files" but especially in "C:\Document and Settings\<user>\Application Data" and "C:\Document and Settings\All Users\Application Data". You have to set Windows Explorer to show all hidden files and folders (Tools > Folder Options > View tab). Just delete the McAfee folders even if they are empty in all the "Application Data" folders. Can be more than one!
          In Vista: C:\Program Files, C:\ProgramData and C:\Users\yourname\AppData\Roaming

          4. Reboot and redownload/reinstall your McAfee products directly from your account at the McAfee web site.
          If from McAfee direct: https://us.mcafee.com/root/login.asp
          If you bought your McAfee products from Dell: https://us.mcafee.com/root/login.asp?affid=105
          • 2. RE: error message
            I tried to reinstall the Data Backup program from the McAfee website without uninstalling everything because I don't really want to use the long way that you suggested unless if I absolutely have to. The error message doesn't come up any more, and some parts of the program now works. The files now appear in their window, but I still can't use any of the action buttons. I can't change the settings and basically nothing works. Do you have any other ideas I can try or should I just reinstall all the McAfee programs like you suggested?
            • 3. RE: error message
              Peter M
              I'm not quite sure how you achieved that as Data Backup is merely a tool that is included in Security Center and hasn't ever been a separate entity as far as I know.

              You would have to do the complete uninstall and cleanup as I mentioned I'm afraid.

              That's assuming that you actually have the current 2007 products.
              • 4. RE: error message


                McAfee Databackup needs .Net Framework 1.1 in order to work (it's also the only program in the suite that needs .Net Framework).

                I would uninstall ALL .Net Framework from the PC, then reboot, and install .Net Framework 1.1.

                @Peter, although the MDB was never a seperate program (although it may b in the future), it's not integrated into the MSC like Shredder/QuickClean - during the installation you have the option whether to install MDB or not. You can also uninstall it seperate of the other programs.
                • 5. RE: error message
                  Peter M


                  That's interesting.....I do now recall being asked if I wanted to install DB or not, so I stand corrected....sorry about that ms7 :confused:. (I refused it because I've read about too many problems with it).

                  I have .net 2 and 3 also installed in both XP and Vista & those came in as options in Windows Update. They are backwards compatible I believe.
                  • 6. RE: error message
                    Thanks. I already tried reinstalling all of the .net Frameworks including 1.1 because that was one of the things that was missing after I repaired my operating system. It's not so much that I really want this program, I'm just looking for a quick, easy and free way to back up my files without the hassal of all the dragging and dropping files. If you've got any other ideas I'd be glad to hear them.