1 2 Previous Next 10 Replies Latest reply on Mar 4, 2009 11:49 AM by SafeBoot

    sbnp.dll

    Dvanmeter
      I recently upgraded a Windows XP machine from 4.2 to 5.1.7. The upgrade went well and everything appears to be working but the log file shows the following error

      2/11/2009 3:32:08 PM Transferring local audit information to database
      2/11/2009 3:32:17 PM Checking for file updates
      2/11/2009 3:32:30 PM Removing file "C:\Program Files\SafeBoot\SBNP.dll"
      2/11/2009 3:32:31 PM Error [e0130006]: Error opening file
      2/11/2009 3:32:55 PM Applying configuration
      2/11/2009 3:33:11 PM Synchronization complete
      2/11/2009 3:33:11 PM Automatically synchronizing again in 60 minute(s)
      2/11/2009 3:33:14 PM Applying cryption changes

      There was a file sbnp.dll that was still a 4.2 file left over in the following folder and I deleted it. I verified the 5.1.7 version is under C:\windows\system32, but the error still remains everytime the system syncs. anyone seen this before?
        • 1. nover mind fixed it
          Dvanmeter
          I fixed it, I went to the regsitry and looked for the dll name. I found a couple of locations in the regsitry that was still pointing to c:\program files\safeboot and deleted them. Next sync the error went away
          • 2. RE: nover mind fixed it
            You can also edit it out of [SBfolder]\SBFILE41.LST and [SBfolder]\SBFILE.LST. If you remove its block from there, that seems to work too (and without having to reg-hack).
            • 3. RE: nover mind fixed it
              Dvanmeter
              Thanks for the tip. I think I will do all three, edit the .lst file, delete the old dll and delete the old reg keys. Just a question, do you know if the SBFILE41.LST is even needed? I noticed it on a new install of 5.17 that has never had 42 version installed, or maybe im just thinking that the SBFILE41.LST is for the old 42 client and its not.
              • 4. RE: nover mind fixed it
                please don't tinker with our files wink
                • 5. RE: nover mind fixed it
                  Dvanmeter
                  That wasnt a very professional posting from Mcafee Management. I prefer you say that you will look into the issue and post official workarounds or fixes.
                  • 6. RE: nover mind fixed it
                    Deleting a file that's under management will cause this issue - you should remove the file group containing it. Deleting it, then hacking our LST files is a double negative which will solve the problem.

                    So, the (official) solution would be to have the file removed by virtue of removing the file group containing it, thus forcing the clean up as it goes.

                    For "official" and "professional" support (notice the smiley this time please), please use McAfee Technical Support services - this forum is contributed to by people (like me) on their own personal time and is not sanctioned or monitored by McAfee. happy
                    • 7. RE: nover mind fixed it
                      Dvanmeter
                      the 4.2 filesets are removed via the console and only the v.5.1.7 are selected.
                      • 8. RE: nover mind fixed it
                        Just GREAT thanks !!!

                        with that (delete entries of sbnp.dll in the two files SBFILE(41).LST) , the sbsetup -uninstall perform perfectly
                        (no need to make changes in the registry)

                        since i have migrate V4 to V5 , i met the problem described there.

                        i loose my time and especially my mind with this issue .... what a luck for me to find the solution :)

                        again thanks ....... (to you and Google)
                        • 9. info
                          Dvanmeter
                          Ok, I found the easiest way to do this is to make sure you unload the sbnp.dll prior to upgrading to V517. Remove the checkbox for NP Password change from fileset for your Safeboot 4.2 conainer. Sync the device and it will say it removed that item. Now when you upgrade to V517 you will not have any problems. From what I remember the sbnp.dll handles password intercept when a user changes their windows password by hitting crtl-alt-delete and selecting Change password option.
                          1 2 Previous Next