2 Replies Latest reply on Sep 6, 2017 4:59 AM by joezo

    browswer slow down? possibly something to do with McAfee?

    joezo

      So, I only recently became aware of McAfee installing or adding their Web Advisor. How long has it been in the program? i notice that I can't disable it. If I click on the option within Settings- to disable it- all I get is a web page explaining it.

       

      The reason I wanted to disable it is that about the same time I became aware of Web Advisor, I noticed a big slow down in my web browsing. I at first thought it might be my provider, Time-Warner, since my Netflix connection also seemed much slower. But then I noticed that the other 2 PCs on my home network didn't  have the slow down- so I started to panic.

       

      Then, I think while within the McAfee program, I got a popup saying I need to close the popup so an update could be installed. There was also an icon in the tray indicating something similar. (OK, I generally forget to take good notes while panicking). So, I closed that popup, rebooted, then voila--- the browser slow down was over- back to a good speed.

       

      I still don't know for sure that the slow down was due to some buggy update from McAfee, but it seems reasonable- then I suggest they "pushed" the hotfix. Am I right?

       

      And, why won't McAfee allow me to disable Web Advisor? Not that I have any reason to do so- but shouldn't it be possible?

       

      Joe

        • 1. Re: browswer slow down? possibly something to do with McAfee?
          catdaddy

          You do not have to completely remove Web Advisor to (Disable it).


          1. Open Firefox.
          2. Click the stacked menu icon on the upper right.
          3. Select Add-ons.
          4. Click Disable next to McAfee WebAdvisor or SiteAdvisor
          5. Open Firefox.
          6. Click the stacked menu icon on the upper right.
          7. Select Add-ons.
          8. Click Disable next to McAfee WebAdvisor or SiteAdvisor

           

          If you use Chrome

          1. Open Chrome.
          2. Click the menu icon on the upper right (the three dots stacked vertically).
          3. Click More Tools, Extensions.
          4. Remove the check mark next to McAfee WebAdvisor or SiteAdvisor.

           

          1. Open Internet Explorer.
          2. Click the Tools menu.
          3. Select Manage Add-ons.
          4. Select the McAfee WebAdvisor or SiteAdvisor add-on, and click Disable.

           

          Hope this helps...

          • 2. Re: browswer slow down? possibly something to do with McAfee?
            joezo

            Catdaddy, thanks for your quick reply. Good to know there is some way to disable WebAdvisor if necessary-  but I'm still wondering what the problem was, that is if it had anything to do with WebAdvisor. The fact that McAfee "pushed" a hotfix shortly after ad ding this feature makes me suspicious.

             

            Also, I forgot to mention a few things. I did mention that my other 2 PCs on my home network didn't have the problem but I forgot to mention that I don't have McAfee on them, instead they have Norton.

             

            And, I forgot to mention that when WebAdvisor first was added to my McAfee program - every time I opened a any browser window, I got a weird popup near the top of the screen that informed me about WebAdvisor and if I clicked on it- I got another browser window to a McAfee site blabbing about how wonderful this new feature is- with little real explanation- the same site that I'd get to if I went into the McAfee settings, to the feature, clicked on it (thinking I could disable it)- but no, I'd get to that web page. Seems to me they added this feature without sufficient testing- used us as testers, enough people complained, then they pushed the hotfix- without any discussion of this problem. It would be comforting to get an explanation- so I'd know for sure if my interpretation of this problem is correct.

             

            I do recall something similar a year or so ago with McAfee. I don't recall the details- but it was another example of insufficient testing prior to pushing some new feature or a new version of the program- then shortly after- they fixed it.

             

            If any McAfee tech is reading this- please make it possible to disable WebAdvisor from within settings.

            Joe