8 Replies Latest reply: Jun 16, 2015 2:48 PM by fitchsoccer342 RSS

    Unable to find a valid repository

      Hello!
      We use ePO 4.0 and VirusScan Enterprise 8.7
      All systems are managed from central ePO server and update from distributed FTP-repositories.
      Some time ago we have start to recieve a problem: Systems do not update, I see in logs: "Unable to find a valid repository".
      It is not looks like "the repository is not up to date". When I look "View packages" for these repositories I see everything is good.

      EVEN MORE!!! When I include the repository manually in Repository List on system from VirusScan Console, update goes excellent!

      I have tried to create UNC-repositories, the situation I see is same. When I try to update using automatically recieved repository list from ePO server, it failed with error "Unable to find a valid repository". And when I include the repository manually on system, update is successfull.

      This problem appears on all the systems under problem distributed repository.
      This problem spreads on distributed repository one by one, like a virus.

      How can I decide this problem and repair Automatic update system?
        • 1. RE: Unable to find a valid repository
          Laszlo G
          Are you using McAfee Agent 4.0 on these machines? If so did you install patch1 fot McAfee Agent?
          Because this error is like one of the MA 4.0 without patch
          • 2. Fixed/Solved FTP Repository Failed to update Mcafee
            pwolfe
            :) In Response to the FTP repository.

            You have to create the Repository Under The System Policy for the Current branch or Location. This Flips the Local = "0" Flag in the SiteList.xml to = 1 And the Updates will process.

            What a Joke Eh......


            1. Delete you're Current Global FTP Distributed Repository Site.
            2. Go To Systems Tab At the Top of the EPO Interface.
            3. Follow you're System Tree and Select the correct Unit or Location to work with
            4. In the Right Pane...Select Policies
            5. In the Drop Down menu select Mcafee Agent
            6. Edit the Policy Listed ( A New View will appear)
            7. Select the 4th Tab at the top of the screen "Repositories"
            8. Click the Add At the Bottom of the Repository List.
            9. Fill In you're FTP information
            10. Save
            11. Notice The Local Flag in the TYPE Column. ...Not Global.
            12. Update You're EPO Agent Settings By Tickling the agent with the following Command Line
            13. "C:\Program Files\McAfee\Common Framework\cmdagent" /p /e /c
            14. The Update should start. If Not force the Update by Hand.



            Hope this helps to all that need it.
            • 3. Re: RE: Unable to find a valid repository
              hbss_admin

              How can you tell if patch 1 is applied?

              • 4. Re: Unable to find a valid repository
                Attila Polinger

                Hi Nehludov,

                 

                not sure if you are still expecting solution, still I'd like to add this piece of info that with global distributed repositories, the McAfee agent checks the repository content by looking at sitestat.xml and comparing it to the master repository's sitestat.xml. This file holds a timestamp and a version info of the master repository so if the content of this file on a distributed repository does not match that of the master repository, the agent quits and tries the next repository.

                With local distributed repositories, this check is not performed, however, then you need to keep those local repositories up to date.

                 

                If you define a repository in the McAfee Agent policy under Repositories, that is local (sitestat check not performed). If you define a repository under Systems - distributed repositories that is global (sitestat check is performed).

                 

                Regarding your original problem: we/I used to have problems with files stuck/locked in the distributed repository which could not get replaced by the ePO mirror task so if this happens with the sitestat.xml, you can imagine the consequence.

                This is why we chose to have local distributed repositories and keep them up to date ourselves. Its much faster (for all 24) and have a separate log so we always find problem causes quicker.

                 

                Attila

                • 5. Re: Unable to find a valid repository

                  I live in Iran

                  i've used virusscan enterprise 8.5.0i

                  these days i can't update it

                  i receave this error:

                  "Error occurred while downloading file Site State.Xml

                  unable to find a valid repository"

                   

                  What should i do?

                  is it because of this: "

                  We are unable to provide software, services and technology to you in accordance with United States Law. Since McAfee is a US company, the corporation is subject to the US Export Adm

                  inistration Regulations.

                  The following countries are subject to U.S. trade sanctions or embargo:   Cuba, Iran, North Korea, Sudan and Syria."

                  ?????



                   

                   

                  Message was edited by: shabnam k on 10/18/10 7:28:56 AM CDT
                  • 6. Re: Unable to find a valid repository
                    MaxPat

                    EPO 4.5 latest patch

                    McAfee Viruscan 8.7i latest patch

                     

                    I had a similar issue with servers that are connecting through an agent handler but had icmp ping blocked, just changed the mcafee agent general policy for the agents in:

                     

                    McAfee Agent > General > [Policy name]

                     

                    Repositories option:

                         Select repository by: Use order in repository list option.

                     

                    Regards.

                    • 8. Re: Unable to find a valid repository
                      fitchsoccer342

                      Talk about bringing up threads from the dead.. this op was from 2008 using ePO 4.0!