8 Replies Latest reply on Nov 5, 2009 10:06 AM by smokensqueal

    ePO 4.0 server only accpeting 37 systems

      I've been given an ePO server ver 4.0 that will only accept 37 systems. I'm new to this ePO thing so any help would be great. When trying to add a new system it just never shows up. Any ideas?
        • 1. Re: ePO 4.0 server only accpeting 37 systems
          Sailendra Pamidi

          Hi

          Its not clear from your post how you are trying to add the system. Typically you can deploy an agent to a system while adding to the system tree or you can simply add an entry to the system tree without deploying the agent.

           

          In the latter case, you would obviously need to push an agent before the properties show up on the ePO console.

           

          One other thing you may want to check is if you are using the default SQL Express edition that ships with ePO and your ePO database has reached 4GB in size.

          SQL Express has a 4GB database limit and you are pretty much limited in what you can do if the db reaches that size (other than delete events ofcourse) to get more space.

          • 2. Re: ePO 4.0 server only accpeting 37 systems

            Hi,

             

            can you be more clear about the issue please?

             

            Do you get any error message when you try to add new system? What's EPo 4.0 build version? What's database you use?

             

            Best regards

            Davide

            • 3. Re: ePO 4.0 server only accpeting 37 systems

              Thanks for the response. Sorry I didn't provide more information but this is all new to me. I found the answer though. It looks like the two "Agent-Server secure communication keys" only allowed for 26 and 10 communications. And the 37th system was added but not communicating.

               

              I tried to push the agent and just add the system in the system tree. I found it would add the IP of a system but everything would be blank. When I tried to push I found the error under Reporting Server Task Log stating "Failed to Authenticate with remote system, system error: The network location cannot be reached. For information about network troubleshooting, see Windows help." Which I'm assuming the licenses is what was blocking the communication.

               

              Thanks for the information on the SQL Express 4 GB limit. I'll have to look into that more. I wonder approxamately how many machines that would be.

               

              Thanks all for responding and willing to help.

              • 4. Re: ePO 4.0 server only accpeting 37 systems
                Sailendra Pamidi

                Hi,

                  There is no license 'limitation' as to the number of machines that can communicate to ePO. From what you mention, the agent push failed because of network issues. You can try doing the push again after checking the basic connectivity to the client machines.

                 

                Also make sure that admin$ share is enabled on the target systems as well netbios ports for 'File and Print Sharing' to ensure that FramePkg.exe is copied over successfully during the 'Push'.

                • 5. Re: ePO 4.0 server only accpeting 37 systems
                  dries

                  Regarding the 4GB SQL Express limit, it is not so much the number of systems under management as it is a matter of how many events are generated over what timeframe. 4GB is a lot of space, but there are many variables that contribute to how it is used and best practices for database management.

                   

                  I am sure several of the community members have experiences they can share with DB management.

                  • 6. Re: ePO 4.0 server only accpeting 37 systems

                    Interesting. Now that you say that I've went back and check and I now have 40 systems reporting and the Security Keys for Agent-server secure communication key: are showing 29 and 11agents.

                     

                    I know the first time I tried to push the agent the admin$ share has been disabled I tried to enable it and it still failed. I'm not sure about the netbios port though. On my two test systems I also tried to create an "agent installation package" and ran that on them. At the time I couldn't get the ePO serer to communicate with them even after running that. But now those two are part of the 40 systems that are reporting.

                     

                    So a few questions.

                     

                    1. I'm assuming the admin$ has to be shared and there is no way around that. Our standard build has that disabled by default so even though I might get it to work on a test system I don't think that will be the way to deploy.

                     

                    2. Since I created that agent installation package when I run that on a system do I have to add the system to the ePO server or will it automatically report to the ePO server in some random time?

                     

                    3. Once that agen installation package is ran on a system is there any way to force it or the ePO server to make contact to ensure it's functioning?

                     

                    Thanks again for all the help. This is really helping me out.

                    • 7. Re: ePO 4.0 server only accpeting 37 systems
                      GWIRT

                      1. Correct, the agent can only be "pushed" through the admin$ share.

                       

                      2. The client will automatically report to ePO within 10 minutes of installation and populate in the System Tree based on the sorting criteria.

                       

                      3. Once the agent checks in, you can click on the "Show Agent Log" to view the log.

                       

                      Hope this helps!

                       

                       

                      Message was edited by: Greg Wirt on 11/4/09 1:24 PM
                      • 8. Re: ePO 4.0 server only accpeting 37 systems

                        Thanks everyone this has seemed to really help out. I've ran the Agent file that I've created on two other systems. Even though I haven't figured out the timing yet on when they report to the ePO server they do eventually report to the ePO server. One of them I waited for 2 hours and it didn't report I rebooted it and after about 20 minutes after the reboot it finally showed up in the ePO server. The other one I haven't rebooted and it still hasn't shown up in the ePO server. No big deal though. I now have 41 systems reporting to my ePO server. so I think everything is working as expected now.

                         

                        Thanks again for everyone's help.