1 2 Previous Next 12 Replies Latest reply on Oct 20, 2009 7:15 AM by JoeBidgood

    Problems installing ePO 4.0 Patch 5

      Hi, was wondering if anyone else was having issues with the Patch 5 upgrade?

      My upgrade goes through right to the end where it's saying Starting new McAfee Services and then stops, stating "The Wizard was interrupted before McAFee EPO could be completely installed".

      I'm logged on the server with a local admin account and am running the Patch with a ePO Global Admin account. We do have VirusScan 8.5i setup on the server with the option to stop services being uninstalled

      I'm upgrading from Patch 1 (Build 1083).

      In the install logs, the last few lines before it stops are as follows

      Property(S): SourcedirProduct = {AF05AA5C-1B53-45DE-9FFD-8F37F329A4BC}
      Property(S): SOURCEDIR = K:\Anti Virus\ePolicy\Products\ePolicy Orchestrator\4.0\ePO 4 Patch 5\
      Property(S): Prod_StartOldServices = **********
      Property(S): Prod_RemoveFromRepoistoryRollback = **********
      Property(S): Prod_RemoveFromRepoistory = **********
      === Logging stopped: 19/10/2009 12:10:27 ===
      MSI (c) (24:CC) [12:10:27:565]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: 0
      MSI (c) (24:CC) [12:10:27:565]: MainEngineThread is returning 1602
      === Verbose logging stopped: 19/10/2009 12:10:27 ===


      Has anyone had a similar issue.

      I would log a support call but after supporting ePolicy since 2002, I'd rather chew my leg off than give it to Tier 1/2 again and spend a week complaining at them that they know nothing before I complain again!!

      Thanks in advance
        • 1. RE: Problems installing ePO 4.0 Patch 5
          JoeBidgood
          The MSI log files make finding things a little more... interesting :)

          If yous earch the file for FAILURE: you should see something a bit more useful... what do you get?

          HTH -

          Joe
          • 2. RE: Problems installing ePO 4.0 Patch 5


            Hi Joe, thanks for the response. This is the only FAILURE entry (although the word failre is mentioned within some other entries).

            1: FAILURE: In LaunchAppAndWait while trying to run the following program:
            "D:\mcafee\epo\jre\bin\java.exe"
            Return code: 1
            Error Message: Incorrect function.

            Any ideas?

            Cheers,
            Gav
            • 3. RE: Problems installing ePO 4.0 Patch 5
              JoeBidgood
              Okay, thanks. Under the logs folder you should have a "Troubleshooting" folder - are there any errors logged in any of these additional logs? (Maybe the epo-patch.log?)
              • 4. RE: Problems installing ePO 4.0 Patch 5
                Hi Joe,

                There are no other entries unfortunately - nothing in the EPO400 Troubleshoot directory and the only other file I've got is EPO400 Error.ini which shows the following:


                [ErrorLog]
                ErrorString=FAILURE: In LaunchAppAndWait while trying to run the following program:
                "D:\mcafee\epo\jre\bin\java.exe"

                Return code: 1
                Error Message: Incorrect function.
                • 5. RE: Problems installing ePO 4.0 Patch 5
                  JoeBidgood
                  Hm. I would have expected to see a few more logs than that...

                  One thing that we have seen is that having the AutoClose option enabled for the ePO DB can interfere with patch installation - I was looking for the ePO-patch.log to confirm that it was this, but in the absence of the file it's worth checking anyway. If autoclose is set to True, please set it to False, restart the SQL server, and try the patch install again.

                  Beyond that there is a master KB article for these types of errors, which is KB 60569 - I would go through this and see if anything is applicable to your situation.

                  HTH -

                  Joe
                  • 6. RE: Problems installing ePO 4.0 Patch 5


                    I've tried that, changing the AutoClose option to False, restarting the SQL Server and running the patch again but with no success.

                    I'll have a look through that article instead. Thanks for the help, Gavin
                    • 7. RE: Problems installing ePO 4.0 Patch 5
                      Hi, I have tried again with VirusScan and Framework services stopped and it's failed again but under the Troubleshooting Logs area, in a core-patch.log file, I have the following info:


                      BUILD FAILED
                      D:\mcafee\epo\Installer\core\build.xml:444: java.sql.SQLException: Could not allocate space for object 'OrionExtensionsBackup' in database 'ePO4_ACO-SHEFFORD-2' because the 'PRIMARY' filegroup is full.

                      Total time: 2 seconds


                      I'm not really a database person. Any ideas on this?
                      • 8. RE: Problems installing ePO 4.0 Patch 5
                        JoeBidgood
                        Ah! That's more like it :)

                        As the message implies, the DB has run out of space, either because you've run out of disk space, or run into a DB size limit (either manually configured, or the hard-coded limit in the free versions of SQL - 2GB for MSDE, 4GB for SQL Express.)

                        How big is your db? Are you using one of the free versions? (If it was installed as part of the ePO install then yes, you are.)

                        If you've run into a db size limit I'd rerecommend freeing up some space by removing old events and then trying it again (or removing / increasing the limit if it's a manually-configured limit.)

                        HTH -

                        Joe
                        • 9. RE: Problems installing ePO 4.0 Patch 5
                          Hi Joe,

                          That's great info - I've checked the MSDE database we have and it's near the limit (1.94GB) so in the short term I'll need to clear down the events, as you have suggested.

                          I've just found out how to purge these and I've purged the old event logs, server task logs and some old audit logs.

                          The database doesn't seem to have gone down in size. How to I compact it (sorry, really not a database guru).
                          1 2 Previous Next