1 Reply Latest reply on Jul 10, 2017 9:38 AM by aarmstro

    Agent 5.0.5.658 Upgrade fails

    pstuart

      I am currently running MA 4.8.0.1995 on my CentOS & Red Hat systems, upgrading to 5.0.5.658.  Both client tasks and local attempts to install fail:

       

      Preparing...                          ################################# [100%]

              package MFErt-2.0-2.i686 is already installed

      error: Failed dependencies:

              libz.so.1 is needed by (installed) cracklib-2.9.0-11.el7.i686

      starting ma service...

      ./5.0.5.658_T53_rpm.sh: line 743: /etc/init.d/ma: No such file or directory

      MA Start Failed

       

      I attempted to yum remove MFEcma MFErt and found two dependencies: pam-1.1.8-18.el7.i686 and cracklib-2.9.0-11.el7.i686.  On a test system, I went ahead and removed the two packages and was able to update MA to 5.0.5.658.  The only package I am aware of that requires the pam.i686 is VSEL, which we have the web monitor disabled by policy.  While this workaround is successful, it is not feasible for 100+ systems.  Suggestions? Ideas? Comments?