6 Replies Latest reply on Aug 26, 2009 6:47 AM by PhilR

    Multiple versions of VSE in repository - is it possible?

      We so we currently have VSE 8.5 patch 6 in production in our environment. We're getting ready to upgrade to ePO 4.5 and then we'll be rolling VSE 8.7 out. Is it possible to check in 8.7 while 8.5 is still there or will it overwrite the older version? I know the agent only allows one version to be installed at a time, wasn't sure if a product like VSE was the same or not.
        • 1. RE: Multiple versions of VSE in repository - is it possible?
          Yea, you can do it, just check it in, nothing gets overwritten.

          Currently I have 8.0, 8.5 and 8.7 checked in, it's all good and intended to work that way.

          I deploy 8.5 for server and deploy 8.7 for workstations.

          The new software won't deploy unless you tell it to, so it is perfectly safe to check it in.
          • 2. RE: Multiple versions of VSE in repository - is it possible?
            Yep we have 8.5 and 8.7 checked into our EPO server.

            Just make sure you know to taylor both sets of policies happy
            • 3. RE: Multiple versions of VSE in repository - is it possible?
              Yup totally possible...

              I'm running 8.0 and 8.7 in my repository, 8.0 sitting there redundant.
              • 4. RE: Multiple versions of VSE in repository - is it possible?

                I was kind of hoping there was a way to upgrade, or migrate our 8.5 policies to 8.7. Is there a way to convert or copy these policies or am I going to have to go through and manually setup all of the 8.7 policies?
                • 5. RE: Multiple versions of VSE in repository - is it possible?
                  You can run the ePOPolicyMigration.exe that comes inside the zip file for VSE8.7.

                  Migrating policies and events in ePolicy Orchestrator


                  •Issue

                  The Policy Migration tool (ePOPolicyMigration.exe) upgrades VirusScan Enterprise polices and tasks from an earlier version of VirusScan Enterprise. This tool runs only one time per server. If you have both the VirusScan Enterprise 8.0i .NAP file and the 8.5i .NAP or extension installed on the same server, you must choose whether to upgrade policies and tasks from VirusScan Enterprise 8.0i or 8.5i. You cannot upgrade both.

                  Choose only one of these upgrade scenarios:

                  ◦When upgrading VirusScan Enterprise 8.5i policies and tasks in ePolicy Orchestrator 3.6.1, first check in the .NAP file, then execute the Policy Migration tool on the server.

                  ◦When upgrading VirusScan Enterprise 8.5i policies and tasks in ePolicy Orchestrator 4.0, first check in the extension, then execute the Policy Migration tool on the server.

                  ◦When upgrading VirusScan Enterprise 8.0i policies and tasks, use the command-line option with the force switch as follows: ePOPolicyMigration.exe /force80

                  NOTE: You can upgrade more than one version of the VirusScan Enterprise software to a later version in ePolicy Orchestrator, but you can upgrade only one version of VirusScan Enterprise policies and tasks to a later version.
                  •Issue

                  Some Access Protection policies do not migrate when using ePOPolicyMigration.exe to migrate VirusScan Enterprise policies from an older version to a newer version of the product. See McAfee Support KnowledgeBase article 616156 for more information about this issue.

                  •Issue

                  VirusScan Enterprise 8.7i events do not appear after migrating from ePolicy Orchestrator 3.6.1 to ePolicy Orchestrator 4.0. See McAfee Support KnowledgeBase article 616597 for more information about this issue.
                  • 6. RE: Multiple versions of VSE in repository - is it possible?
                    PhilR
                    Read KB66698 before you do anything:

                    https://kc.mcafee.com/corporate/index?page=content&id=KB66698

                    "VirusScan Enterprise 8.7i ePolicy Orchestrator Policy Migration Tool fails with ePO 4.5"

                    "Problem

                    The VirusScan Enterprise 8.7i ePolicy Orchestrator (ePO) Policy Migration Tool does not work with ePO 4.5:

                    Policy settings are not propagated from VSE 8.5i to VSE 8.7i.
                    The My Default policies in all categories are removed for VSE 8.7.

                    Solution

                    This issue has been identified and will be addressed as soon as possible.

                    Until a solution is available, McAfee advises customers to not use the VirusScan Enterprise 8.7i ePO Migration Tool with ePO 4.5.

                    This article will be updated as information becomes available."

                    Oh dear, doesn't anybody test anything these days?

                    Phil