6 Replies Latest reply on Jun 22, 2017 8:53 AM by Peter M

    USB Flash drive attributes read only-cannot repair

    chelsea.m.coker

      I have a flash drive that I only use on one computer.  I work off of it and backup on PC once a month.  This morning, I tried accessing the drive, and it opened just fine.  However, one of the folders is what I would call corrupted.  When I open the folder, it is littered with symbols as file names with extremely weird dates and times.  This is the only folder that is like this.  It has it listed as "Read-only" in attributes in properties, but I cannot get that to change.  This just happened out of nowhere.  Shut down computer last night and it was working fine.  Turned on this morning and it is not working.  I tried doing some command read only resets and scans, but none of the scans I have tried find anything wrong with the drive or its contents.  I have attached a copy of the page when opened to the folder that has been corrupted.  I am not sure corrupt is the correct name, but it is the only way I can describe it.  Sometimes, it also states that I do not have permission to open the files or drive.  If anyone has any suggestions to help me recover all, or some, of the files on that drive in that folder I would be very appreciative.