1 2 Previous Next 16 Replies Latest reply on Aug 3, 2017 2:20 AM by rohithroki

    moncg: monitor gateway is not running

    rohithroki

      Dear Team,

       

      I am getting below error after i have installed VSEL on one of the RHEL 6.5 server

       

      [root@vm1 ~]# /etc/init.d/nails status

      the McAfeeVSEForLinux daemon is running: process information follows

      root     14799  0.0  0.0   4316  1164 ?        Ss   04:12   0:00 /opt/NAI/LinuxShield/libexec/nailsd -c /var/opt/NAI/LinuxShield/etc/nailsd.cfg

      moncg: monitor gateway is not running

      the McAfeeVSEForLinux Apache server does not appear to be running

       

       

       

      Please find the details below

       

      OS details

      Red Hat Enterprise Linux Server release 6.5 (Santiago)

      2.6.32-573.7.1.el6.x86_64 #1 SMP Tue Sep 22 08:34:17 PDT 2015 x86_64 x86_64 x86_64 GNU/Linux

       

      Mcafee agent  version:

      MFEcma-4.8.0-1938.i686

       

      VSEL version :

      McAfeeVSEForLinux 1.9.2.29197-29197-noarch

      Virus definition files 8106.0000

      Virus scanning engine 5800.7501

      Virus scanning engine API 5800.7501

      Apache 2.4.2 (Unix)

      OpenSSL 1.0.1s  1 Mar 2016

      sqlite 2.8.17

       

      I have tried reinstalling the VSEL but i am facing the same issue .

       

      Please find the screenshot when i try to connect through web monitor

       

       

      Kindly help me in fixing the issue.

       

      Regards,

      RKJ

        • 1. Re: moncg: monitor gateway is not running
          rohithroki

          Dear Team,

           

          Can any one help me fixing the above issue .

           

          Regards,

          RKJ

          • 2. Re: moncg: monitor gateway is not running
            aarmstro

            It could be normal .... in 3 scenarios

             

            1) if ePO managed you have the ablity to disable the UI by policy  - VSEL 1.9.2/2.0.3 Policies - <policy applied to machine> - General Policy - Addvanced Tab

                 (on reinstall and same policy is applied you would see same)

             

            2)  If you choose to not to run with monitor in install questions

             

            3) You choose to install even if the Pam32 libs etc are not installed - as per readme

              - If you install McAfee VirusScan Enterprise for Linux on 64-bit RHEL,

                CentOS, or OEL systems, make sure that the 32-bit PAM libraries are

                also installed (pam.i686). You must install:

                  - libgcc (yum install libgcc) library 

                  - pam (yum install pam.i386) library

             

            If you bypassed this in install/silent install this is noted also in readme

             

            Use the SILENT_CONTINUE_INSTALL_ON_PAM_ERROR option only when the 32-bit

            PAM libraries are not present. If you set this flag to "Yes" and continue

            without PAM libraries, the installation monitor component is skipped, and

            the web interface is not available. You can still manage the McAfee

            VirusScan Enterprise for Linux host using McAfee ePO.

            • 3. Re: moncg: monitor gateway is not running
              rohithroki

              Dear aarmstro,

              Thank you for the reply.

              Server has the pam library 32 bit version also installed and libgcc package also.How ever still i am facing the same issue.Server is reporting on the EPO console but details like Mcafee agent version,DAT version is not getting reflected on the EPO due to which server shows as non compliant when generating the reports.

              Earlier i had installed Mcafee Agent MFEcma-4.8.0-1500.i686 and i have installed the version MFEcma-4.8.0-1938.i686 but still the same issue .Please find the screenshot below.

              • 4. Re: moncg: monitor gateway is not running
                aarmstro

                Yeah I also notice that the "Last Communication" column is blank so it looks like the McAfee Agent on the Linux is not communicating to ePO

                Did you deploy the agent directly from ePO??

                Or

                Did you download the ePO Agent Package (install.sh)  from the ePO Repository and run directly on the Redhat Machine?

                • 5. Re: moncg: monitor gateway is not running
                  rohithroki

                  aarmstro

                  Thanks you the reply .I have downloaded the ePO Agent Package (install.sh)  from the ePO Repository and run directly on the Redhat Machine

                   

                  Regards,

                  RKJ

                  • 6. Re: moncg: monitor gateway is not running
                    rohithroki

                    Dear Team,

                     

                    Any help will be much appreciated,

                     

                    regards,

                    RKJ

                    • 7. Re: moncg: monitor gateway is not running
                      rohithroki

                      Dear Team,

                      Any suggestions.

                       

                      We are still having the below issue.

                      Regards,

                      RKJ

                      • 8. Re: moncg: monitor gateway is not running
                        aarmstro

                        If you send down a full props agent wakeup call tot the agent on the problem machine should appear in log

                        /opt/McAfee/cma/scratch/etc/log

                        Is this showing any issue on enforce policy section???

                         

                        Try also sending props from the linux box  by running following command it will give you list of options

                        /opt/McAfee/cma/bin/cmdagent

                        e.g.  /opt/McAfee/cma/bin/cmdagent -P   - this should collect and send props to ePO.

                         

                        Details\Errors will be in "log" file mentioned above - if cmdagent has issue it will be in cmdagent.log at same location.

                         

                        What version dats/engine showing locally??

                        /opt/NAI/LinuxShield/bin/nails --version

                        • 9. Re: moncg: monitor gateway is not running
                          rohithroki

                          Dear aarmstro

                          Please find the logs files related to enforcing

                          2017-06-29 08:29:34 [8992]  (180236)  [Management]  [I] Enforcing policies

                          2017-06-29 08:29:34 [8992]  (180236)  [Management]  [I] None of the policies exists for the software Id LYNXSHLD1920

                          2017-06-29 08:29:34 [8992]  (180236)  [Management]  [I] Legacy Policies exists for the software Id EPOAGENT3700LYNX

                          2017-06-29 08:29:34 [8992]  (180236)    [Plugin]  [I] Going to Enforce Policy

                          2017-06-29 08:29:34 [8992]  (180236)     [events] [I] Creating event interface object

                          2017-06-29 08:29:34 [8992]  (180236)    [Plugin]  [I] Going to Check Software Exists

                          2017-06-29 08:29:34 [8992]  (180236)     [events] [I] deleting event interface object

                          2017-06-29 08:29:34 [8992]  (180236)     [Agent]  [I] Enforcing agent policies

                          2017-06-29 08:29:34 [8992]  (180236)  [Management]  [I] Enforcing management subsystem policies

                          2017-06-29 08:29:34 [8992]  (180236)  [Management]  [I] Properties collection is marked for Maximum

                          2017-06-29 08:29:34 [8992]  (180236)    [MESHCTL] [I] Enforceing mesh policy  port=8083 relayEnabled=0.

                          2017-06-29 08:29:34 [8992]  (180236)    [updsubs] [I] Enforcing updater subsystem policies

                          2017-06-29 08:29:34 [8992]  (180236) [Management] [I] Retrieved current event policies successfully

                          2017-06-29 08:29:34 [8992]  (180236) [Management] [I] Event policies unchanged

                          2017-06-29 08:29:34 [8992]  (180236) [Management] [I] Finished event policy update

                          2017-06-29 08:29:34 [8992]  (180236)     [Agent]  [I] Next Policy Enforcement will be in : 1800 seconds

                           

                          2017-06-29 08:47:00 [8986]  (81926)    [Plugin]  [I] Going to Collect Properties

                          2017-06-29 08:47:00 [8986]  (81926)     [events] [I] Creating event interface object

                          2017-06-29 08:47:00 [8986]  (81926)    [Plugin]  [I] Going to Check Software Exists

                          2017-06-29 08:47:00 [8986]  (81926)    [Plugin]  [E] could not find LYNXSHLD1920 product's manageability operations provider

                          2017-06-29 08:47:00 [8986]  (81926)    [Plugin]  [E] LYNXSHLD1920 Software is not installed

                          2017-06-29 08:47:00 [8986]  (81926)    [Plugin]  [I] Going to Check Software Exists

                          2017-06-29 08:47:00 [8986]  (81926)  [Cryptshim] [I] Successfully freed key data

                          2017-06-29 08:47:00 [8986]  (81926)    [agProps] [I] Setting the properties as :/opt/McAfee/cma : 4.8.0.1938 : 4.8.0.1938 : 30 : 240 : {6A62A37D-9043-E711-875C-A50ACF489DC5} : 8512 : 1 :

                          2017-06-29 08:47:00 [8986]  (81926)     [events] [I] deleting event interface object

                          2017-06-29 08:47:00 [8986]  (81926)     [Agent]  [I] Forward all events request received

                          2017-06-29 08:47:00 [8984]  (49156)    [Pckproc] [I] after wait timeInterval=2147483647

                          2017-06-29 08:47:00 [8984]  (49156)    [Pckproc] [I] start processPackage timeInterval=2147483647

                          2017-06-29 08:47:00 [8984]  (49156)  [Management]  [I] Requested for the Full Props by the Agent

                          2017-06-29 08:47:00 [8986]  (81926)     [Agent]  [I] Verifying agent GUID

                          2017-06-29 08:47:00 [8986]  (81926)     [Agent]  [I] Agent will connect to Server in : 14227 seconds

                          2017-06-29 08:47:00 [8984]  (49156)    [SpiPkgr] [I] Using sequence number 208

                          2017-06-29 08:47:00 [8984]  (49156)     [Agent]  [I] Agent server communication session started

                          2017-06-29 08:47:00 [8984]  (49156)     [Agent]  [I] Package type is propssend package

                          2017-06-29 08:47:00 [8984]  (49156)     [Agent]  [I] Agent is connecting to ePO server

                          2017-06-29 08:47:01 [8984]  (49156)    [imutils] [I] Trying with site: 10.198.32.132:8510

                          2017-06-29 08:47:01 [8984]  (49156)     [naInet] [I] HTTP Session initialized

                          2017-06-29 08:47:01 [8984]  (49156)     [imsite] [I]    Upload from: /opt/McAfee/cma/scratch/Unpack/pkgThuJun291247002017_1662105485.spkg

                          2017-06-29 08:47:01 [8984]  (49156)     [imsite] [I]    Upload response target: /opt/McAfee/cma/scratch/Unpack/pkgThuJun291247002017_1759063610.spkg

                          2017-06-29 08:47:02 [8984]  (49156)     [imsite] [I] NaInet library returned code == 13

                          2017-06-29 08:47:02 [8984]  (49156)     [naInet] [I] HTTP Session closed

                          2017-06-29 08:47:02 [8984]  (49156)     [Agent]  [I] No package received from ePO server

                          2017-06-29 08:47:02 [8984]  (49156)     [Agent]  [I] Agent server communication session over

                          2017-06-29 08:47:02 [8984]  (49156)    [Pckproc] [I] end processPackage timeInterval=2147483647

                          2017-06-29 08:47:02 [8984]  (49156)    [Pckproc] [I] before wait timeInterval=2147483647

                          2017-06-29 08:47:04 [8984]  (49156)    [Pckproc] [I] after wait timeInterval=2147483647

                          2017-06-29 08:47:04 [8984]  (49156)    [Pckproc] [I] start processPackage timeInterval=2147483647

                          2017-06-29 08:47:04 [8984]  (49156)     [Agent]  [I] Received agent ping from ePO server

                          2017-06-29 08:47:04 [8984]  (49156)    [Pckproc] [I] end processPackage timeInterval=2147483647

                          2017-06-29 08:47:04 [8984]  (49156)    [Pckproc] [I] before wait timeInterval=2147483647

                          2017-06-29 08:47:04 [8986]  (81926)     [Agent]  [I] Verifying agent GUID

                          2017-06-29 08:47:04 [8986]  (81926)     [Agent]  [I] Agent will connect to Server in : 0 seconds

                          2017-06-29 08:47:04 [8986]  (81926)        [Asc] [I] m_lastASCITime = 1498740424

                          2017-06-29 08:47:04 [8986]  (81926)     [Agent]  [I] Agent started performing ASCI

                          2017-06-29 08:47:04 [8986]  (81926)     [naInet] [I] HTTP Session initialized

                          2017-06-29 08:47:04 [8986]  (81926)     [imsite] [I] Connecting to site: 10.198.32.132 on port: 8511

                          2017-06-29 08:47:04 [8986]  (81926)     [naInet] [I] HTTP Session closed

                          2017-06-29 08:47:04 [8986]  (81926)  [Management]  [I] Collecting properties

                          2017-06-29 08:47:04 [8986]  (81926)    [Plugin]  [I] Going to Collect Properties

                          2017-06-29 08:47:04 [8986]  (81926)     [events] [I] Creating event interface object

                          2017-06-29 08:47:04 [8986]  (81926)    [Plugin]  [I] Going to Check Software Exists

                          2017-06-29 08:47:04 [8986]  (81926)    [Plugin]  [E] could not find LYNXSHLD1920 product's manageability operations provider

                          2017-06-29 08:47:04 [8986]  (81926)    [Plugin]  [E] LYNXSHLD1920 Software is not installed

                          2017-06-29 08:47:04 [8986]  (81926)    [Plugin]  [I] Going to Check Software Exists

                          2017-06-29 08:47:04 [8986]  (81926)  [Cryptshim] [I] Successfully freed key data

                          2017-06-29 08:47:04 [8986]  (81926)    [agProps] [I] Setting the properties as :/opt/McAfee/cma : 4.8.0.1938 : 4.8.0.1938 : 30 : 240 : {6A62A37D-9043-E711-875C-A50ACF489DC5} : 8512 : 1 :

                          2017-06-29 08:47:04 [8986]  (81926)     [events] [I] deleting event interface object

                          2017-06-29 08:47:04 [8986]  (81926)     [Agent]  [I] Forward all events request received

                          2017-06-29 08:47:04 [8984]  (49156)    [Pckproc] [I] after wait timeInterval=2147483647

                          2017-06-29 08:47:04 [8984]  (49156)    [Pckproc] [I] start processPackage timeInterval=2147483647

                          2017-06-29 08:47:04 [8984]  (49156)  [Management]  [I] Requested for the Full Props by the Agent

                          2017-06-29 08:47:04 [8986]  (81926)     [Agent]  [I] Verifying agent GUID

                          2017-06-29 08:47:04 [8986]  (81926)     [Agent]  [I] Agent will connect to Server in : 14223 seconds

                          2017-06-29 08:47:04 [8984]  (49156)    [SpiPkgr] [I] Using sequence number 209

                          2017-06-29 08:47:05 [8984]  (49156)     [Agent]  [I] Agent server communication session started

                          2017-06-29 08:47:05 [8984]  (49156)     [Agent]  [I] Package type is propssend package

                          2017-06-29 08:47:05 [8984]  (49156)     [Agent]  [I] Agent is connecting to ePO server

                          2017-06-29 08:47:05 [8984]  (49156)    [imutils] [I] Trying with site: 10.198.32.132:8510

                          2017-06-29 08:47:05 [8984]  (49156)     [naInet] [I] HTTP Session initialized

                          2017-06-29 08:47:05 [8984]  (49156)     [imsite] [I]    Upload from: /opt/McAfee/cma/scratch/Unpack/pkgThuJun291247042017_62803106.spkg

                          2017-06-29 08:47:05 [8984]  (49156)     [imsite] [I]    Upload response target: /opt/McAfee/cma/scratch/Unpack/pkgThuJun291247052017_1722208874.spkg

                          2017-06-29 08:47:06 [8984]  (49156)     [imsite] [I] NaInet library returned code == 13

                          2017-06-29 08:47:06 [8984]  (49156)     [naInet] [I] HTTP Session closed

                          2017-06-29 08:47:06 [8984]  (49156)     [Agent]  [I] No package received from ePO server

                          2017-06-29 08:47:06 [8984]  (49156)     [Agent]  [I] Agent server communication session over

                          2017-06-29 08:47:06 [8984]  (49156)    [Pckproc] [I] end processPackage timeInterval=2147483647

                          2017-06-29 08:47:06 [8984]  (49156)    [Pckproc] [I] before wait timeInterval=2147483647

                          2017-06-29 08:47:20 [8988]  (114696)     [Agent]  [I] Forward immediate events request received

                           

                          Please find the output of /opt/NAI/LinuxShield/bin/nails --version

                           

                          McAfeeVSEForLinux 1.9.2.29197-29197-noarch

                          Virus definition files 8106.0000

                          Virus scanning engine 5800.7501

                          Virus scanning engine API 5800.7501

                          Apache 2.4.2 (Unix)

                          OpenSSL 1.0.1s  1 Mar 2016

                          sqlite 2.8.17

                          1 2 Previous Next