2 Replies Latest reply on Jul 14, 2009 9:37 AM by staro30

    ePO 4 Patch 4 install error; Insert Disk 1

      Hi,

      We are trying to install patch 4 for ePO 4. It gets stuck on c:\Program Files\McAFee\epolicy orchestrator\sitemgrwrap.dll

      And asks 'Insert Disk 1' Ok or Cancel.

      Before clicking Ok or Cancel the EPO400-Patch-MSI.LOG shows:

      1: Setup detected that Tomcat is already patched so skipping the registry update.
      1: End MerMod_FixTomcatRegistry
      MSI (s) (60:B0) [10:44:54:328]: Executing op: ActionStart(Name=InstallFiles,Description=Copying new files,Template=File: [1], Directory: [9], Size: [6])
      InstallShield 10:44:54: CallScriptFunctionFromMsiCA() ends
      MSI (s) (60:B0) [10:44:54:343]: Executing op: ProgressTotal(Total=159266994,Type=0,ByteEquivalent=1)
      MSI (s) (60:B0) [10:44:54:343]: Executing op: SetTargetFolder(Folder=C:\Program Files\McAfee\ePolicy Orchestrator\)
      MSI (s) (60:B0) [10:44:54:343]: Executing op: SetSourceFolder(Folder=1\PROGRA~1\McAfee\EPOLIC~1\|program files\McAfee\ePolicy Orchestrator\)
      MSI (s) (60:B0) [10:44:54:343]: Executing op: ChangeMedia(MediaVolumeLabel=ePO4-Patch-4,MediaPrompt=Please insert the disk: 1,MediaCabinet=1\ePOMain.cab,BytesPerTick=32768,CopierType=1,,,SignatureRequire d=0,,,IsFirstPhysicalMedia=1)
      MSI (s) (60:B0) [10:44:54:343]: Executing op: FileCopy(SourceName=SITEMG~1.DLL|SiteMgrWrap.dll,SourceCabKey=sitemgrwrap.dll,D estName=SiteMgrWrap.dll,Attributes=16384,FileSize=176128,PerTick=32768,,VerifyMe dia=1,,,,,CheckCRC=0,Version=4.0.0.1221,Language=1033,InstallMode=126091264,,,,, ,,)
      MSI (s) (60:B0) [10:44:54:343]: File: C:\Program Files\McAfee\ePolicy Orchestrator\SiteMgrWrap.dll; Overwrite; Won't patch; Existing file is a lower version
      MSI (s) (60:B0) [10:44:54:343]: Source for file 'sitemgrwrap.dll' is compressed
      MSI (s) (60:B0) [10:44:54:343]: Re-applying security from existing file.
      MSI (s) (60:B0) [10:44:54:343]: Verifying accessibility of file: SiteMgrWrap.dll
      MSI (s) (60:B0) [10:44:56:015]: Source is incorrect. Package code of Z:\ePO4\ePO400.msi is incorrect.
      MSI (s) (60:B0) [10:44:56:031]: Source is incorrect. Package code of Z:\ePO4\ePO400.msi is incorrect.

      We have tried a different cd but still received the same error. Before clicking on Cancel (it then rolls back) the c:\Program Files\McAFee\epolicy orchestrator folder does not contain sitemgrwrap.dll, should it? I have copied the epo 4 sitemgrwrap.dll into this folder prior to loading the patch but still get the same error. I will add the patch 4 version of sitemgrwrap.dll before actually installing patch 4 to see if that gets round it.

      Anyone seen this or have any other ideas?

      Thanks
      Staro