3 Replies Latest reply on Jul 19, 2017 10:15 AM by aerialjibe

    DLP 11.0.0 BSOD (Blue Screen)

    aerialjibe

      Nice product

       

      When using a encrypted key Kingston DataTraveler Vault Privacy together with DLP11.0.0 the system has a BSOD on the moment the Kinston software asks for a password (DTVP_Launcher).

      I did find an issue with DLP and Kingston in the past but this is another problem (https://kc.mcafee.com/corporate/index?page=content&id=KB85533&snspd-0915)

       

      Arrrgggg.......

       

      We are trying to get Windows10 1703 supported by McAfee and used:

      DLP10.0.230... Chrome didn't work.

      DLP10.0.250... IE didn't work.

      DLP10.250.92... We skipped this because DLP11.0.0 was available...

      DLP11.0.0... can't use our allowed secure Datatraveler sticks

       

      Please provide a new version...

        • 1. Re: DLP 11.0.0 BSOD (Blue Screen)
          aerialjibe

          Hi,

           

          To help McAfee to solve this problem I did some extra checks.

           

          Test 02:

          • Clean install Windows10_1703.
          • Installed McAfee suite:
            Agent 5.0.5.658
            Drive Encryption: Windows 7.2.1.16
            Endpoint Security Firewall 10.5.1.1064 
            Endpoint Security Threat Prevention 10.5.1.1261 
            Endpoint Security Platform 10.5.1.1190 
            Drive Encryption Agent 7.2.1.16
          • Installed DLP10.250.92.
          • Removed DLP10.250.92.
          • Installed DLP11.0.0.1162
          • Test with Kingston Datatraveler Vault Privacy (8GB) stick

          => BLUE SCREEN!!!

           

           

          Test 02:

          • Clean install Windows10_1703.
          • Installed McAfee suite:
            Agent 5.0.5.658
            Drive Encryption: Windows 7.2.1.16
            Endpoint Security Firewall 10.5.1.1064 
            Endpoint Security Threat Prevention 10.5.1.1261 
            Endpoint Security Platform 10.5.1.1190 
            Drive Encryption Agent 7.2.1.16
          • Installed DLP10.250.92.
          • Test with Kingston Datatraveler Vault Privacy (8GB) stick

          => All OK

           

          Test 03:

          • Clean install Windows10_1703.
          • Installed McAfee suite:
            Agent 5.0.5.658
            Drive Encryption: Windows 7.2.1.16
            Endpoint Security Firewall 10.5.1.1064 
            Endpoint Security Threat Prevention 10.5.1.1261 
            Endpoint Security Platform 10.5.1.1190 
            Drive Encryption Agent 7.2.1.16
          • Installed DLP11.0.0.1162
          • Test with Kingston Datatraveler Vault Privacy (8GB) stick

          => All OK

           

          Test 04:

          • Clean install Windows10_1703.
          • Installed McAfee suite:
            Agent 5.0.5.658
            Drive Encryption: Windows 7.2.1.16
            Endpoint Security Firewall 10.5.1.1064 
            Endpoint Security Threat Prevention 10.5.1.1261 
            Endpoint Security Platform 10.5.1.1190 
            Drive Encryption Agent 7.2.1.16
          • Installed DLP10.250.92.
          • Removed DLP10.250.92.
          • Installed DLP10.250.92.(again)
          • Test with Kingston Datatraveler Vault Privacy (8GB) stick

          => All OK

           

          I really hope McAfee can find the reason why after upgrading to DLP11 (from DLP10) the system is not functioning correctly.
          We can deploy DLP11 on W10 systems but have to know that if we use DLP11 and upgrade is later our Kinston Datatraveler sticks still work. We have ~1000 users that use such a stick.

           

          Regards,

          Jacques.

          • 2. Re: DLP 11.0.0 BSOD (Blue Screen)
            aerialjibe

            Dear all,

             

            A case was created for this.

            The problem seems related to Drive Encryption.

             

            I tested even some more steps.

             

            Test 11 :

            • Clean install Windows10_1511.

             

            • Installed McAfee suite:
              Agent 5.0.5.658
              Drive Encryption: Windows 7.1.3.604
              Drive Encryption Agent 7.1.3.604
              HIPS 8.0.0.4210
              VSE 8.8.0.1804
              DLP 9.3.600.32
              Test with Kingston Datatraveler Vault Privacy (8GB) stick
              => OK

             

            • Installed McAfee suite:
              Endpoint Security Firewall 10.5.1.1038 
              Endpoint Security Threat Prevention 10.5.1.1184
              Endpoint Security Platform 10.5.1.1147 
              Test with Kingston Datatraveler Vault Privacy (8GB) stick
              => Blue Screen!!  (even without removing or upgrading DLP)

             

            • Removed HIPS 8.0.0.4210
              Test with Kingston Datatraveler Vault Privacy (8GB) stick
              => Blue Screen!!  (even without removing or upgrading DLP)

             

            • Upgrade Drive Encryption:
              Drive Encryption: Windows 7.2.1.16
              Drive Encryption Agent 7.2.1.16
              system restart (just to make sure that DE is functioning correctly)
              Test with Kingston Datatraveler Vault Privacy (8GB) stick
              => Blue Screen!!  (even without removing or upgrading DLP)

             

            • Remove Drive Encryption:
              Removed: Drive Encryption: Windows 7.2.1.16
              Removed: Drive Encryption Agent 7.2.1.16
              Test with Kingston Datatraveler Vault Privacy (8GB) stick
              => OK

             

            • Upgrade DLP:
              Installed DLP 11.0.0.1162
              Test with Kingston Datatraveler Vault Privacy (8GB) stick
              => OK

             

            Indeed after removing DE inserting the key and starting the Datatraveler app doesn’t trigger the Blue Screen.

            I expect McAfee also has or can get a Kingston Datatraveler key and can do further testing in their own testlabs.

             

            Regards,

            Jacques