1 Reply Latest reply on Jul 9, 2009 4:19 AM by vikram.gupta

    LINUX cma connection problem

      Hi,
      I am facing some problem in epo -> cma connection.

      I am using epo 4.0 (on windows server 2k3, service pack 1).
      After installing cma agent on a linux machine (version: MFEcma-4.0.0-1298) and have added the system in epo server.

      cma service is running fine on LINUX machine:

      [root@Betaal-lnx etc]# service cma status
      cma (pid 4426) is running...

      Both the machines are on the same network (WORKGROUP)

      First I was getting an error saying "Authentication failure....", so after searching a few post here, I got to know that this can be resolved by deleting the "sitecache.bin" file on LINUX machine. That worked fine, but now I am stuck with some other error... :(

      Here are the error logs (from /opt/McAfee/cma/scratch/etc/logs)

      2009-07-08 21:25:23 [4429] [Agent] [I] Agent is connecting to ePO server
      2009-07-08 21:25:23 [4429] [persite] [I] Cache file location = /opt/McAfee/cma/scratch/etc/sitecache.bin
      2009-07-08 21:25:24 [4429] [naInet] [I] HTTP Session initialized
      2009-07-08 21:25:24 [4429] [bldtrob] [E] Error trace:
      2009-07-08 21:25:24 [4429] [imsite] [E] [uploadFile,,/spipe/pkg?AgentGuid={B40F7988-D56B-DE11-87C6-C109F8E51100}&Source =Agent_3.0.0,pkgWedJul81555202009_820259750.spkg,/opt/McAfee/cma/scratch/Unpack, /opt/McAfee/cma/scratch/Unpack/pkgWedJul81555232009_362629836.spkg]->
      2009-07-08 21:25:24 [4429] [imsite] [E] [checkBuildTransferObject]->
      2009-07-08 21:25:24 [4429] [bldtrob] [E] [inetmgr::CreateTransferItfFromProperties()]->
      2009-07-08 21:25:24 [4429] [bldtrob] [E] Failed >> Setting naInet transfer option Name =
      2009-07-08 21:25:24 [4429] [imsite] [I] Upload from: /opt/McAfee/cma/scratch/Unpack/pkgWedJul81555202009_820259750.spkg
      2009-07-08 21:25:24 [4429] [imsite] [I] Upload response target: /opt/McAfee/cma/scratch/Unpack/pkgWedJul81555232009_362629836.spkg
      2009-07-08 21:25:24 [4429] [imsite] [E] Error trace:
      2009-07-08 21:25:24 [4429] [imsite] [E] [uploadFile,,/spipe/pkg?AgentGuid={B40F7988-D56B-DE11-87C6-C109F8E51100}&Source =Agent_3.0.0,pkgWedJul81555202009_820259750.spkg,/opt/McAfee/cma/scratch/Unpack, /opt/McAfee/cma/scratch/Unpack/pkgWedJul81555232009_362629836.spkg]->
      2009-07-08 21:25:24 [4429] [imsite] [E] NaInet library returned code == -6
      2009-07-08 21:25:24 [4429] [imsite] [E] Error trace:
      2009-07-08 21:25:24 [4429] [imsite] [E] [uploadFile,,/spipe/pkg?AgentGuid={B40F7988-D56B-DE11-87C6-C109F8E51100}&Source =Agent_3.0.0,pkgWedJul81555202009_820259750.spkg,/opt/McAfee/cma/scratch/Unpack, /opt/McAfee/cma/scratch/Unpack/pkgWedJul81555232009_362629836.spkg]->
      2009-07-08 21:25:24 [4429] [imsite] [E] NaInet library returned code == -6
      2009-07-08 21:25:24 [4429] [imsite] [E] Error trace:
      2009-07-08 21:25:24 [4429] [imsite] [E] [uploadFile,,/spipe/pkg?AgentGuid={B40F7988-D56B-DE11-87C6-C109F8E51100}&Source =Agent_3.0.0,pkgWedJul81555202009_820259750.spkg,/opt/McAfee/cma/scratch/Unpack, /opt/McAfee/cma/scratch/Unpack/pkgWedJul81555232009_362629836.spkg]->
      2009-07-08 21:25:24 [4429] [imsite] [E] The naInet library returned an error. [Parent error: NaInet library returned code == -6]
      2009-07-08 21:25:24 [4429] [naInet] [I] HTTP Session closed
      2009-07-08 21:25:24 [4429] [Agent] [E] Agent failed to communicate with ePO server
      2009-07-08 21:25:24 [4429] [Agent] [I] Agent server communication session over

      and logs from EPO server:

      20090708155803 I #3396 EPOJNI Getting license data...
      20090708155817 I #5256 EPOJNI Processing console request file F:/PROGRA~1/McAfee/EPOLIC~1/DB/Request/299BDF2543390B54DA5DA8FF2F144A38/console .req
      20090708155817 I #5256 usermgr Attempting to add user: MCAFEE-HA5OQMRT\administrator
      20090708155817 I #5256 usermgr Current user: SYSTEM
      20090708155817 I #5256 EPOJNI Begin agent wake up processing thread
      20090708155817 I #5256 usermgr Attempting to add user: MCAFEE-HA5OQMRT\administrator
      20090708155817 I #5256 usermgr Current user: SYSTEM
      20090708155817 I #5256 EPOJNI Getting configure info from F:\PROGRA~1\McAfee\EPOLIC~1\DB\Server.ini
      20090708155817 I #5256 EPOJNI Initialize work queue with 5 threads
      20090708155817 I #5972 EPOJNI Server failed to wake up using IP... Adding to WorkQueue, will try DNS, detailed error = 0
      20090708155817 I #5972 EPOJNI Server failed to wake up using DNS... Adding to WorkQueue, will try NETBIOS, detailed error = 0
      20090708155817 I #5972 EPOJNI Wake up agent on NetBIOS name BETAAL-LNX...
      20090708155822 I #5256 EPOJNI Deleting console request file F:/PROGRA~1/McAfee/EPOLIC~1/DB/Request/299BDF2543390B54DA5DA8FF2F144A38/console .req


      Searching on net couldn't help...:(

      If any one has any idea of this, please let me know....
      If some other logs or any thing else about the two systems is required, let me know and I will update it here...

      Thanks
      Vikram
        • 1. RE: LINUX cma connection problem
          I think the problem is because of some configuration issue. The same epo server is connecting fine with Windows cma. Moreover, when I issue "wake up agent" command from epo server, the server log (reporting -> server task logs) says that it completed successfully.

          7/9/09 2:25:37 PM Less than a minute Wake Up Agents admin Completed

          The error in logs starts coming after the agent tries to set "naInet transfer option Name". Also there is some error saying "socket getting closed".....


          2009-07-09 17:41:40 [4323] [naInet] [I] HTTP Session initialized
          2009-07-09 17:41:40 [4323] [bldtrob] [D] Setting naInet transfer option Server = :80
          2009-07-09 17:41:40 [4323] [bldtrob] [D] Setting naInet transfer option ServerName = :80
          2009-07-09 17:41:40 [4323] [bldtrob] [D] Setting naInet transfer option ServerIP = :80
          2009-07-09 17:41:40 [4323] [bldtrob] [D] Setting naInet transfer option Name =
          2009-07-09 17:41:40 [4323] [bldtrob] [E] Error trace:
          2009-07-09 17:41:40 [4323] [imsite] [E] [uploadFile,,/spipe/pkg?AgentGuid={D6BDB91E-7E6C-DE11-87C6-4109F8E51100}&Source =Agent_3.0.0,pkgThuJul91211362009_1613084927.spkg,/opt/McAfee/cma/scratch/Unpack ,/opt/McAfee/cma/scratch/Unpack/pkgThuJul91211392009_31700624.spkg]->
          2009-07-09 17:41:40 [4323] [imsite] [E] [checkBuildTransferObject]->
          2009-07-09 17:41:40 [4323] [bldtrob] [E] [inetmgr::CreateTransferItfFromProperties()]->
          2009-07-09 17:41:40 [4323] [bldtrob] [E] Failed >> Setting naInet transfer option Name =
          2009-07-09 17:41:40 [4323] [bldtrob] [D] Setting naInet transfer option RelativePath = Software
          2009-07-09 17:41:40 [4323] [imsite] [D] Successfully instantiated naInet::TransferItf
          2009-07-09 17:41:40 [4323] [imsite] [D] assignTransferCredentials
          2009-07-09 17:41:40 [4323] [imsite] [I] Upload from: /opt/McAfee/cma/scratch/Unpack/pkgThuJul91211362009_1613084927.spkg
          2009-07-09 17:41:40 [4323] [imsite] [I] Upload response target: /opt/McAfee/cma/scratch/Unpack/pkgThuJul91211392009_31700624.spkg
          2009-07-09 17:41:40 [4323] [improgr] [D] ImProgress::operator()
          2009-07-09 17:41:40 [4323] [improgr] [D] ImProgress::operator()
          2009-07-09 17:41:40 [4323] [imsite] [E] Error trace:
          2009-07-09 17:41:40 [4323] [imsite] [E] [uploadFile,,/spipe/pkg?AgentGuid={D6BDB91E-7E6C-DE11-87C6-4109F8E51100}&Source =Agent_3.0.0,pkgThuJul91211362009_1613084927.spkg,/opt/McAfee/cma/scratch/Unpack ,/opt/McAfee/cma/scratch/Unpack/pkgThuJul91211392009_31700624.spkg]->
          2009-07-09 17:41:40 [4323] [imsite] [E] NaInet library returned code == -6
          2009-07-09 17:41:40 [4323] [improgr] [D] ImProgress::operator()
          2009-07-09 17:41:40 [4323] [imsite] [E] Error trace:
          2009-07-09 17:41:40 [4323] [imsite] [E] [uploadFile,,/spipe/pkg?AgentGuid={D6BDB91E-7E6C-DE11-87C6-4109F8E51100}&Source =Agent_3.0.0,pkgThuJul91211362009_1613084927.spkg,/opt/McAfee/cma/scratch/Unpack ,/opt/McAfee/cma/scratch/Unpack/pkgThuJul91211392009_31700624.spkg]->
          2009-07-09 17:41:40 [4323] [imsite] [E] NaInet library returned code == -6
          2009-07-09 17:41:40 [4323] [imutils] [D] getErrorText()
          2009-07-09 17:41:40 [4323] [imsite] [E] Error trace:
          2009-07-09 17:41:40 [4323] [imsite] [E] [uploadFile,,/spipe/pkg?AgentGuid={D6BDB91E-7E6C-DE11-87C6-4109F8E51100}&Source =Agent_3.0.0,pkgThuJul91211362009_1613084927.spkg,/opt/McAfee/cma/scratch/Unpack ,/opt/McAfee/cma/scratch/Unpack/pkgThuJul91211392009_31700624.spkg]->
          2009-07-09 17:41:40 [4323] [imsite] [E] The naInet library returned an error. [Parent error: NaInet library returned code == -6]
          2009-07-09 17:41:40 [4323] [naInet] [D] Socket getting closed, Handle -1
          2009-07-09 17:41:40 [4323] [naInet] [I] HTTP Session closed
          2009-07-09 17:41:40 [4323] [Agent] [E] Agent failed to communicate with ePO server
          2009-07-09 17:41:40 [4323] [Agent] [I] Agent server communication session over