1 2 3 Previous Next 22 Replies Latest reply on Dec 23, 2010 10:15 AM by thurmanw1

    Agent upgrade error

    1006
      Hi There,

      Im trying to update my epo agent and for some reason its telling me the following:

      The feature you are trying to use is on a network resource that is unavailable.

      Click OK or try again, or enter an alternate path to a folder containing the installation package 'MFEagent.msi' in the box below.

      Anyone ever had this problem?

      I also tried to downlad a DAT and its telling me the follwing:

      SDStbRes.dll: The specified module could not be found.
        • 1. RE: Agent upgrade error
          tonyb99
          what version is the old one you are trying to upgrade from?

          its not an agent 2 version is it?
          • 2. RE: Agent upgrade error
            1006
            Basically its the same agent.. But nothing was showing up in the EPO dashboard so i decided to uninstall the pc from mcafee and re install the software again.

            I am managing to deploy the agent via network but when i try to wake it up its giving me the following:

            2009-07-01 15:13:01.477 INFO Waking up agent xxxx using NetBIOS
            2009-07-01 15:13:03.417 ERROR Unknown error contacting agent
            2009-07-01 15:13:03.417 ERROR Wakeup agent failed
            • 3. RE: Agent upgrade error
              tonyb99
              so you are trying to install manually on a workstation rather than just push an install over the top from an epo placeholder?

              what version of agent?
              what OS?
              are you logged in as local admin?
              are you using the /forceinstall option on the framepkg.exe?
              does it have embedded credentials?
              • 4. RE: Agent upgrade error


                I had never seen this problem before, but recently (in the last week) have seen it appear on a number of PCs. I have seen it on PCs when trying to upgrade from 1345 to 1444 or from 1421 to 1444.

                I found how to fix it on an effected PC, using a soloution the McAfee tech told me wouldn't work, but no idea on how to fix it on multiple systems.

                To fix it on a system manually I searched the registry for all McAfee items and delted them, copied the common framework folder from a good machine to the effected PC, then re-installed the agent using a force install. This fixed the problem, but is very time consuming, too much so to do on multiple PCs and cleaning the registry probably not a good idea to do from scripts.


                I did log multiple support calls with mcafee, but it was too frustrating so I gave up on trying to get some actual help from them.....they couldn't offer me ANY soloution on how to fix this error, even though I had multiple mcafee techs do a remote session to the effected PCs that where showing the exact error you describe, they all kept saying they had never seen it before and that there was no info on it.

                I have found that the 1444 agent version is very buggy to install. On many PCs it doesn't install properly through the deployment task, saying that it can't download the framepkg.exe file (where on other machines it works fine). On many PCs it will start the installation ok, then start the agent, but then it doesn't know it is installed, so re-installs it , again, when the next deployment task runs, this loops indefinatley until the PC is rebooted, so obvioulsy it was just waiting for a reboot, ok, fine, but it shouldn't keep downloading the file over and over and over and over etc until it is rebooted, also I have found a 3rd error on multiple systems where it enables the ePO server repository, even though it is set to be unavailable by the agent policy. So for example, repository a and b are available before the agent upgrade, with all other repositories unavailable, but then, after the 1444 agent installs repository a and b are available, all other repositories are unavailable, but, the ePO master repository becomes available also.....the only way I have found to fix that repository issue is to keep re-installing the agent, until eventually it fixies itself!!!

                The combination of the agent keeping trying to download itself over and over and the fact that the master repository became active caused massive amounts of network traffic when installing on my network.

                I hadn't had any of these issues with previous patches, even the 1421, which i just deployed a couple of weeks ago, but then even though that installed ok, and very easily, it stopped all DAT updates occuring because it has a bug which means you can't use it with UNC repositories, so we had to upgrade to 1444 in order to even get DAT updates to work!!!! I mean, how the hell did that bug not come out in testing.....this is our latest and greatest agent version, oh, but it doesn't work if you do something simple like try to update from a simpe unc share.....you what?

                I called mcafee about 10 times in a couple of days for issues related to the installation of the 1444 agent, each time it was like talking to a brick wall. I have 3 clear issues happening on multiple machines, but they kept re-acting to my calls as if each time I called I must be doing something wrong in the way I had setup ePO etc

                I kept telling them, um, the only thing that has changed is the agent, I have the same tasks and setting that i used to install the 1345 agent and then the 1421 agent, its the same tasks and settings, but now i have at least 3 new errors that I have never seen before, all related to agent installation and occuring on multiple PCs, are you sure its not related to the new agent?

                Anyway, YES, I have seen this error you describe, on multiple systems, but only when installing the 1444 agent.....however.....It could be that the problem was initialy caused from the 1345 agent, as, on PCs with the error, you also get the error if you try to run the 1345 package, or, it could be cause by a failure to deploy the agent from ePO, not sure yet.

                anyway, There is certainly some bug here.
                • 5. RE: Agent upgrade error
                  1006
                  Thanks for your help!!

                  My agent is 1421 so i dont know how come its giving me the error. So basically i just do an entire search for anything starting with mcafee and delete? can it mess up anything else on the computer or im fine by that?
                  • 6. RE: Agent upgrade error
                    Yea, I am not sure exacty which version caused the issue, it could have been casued by 1345 and/or higher.

                    McAfee are now emailing me a few times as they have started to show an interest in what I have been reporting to them for the last few days.....though they are a bit late to show interest!!!

                    Well, I uninstalled VSE and antispyware on the PC first, just to avoid stuffing them up.
                    Then I did a search and delete on all McAfee entries as you say.
                    Then I copied the common framework folder from another PC to the problem one.
                    (it didn't copy all files, some where in use, but whatever ones it did copy where enough to fix it).

                    After doing that I then did a force install on the agent, and it installed ok that time.

                    I did a lot of other tests/experiments, but those steps proved to be the one that work.

                    Now, how you would go about doing that on multiple PCs, I have no idea.
                    I tried it on 3 PCs manully and it worked ok for them.

                    The PCs that showed that error also wouldn't upgrade via ePO either, that is why i went to try to install it manually, to see what was going on. The product deployment task wouldn't work on them, when I try to install manually, I get the same error you are getting...

                    Please try and see if it works.

                    Also, doing a frminst remove agent doesn't uninstall the agent on those PCs either, when you try to uninstall you get the same error message.
                    So there is no way to uninstall or re-install the agent.
                    If you copy the file it is looking for from another PC and point it to that file, well, it still doesn't work, it just asks for the file again.
                    The McAfee techs had no luck when they where on the PCs either.......I tried 3 different techs, they all said they had never seen it and had no information.....there is certainly a bug in the version 4 agent somewhere.....

                    Certainly nothing was wrong with the setup as ePO, as all works well for the majority of systems, and tasks are still the same as have been used fine for the last couple of years, I had it all running nice and smooth.....it was only when upgrading from 1435 upwards that things started to behave badly......some systems didn't update from 1435 to 1421, everything that updated to 1421 then started failing to update DATs, i mean, what is the deal with that.....still sore that that issue got through testing.......agent doesn't update DATs from UNC repository.....you'd think that would be uncovered before it was released....
                    • 7. RE: Agent upgrade error
                      1006
                      Thanks for your help I will try it within the hour and let you know!

                      Thanks again!
                      • 8. RE: Agent upgrade error
                        1006
                        Well unfortunatly didnt work for me.. This is what i did:

                        Regedit and searched for mcafee and deleted everything with mcafee.

                        Coppied Programfiles/mcafee onto the computer
                        coppied C:\Documents and Settings\All Users\Application Data\mcafee

                        went to cmd and entered the following: framepkg.exe /install=agent /forceinstall

                        once it starts installing itself tells me the following:

                        The featue you are trying to use is on a network resource that is unavailable.

                        Click OK to try again, or enter an alternate path to a folder containing the installation package 'MFEagent.msi' in the box below.

                        when i gibe it the path it gives me an error:

                        The pathe C:\Documents and Settings\All Users\Application Data\McAfee\Commonframework\MFEagent.msi is not a vaild installation package for the product. Try to find the installation package 'MFEagent.msi' in a folder which you can install.

                        Error 1714. The older version of McAfee Agent cannot be removed. Contact your technical support group.


                        Any idea what needs to be done??
                        • 9. RE: Agent upgrade error
                          hmm not sure,

                          After I cleared the registry (which took forever) the only folder I copied was the c:\program files\mcafee\common framework folder, from a PC that worked ok to the faulty PC.

                          Then after that I rebooted the PC and the agent install ran ok (in my cases)

                          I didn't coppy the application data folder, actually I had already deleted it when trying something else I think
                          1 2 3 Previous Next