9 Replies Latest reply on Jun 21, 2009 12:54 AM by thedevil

    Problem with the SOFTWARE tab on EPO

      When clicking on the SOFTWARE tab on the EPO interface, I recieve the following error msg:
      "An unexpected error occurred":



      On the DASHBOARDS tab, under the Master Repository Status, DAT and Engine appear as "Not presented":


      When trying to create a Product Deployment client task, I have no option to select any software to deploy:


      We have EPO for more than half a year now, and never faced this problem before.
      Our organization uses 1 main server and 2 CLUSTER servers.

      Thank you for any help.
        • 1. RE: Problem with the SOFTWARE tab on EPO
          epo909
          Hi.

          That was a clean install? Or an upgrade?
          At the login screen, do you get any error message, regarding software problems?

          Check if the directory structure of '*\Program Files\McAfee\ePolicy Orchestrator\DB\Software' is OK.

          Seems like your master repository is the problem.

          Best Regards,
          RD
          • 2. The DB folder location
            It seems that the DB\Software is located at E:\epo\ePOCluster
            I don't get any error message regarding software problems when I log in.
            • 3. RE: The DB folder location
              tonyb99
              what patch version of epo 4?
              • 4. RE: The DB folder location
                patch 3
                • 5. RE: The DB folder location
                  tonyb99
                  no recent changes to anything, no software checked in etc?
                  • 6. RE: The DB folder location
                    no recent changes to anything except device policy.
                    I looked at the SERVER log and found the following error message:
                    Does it have any realation to my issue?
                    P.S. is there any other log file where I can look for the problem?

                    20090618161750 E #7576 DAL COM Error :80040e2f DAL2_CProductProperty::SaveAllSections
                    20090618161750 E #7576 DAL Meaning = IDispatch error #3119
                    20090618161750 E #7576 DAL Source = Microsoft OLE DB Provider for SQL Server
                    20090618161750 E #7576 DAL Description = Violation of UNIQUE KEY constraint 'PK_EPOProductSettings'. Cannot insert duplicate key in object 'dbo.EPOProductSettings'.
                    20090618161750 E #7576 EPOServer Failed to save all sections for product properties! Err=-15
                    20090618161750 E #7576 EPOServer Failed to process product properties
                    20090618161750 E #7576 EPOServer naimserv::servdal_ModifyAgentProps: Modify agent props failed!
                    20090618161750 E #7576 mod_epo Failed to process agent request
                    • 7. RE: The DB folder location
                      tonyb99
                      your error message corresponds to this: https://kc.mcafee.com/corporate/index?page=content&id=KB60891&actp=search&search id=1245335460960

                      what db are you running? is this an upgrade from 3.6.1 to 4.0?
                      • 8. RE: The DB folder location
                        epo909
                        I had those errors in the past and the solution was to upgrade the hardware in the DB server, it seems that ePO4 migration consumes a lot of DB processing.
                        However I never upgraded to SQL 2005 or had those master repository errors.

                        It would be great if thedevil could post some of the contents of epoapsvr.log.
                        • 9. Here are some of the contents of epoapsvr.log
                          I looked at the epoapsrv.log and found some errors:
                          20090621015953 I #1440 usermgr Attempting to add user: administrator
                          20090621015953 I #1440 usermgr Current user: SYSTEM
                          20090621015956 I #1440 usermgr Attempting to add user: administrator
                          20090621015956 I #1440 usermgr Current user: SYSTEM
                          20090621015959 I #1440 SiteMgrWrap Created instance of Site Manager
                          20090621015959 I #1440 usermgr Attempting to add user: administrator
                          20090621015959 I #1440 usermgr Current user: SYSTEM
                          20090621015959 I #1440 SiteMgr SetEPOMode: SiteMgr enter ePO mode, server=MCAFEE-02, port=8443, EPOUser=, Password=********
                          20090621015959 I #1440 usermgr Attempting to add user: administrator
                          20090621015959 I #1440 usermgr Current user: SYSTEM
                          20090621015959 I #1440 SiteMgr DALInit: Connected to DAL successful
                          20090621015959 I #1440 SiteMgr SetEPOMode: Set ePO mode successful
                          20090621015959 I #1440 SiteMgr ReplicationThreadProc: Replication thread started
                          20090621015959 I #1440 SiteMgr ReplicationThreadProc: Replication using 12 threads
                          20090621015959 I #1440 SiteMgr Replication Temp dir: C:\WINDOWS\TEMP\naiDFCC.tmp\00000000, 1
                          20090621020002 I #1440 SiteMgr Relication on ePO server, skip download from master site
                          20090621020002 I #1440 SiteMgr Replication determining master site size
                          20090621020002 e #1440 SiteMgr Failed to verify file hash for file E:/epo/EPOCLU~1/DB\Software\catalog.z , downloaded file hash: D587615910EBD74AD03781A5FD32B4D09356C560, expected file hash: 9876B20FCC5F205729461E7FA7DD54A75E6D13E3
                          20090621020002 e #1440 SiteMgr Failed to get the directory tree file size for E:/epo/EPOCLU~1/DB\Software

                          20090621020002 I #1440 SrvEvtInf Generating Event
                          20090621020002 x #1440 SiteMgr SiteMgr main control final release...
                          20090621020354 I #7680 EPOJNI Getting license data...