2 Replies Latest reply on May 21, 2009 10:52 AM by monkey79

    epo 4.0 Upgrade Problems

      I am trying to upgrade from ePO 3.6.1 to ePO 4.0.

      I am receiving the following error during setup.

       

      The Sql Server TCP port does not match the selected database server.

      Correct the problem and try again



      The error log consists of:

      1: Verifying that the Install directory is valid.
      1: Loading the following DLL for Use: [C:\DOCUME~1\harriap\LOCALS~1\Temp\1\{34DFE1AC-DAA0-4B6B-BC56-5A1A9ED11FF6}\CommonSetup.DLL]
      1: Setting the current directory to [C:\DOCUME~1\harriap\LOCALS~1\Temp\1\{34DFE1AC-DAA0-4B6B-BC56-5A1A9ED11FF6}].
      1: String converted successfully to ISO 8859-1 format.
      1: Unloading the following DLL: [C:\DOCUME~1\harriap\LOCALS~1\Temp\1\{34DFE1AC-DAA0-4B6B-BC56-5A1A9ED11FF6}\CommonSetup.DLL]
      1: Setting the current directory to [C:\WINDOWS\SysWOW64].
      1: Start validateePOAdminAccountInfo
      1: End validateePOAdminAccountInfo
      MSI (c) (B4:50) [15:11:18:457]: PROPERTY CHANGE: Adding ORIONADMINPASSWORD property. Its value is '**********'.
      MSI (c) (B4:50) [15:11:18:457]: PROPERTY CHANGE: Adding ORIONADMINVERIFYPASSWORD property. Its value is '**********'.
      1: Start calculateDatabaseNames
      MSI (c) (B4:50) [15:11:18:457]: PROPERTY CHANGE: Adding ORIONDATABASENAME property. Its value is 'ePO4_SL-APTD01'.
      1: Setup is going to use the database name of [ePO4_SL-APTD01] for this installation.
      1: End calculateDatabaseNames
      1: Start validateePODBServerInfo
      1: Loading the following DLL for Use: [C:\DOCUME~1\harriap\LOCALS~1\Temp\1\{34DFE1AC-DAA0-4B6B-BC56-5A1A9ED11FF6}\CommonSetup.DLL]
      1: Setting the current directory to [C:\DOCUME~1\harriap\LOCALS~1\Temp\1\{34DFE1AC-DAA0-4B6B-BC56-5A1A9ED11FF6}].
      1: NT Authenticaiton detected.
      1: Group validation successful.
      1: Unknown failure testing for UDP on the SQL server [LOCALHOST] for instance [] with return code [3]. Trying to connect using port [1433].
      1: Successful connection to MSDE/SQL server [LOCALHOST] for instance [] on port [1433].
      1: Successful connection to MSDE/SQL server [LOCALHOST] for instance [] on port [1433].
      1: SQL instance [] does not match the port [1433] being used.
      1: Unloading the following DLL: [C:\DOCUME~1\harriap\LOCALS~1\Temp\1\{34DFE1AC-DAA0-4B6B-BC56-5A1A9ED11FF6}\CommonSetup.DLL]
      1: Setting the current directory to [C:\WINDOWS\SysWOW64].
      1: End validateePODBServerInfo
      1: Start validateePODBServerInfo
      1: Loading the following DLL for Use: [C:\DOCUME~1\harriap\LOCALS~1\Temp\1\{34DFE1AC-DAA0-4B6B-BC56-5A1A9ED11FF6}\CommonSetup.DLL]
      1: Setting the current directory to [C:\DOCUME~1\harriap\LOCALS~1\Temp\1\{34DFE1AC-DAA0-4B6B-BC56-5A1A9ED11FF6}].
      1: NT Authenticaiton detected.
      1: Group validation successful.
      1: Successful connection to MSDE/SQL server [LOCALHOST] for instance [] on port [1433].
      1: SQL instance [] does not match the port [1433] being used.
      1: Unloading the following DLL: [C:\DOCUME~1\harriap\LOCALS~1\Temp\1\{34DFE1AC-DAA0-4B6B-BC56-5A1A9ED11FF6}\CommonSetup.DLL]
      1: Setting the current directory to [C:\WINDOWS\SysWOW64].
      1: End validateePODBServerInfo
      MSI (c) (B4:50) [15:17:38:026]: Destroying RemoteAPI object.
      MSI (c) (B4:30) [15:17:38:026]: Custom Action Manager thread ending.
      === Verbose logging stopped: 5/21/2009 15:17:38 ===


      I have checked that the local SQL is running on port 1433 as suggested.

      I am getting stuck and need advice on how to resolve.
        • 1. RE: epo 4.0 Upgrade Problems
          twenden
          Found this article on the McAfee KnowledgeBase that addresses your issue. Let me know if it fixes your issue as we shall be upgrading to EPO 4.0 soon.

          ERROR: The SQL Server TCP Port does not match the selected database server. Correct the problem and try again

          Corporate KnowledgeBase ID: KB52404
          Published: March 20, 2008

          Environment
          McAfee ePolicy Orchestrator 4.0
          McAfee ePolicy Orchestrator 3.6.1
          Microsoft Windows Server
          Microsoft SQL Server

          Problem 1
          During an upgrade from ePolicy Orchestrator (ePO) 3.6.1 to ePO 4.0 on the Set Database Information window and after entering the authentication details and clicking Next the following error appears:

          The SQL Server TCP Port does not match the selected database server. Correct the problem and try again

          Problem 2
          Upgrade from ePO 3.6.1 to 4.0 fails with error.

          Problem 3
          The EPO400-CommonSetup.log records the following error:

          Server names DO NOT MATCH so block the install.
          Servername from SQL server : [<Server_Name1>]
          Servername from installer : [<Server_Name2>]

          Cause

          The SQL Server name does not match the name as specified as the DataSource in the ePO 3.6.1 SERVER.INI.

          Solution

          Workaround

          Modify the ePO 3.6.1 SERVER.INI so that it reflects the same name as the Server Name for the SQL Server as specified in the error contained in the EPO400-CommonSetup.log

          1. Navigate to the ePO 3.6.1 SERVER.INI:

          Default path: ...\Program Files\McAfee\ePo\3.6.1\DB\

          2. Right-click SERVER.INI and click Edit.

          3. Under the section [SERVER] locate the statement DataSource=

          4. Modify the Server name to match the specified server in the EPO400-CommonSetup.log.

          5. Continue with the upgrade.
          • 2. RE: epo 4.0 Upgrade Problems
            Thanks for this...

            I changed the server.ini as mentioned..

            But during an installation I had another error relating to the SQL 2005 Backward compatibility.

            There was another thread I read regarding this whereby to replace \Setup\SQL2K5Express\SQLEXPR.EXE with a newer one from the web.

            As I have the full SQL this did not work.

            I then tried the new version of Setup\SQL2K5BC\SQLServer2005_BC.msi.. This also failed.

            Said something regarding wrong version.

            So I downloaded the 64bit version and replaced the file. Ran setup and again failed, so I renamed the 64bit file to the same name SQLServer_BC.msi ran setup and worked with no problems.