3 Replies Latest reply on May 5, 2009 12:01 AM by dk1

    Replication OK, agent can't find valid repository

      We have a few PC's that are showing some strange symptoms. I have about 100 PC's total, spread across 10 sites, and about 28 of these PC's are non-compliant. A lot of them seem to be stuck on the 5576 DATs.

      Basically each site has a distributed repository. Our master repository updates OK and we can update our PC's of that. However, even though distributed repository replication reports as completed successfully, the PC's at these sites report "Unable to find valid repository" when trying to update from the distributed repository. This has been going on for a while now. If I point the PC's to the master repository, they update fine. This is not a solution for us as we have very limited WAN bandwidth and 100 PC's updating from one site will choke the network.

      The repositories are set up with FTP, anonymous access for agent-to-server, and FTP authentication for replication. I can browse to the FTP site from the PC and download and install the software.

      I have tried deleting the contents of the distributed repository and letting the replication put all the files back, but this didn't work. I have tried uninstalling/reinstalling the agent on affected PC's but this doesn't seem to work either.

      On weekdays we perform a distributed incremental replication at about 4-7AM +10GMT. On Sundays, since we're closed we do a full replication from about 9AM +10GMT.

      Any ideas that could be causing this? Any log files I can look at to get a better idea of what is happening?
        • 1. RE: Replication OK, agent can't find valid repository
          There is a show agent log in the EPO console to see what is happening during the update
          for a particular system.

          How have you set client to search for repository by ping time ? by order ? subnet ?
          These are options that can be selected in EPO.

          Have you tried a UNC type repository \\ ?

          Verify on the clients vscan console in the 'edit repository' that the repositories are listed
          • 2. RE: Replication OK, agent can't find valid repository
            The "Show Agent Log" simply shows "Unable to find valid repository; Update process failed".

            The repositories are set by order, with the local repository at the top of the list enabled and all others disabled, and they do show up in the vscan console under the repository list.

            UNC type repository doesn't work either when set up in the epo console. HOWEVER - if I add it manually in the virusscan console on the local PC, it DOES work.
            Something very strange is going on here....

            We are using HIPS 7 build 953, Vscan 8.7 with the anti spyware module and EPO 4 build 1151.

            Any ideas what is going on?
            • 3. RE: Replication OK, agent can't find valid repository
              UPDATE: It appears that if I specify a local repository in the Mcafee Agent policy, they will update from that... but not from a global repository. Well it appears to be working now at least although it is very strange...