4 Replies Latest reply on Mar 5, 2010 8:41 AM by HupSkiDup

    HIPS causing reboot, but no HIPS

    bebig1
      Hi,

      I am getting issues with a "device driver disabled" on my HIPS icon. This is identified with a red circle around the HIPS flag. I ran HIPS Patch 4 via ePO (check in .zip file), then create task to run on a particular group. Seems that some machines (in that group get the patch) and some don't.

      Also, I tried removing HIPS altogether, then reinstalling it via ePO and locally with the .msi or exe file. Both methods asks for a reboot, however, when I do so and bring the system back up. HIPS does not show in the taskbar. I do have the policy set to "show icon" and most other systems are showing the HIPS icon.

      Also, on some systems that I try to install HIPS (via ePO and locally), the system reports back that another instance or version is already running. I look in the processes and see no evidence of the HIPS services. Go to the program files folder under McAfee and no Host Intrusion Prevention folder found.

      Any help I would greatly appreciate from the experts on this forum!!!!
        • 1. RE: HIPS causing reboot, but no HIPS
          jmaxwell
          Sounds like there's some debris floating around in your Registry from a previous fauiled install/unistall rollback attempt....

          Jim
          • 2. Re: HIPS causing reboot, but no HIPS

            No answer to this yet?  Did you ever get the issue resolved?  I am having the same issue when I tried updating from HIPS 7.0.0.1021 to 7.0.0.1070.  The update would not push from the ePO, so I set a task to uninstall the current version, and once it reported it was gone, I pushed 7.0.0.1070.  I keep getting a message saying a "Restart the computer to complete the update of Host Intrusion Prevention."  I have done it more than 10 times and it never seems to udpate and I keep getting the same error message.  I tried to manually install it, and it tells me a restart is requried before the patch can be installed.  I'm pretty much stuck with a machine that can't have HIPS installed on it now.  Anyone know of the registry keys or something else that I need to remove or disable?

            • 3. Re: HIPS causing reboot, but no HIPS

              I did get some assistance from support, and they told me to search for a file named McAfeeHIP_reboot and delete it.  Once I did that and did a reboot I did not get prompted anymore, but the agent and HIPS still aren't running correctly on my machine so that just fixed the issue of getting prompted for a reboot.

              • 4. Re: HIPS causing reboot, but no HIPS
                HupSkiDup

                How about doing a manual uninstall of HIPS, a little tedious but it works.

                a chkdsk /f wouldn't hurt either.

                 

                https://kc.mcafee.com/corporate/index?page=content&id=KB51699

                Make sure it's totally cleaned out before you let EPO auto install it.