8 Replies Latest reply on Apr 15, 2009 8:44 AM by Mithrilhall

    ePO server communication failed - non-admin account

      I'm trying to run the ePolicy Orchestrator client as a regular user (non-admin) and it's failing.


      Agent Subsystem 4/13/2009 12:59:08 PM Error Agent failed to communicate with ePO Sever.
      Internet Manager 4/13/2009 12:59:08 PM Error Failed to connect to server srv4.local.com. Check the agent log for more details.



      Trying frminst.exe /install=agent /siteinfo=c:\temp\sitelist.xml\ produced this:

      Can't access path 'SOFTWARE\Network Associates\TVD\Shared Components\Framework'



      Is it possible to have the ePO agent update while running as a regular user (no admin privileges)?
        • 1. RE: ePO server communication failed - non-admin account
          Yes,it's possible to run the ePO agent as an standard user.

          Can you ping the adress srv4.local.com? Try this:
          ping -a srv4.local.com


          To instal the ePO agent you must use the FramePkg.exe. When you search the directory there is an ePO agent there, or you can also create an agent package from the ePO server.
          To install use this command:
          FramePkg.exe /install=agent
          • 2. RE: ePO server communication failed - non-admin account
            I can ping the ePO server by name fine. I even added it to the host file.

            I ran the Framepkg.exe and it installed fine. But when I launch the McAfee Agent Monitor and hit 'Collect and Send Props' it says 'Failed to upload package to ePO Server'.
            • 3. RE: ePO server communication failed - non-admin account
              Could you please post the agent_%computername%.log from that client and also its sitelist.xml ?
              • 4. RE: ePO server communication failed - non-admin account
                I couldn't find the log file and I can't find sitelist.xml.
                • 5. RE: ePO server communication failed - non-admin account
                  Here is the agent log file. I cut it short because I can see my problem. That isn't the IP address of my ePO server (10.1.1.209). I'm not sure how that got in there since that isn't an IP address on my network.


                  20080812093955 I #2888 InetMgr Connecting to Real Server: 10.1.1.209 on port: 80
                  20080812094017 I #2888 InetMgr Failed to connect to Real Server: 10.1.1.209 on port: 80
                  20080812094017 I #2888 InetMgr Failed to connect to Server
                  20080812094017 I #2888 InetMgr Uploading package to ePO Server...trial 3 / 6
                  20080812094017 I #2888 InetMgr Uploading file C:\Documents and Settings\All Users\Application Data\Network Associates\Common Framework\Unpack\pkg00128630219530470000_16046.spkg to ePO Server...
                  20080812094017 I #2888 InetMgr Connecting to Real Server: 10.1.1.209 on port: 80
                  20080812094020 i #3508 Agent Agent Started Enforcing policies
                  20080812094020 I #3508 Agent Thread time-out occurred
                  20080812094020 I #3508 Manage Enforcing policies
                  20080812094020 i #3508 Manage Enforcing Policies for VIRUSCAN8600
                  20080812094020 i #3508 Manage Enforcing Policies for STINGER_3050
                  20080812094020 I #3508 Manage CManage::EnforcePolicies() - FAILED - "STINGER_3050" Error(-1207)
                  20080812094020 i #3508 Manage Enforcing Policies for PATCH___1100
                  20080812094020 i #3508 Manage Enforcing Policies for EPOAGENT3000META
                  20080812094020 i #3508 Manage Enforcing Policies for EPOAGENT3000
                  20080812094020 i #3508 Manage Enforcing Policies for ePolicy Orchestrator Agent
                  20080812094020 I #3508 Agent CePOAgent::EnforcePolicy priority=-2
                  20080812094020 I #3508 Agent Enforcing policies
                  20080812094020 I #3508 LstnSvr Enforcing Policies
                  20080812094020 I #3508 InetMgr IP address for ePO Server =10.1.1.209
                  20080812094020 I #3508 Logging Enforcing policies
                  20080812094020 I #3508 Manage Enforcing policies
                  20080812094020 I #3508 Script Enforcing policies
                  20080812094020 I #3508 Updater Enforcing policies
                  20080812094020 I #3508 UsrSpCt Enforcing policies
                  20080812094020 I #3508 Sched >>--CSchedule::EnforcePolicy
                  20080812094020 I #3508 Sched >>--CSchedule::ModifyTask
                  20080812094020 I #3508 Sched <<--CSchedule::ModifyTask
                  20080812094020 I #3508 Sched Deployment - Last run time(local) is Tue Aug 12 09:35:21 2008
                  20080812094020 I #3508 Sched
                  20080812094020 I #3508 Sched 0 fields of the task 30 are updated successfully
                  20080812094020 I #3452 Manage DoesSoftwareExists SoftwareID=EPOAGENT3000
                  20080812094020 I #3452 Sched Deployment - Last run time is : not run yet
                  20080812094021 i #3452 Sched Added a new task Deployment to Scheduler's task list
                  20080812094021 i #3460 Sched Scheduler: Invoking task [Deployment]...
                  20080812094021 I #3508 Sched >>--CSchedule::ModifyTask
                  20080812094021 I #2324 Sched >>--RunTask
                  20080812094021 I #3508 Sched <<--CSchedule::ModifyTask
                  20080812094021 I #2324 Manage Running task SoftwareID:EPOAGENT3000, TaskID:30
                  20080812094021 I #3508 Sched Immediate Update - Last run time(local) is Thu Jul 24 16:22:00 2008
                  20080812094021 I #3508 Sched
                  20080812094021 I #3508 Sched 0 fields of the task 32 are updated successfully
                  20080812094021 I #3508 Sched RunAtEnforcementEnabled not found in the task settings
                  20080812094021 I #3508 Sched >>--CSchedule::ModifyTask
                  20080812094021 I #3508 Sched <<--CSchedule::ModifyTask
                  20080812094021 I #3508 Sched Agent Wakeup - Last run time(local) is Tue Aug 12 09:19:32 2008
                  20080812094021 I #3508 Sched
                  20080812094021 I #3508 Sched 0 fields of the task 34 are updated successfully
                  • 6. RE: ePO server communication failed - non-admin account
                    I just looked in sitelist.xml and my server is listed there properly.
                    • 7. RE: ePO server communication failed - non-admin account
                      I advise you do this


                      • Frminst /forceuninstall (removing the ePO agent totally)
                      • Reboot to be sure.
                      • Framepkg.exe /install=agent (Installing the ePO agent. When you search on the ePO server your ePO directory, you will find there also an ePO agent. You can also create an Agent from your ePO server (Agent Installation Package Wizard, in the first screen of server (if you are you are using ePO 3.6.1)

                      • 8. RE: ePO server communication failed - non-admin account
                        That worked perfectly. Thank you.