4 Replies Latest reply on May 24, 2009 12:26 AM by petr.bohac

    ePo server is busy

    notime
      Hi all,

      we were using ePO 3.6.1 and we face a probelm iv the McAfee Agent deplyment on one server as the follwing pic :

      yesterday we upgrade ePO to 4.0 patch 3 but still facing same bropelm


      we are using McAfee agent 4.0 patch 1, and i face same probelm in another account


      any idea about this probelm, is it in MA 4 ???







      machine log


      2009-02-27 11:58:26 X #936 naInet Socket created, Handle 1172
      2009-02-27 11:58:26 I #936 naInet Connecting to Real Server: 172.21.13.25 on port: 80
      2009-02-27 11:58:26 I #936 naInet Connected to ePO Server: 172.21.13.25
      2009-02-27 11:58:26 I #936 naInet Uploading SPIPE HTTP header
      2009-02-27 11:58:26 I #936 naInet Uploading data in bytes: 798
      2009-02-27 11:58:26 X #936 improgr ImProgress::operator()
      2009-02-27 11:58:26 I #936 naInet Reading acknowledgement from ePO Server
      2009-02-27 11:58:28 I #936 naInet HTTP return code: HTTP/1.1 503 Service Unavailable

      2009-02-27 11:58:28 I #936 naInet
      2009-02-27 11:58:28 I #936 naInet ePO Server is busy and not accepting anymore connections
      2009-02-27 11:58:28 I #936 naInet Received response [503 Server Busy] from ePO Server
      2009-02-27 11:58:28 I #936 naihttp failed to receive package..server is busy
      2009-02-27 11:58:28 X #936 naInet Socket getting closed, Handle 1172
      2009-02-27 11:58:28 I #936 naInet Uploaded file : C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00128801951066870000_8137.spkg to Server successfully
      2009-02-27 11:58:28 X #936 improgr ImProgress::operator()
      2009-02-27 11:58:28 X #936 improgr ImProgress::operator()
      2009-02-27 11:58:28 I #936 imsite NaInet library returned code == 12
      2009-02-27 11:58:28 X #936 imutils getErrorText()
      2009-02-27 11:58:28 X #936 imsite The naInet library returned a status code. [Parent error: NaInet library returned code == 12]
      2009-02-27 11:58:28 X #936 naInet Socket getting closed, Handle -1
      2009-02-27 11:58:28 I #936 naInet HTTP Session closed
      2009-02-27 11:58:28 i #936 Agent ePO Server is busy
      2009-02-27 11:58:28 i #936 Agent Agent communication session closed
      2009-02-27 11:58:28 X #936 Filer GetFileAttributes,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00128801951066870000_8137.spkg
      2009-02-27 11:58:28 X #936 Filer =32
      2009-02-27 11:58:28 X #936 Filer SetFileAttributes,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00128801951066870000_8137.spkg
      2009-02-27 11:58:28 X #936 Filer DeleteFile,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Unpack\pkg00128801951066870000_8137.spkg
      2009-02-27 11:58:28 I #936 Agent Agent communication failed, result=-2403
      2009-02-27 11:58:28 I #936 Agent Exponential retry in 1014 seconds, error=-2403(Server busy or reaches max concurrent download number)
      2009-02-27 11:58:28 i #936 Agent Agent will connect to the ePO Server in 16 minutes and 54 seconds.
        • 1. RE: ePo server is busy
          Interesting, that I have also discovered the same issue with some of my clients.

          I haven't got time to dig into the problem but I can say that we're using the same config like you.

          ePO 4.0P3, MA 4.0P1, about 900 clients

          Anyone else noticed the issue?

          Edit: restarted services and everything is working as expected. However it's quite strange issue. Also noticed that most of the queries didn't produce any results.
          • 2. EPO Server busy...
            I am also seeing these in my log..
            I am not able to push any policy updates to my clients. I think it might be a port conflict. I'm not sure what could be blocking access to the port.
            • 3. RE: EPO Server busy...
              guys.
              please verify that you running latest SQL2005 db for your ePo server - they have hardcoded app server limitation (tomcat) that use all 254 connections from clients and not able to insert data to SQL2000 db.
              probably you can see many clients events on your DB\events folder now that slowly disappear...

              if this a case - you need to migrate db to latest SQL
              • 4. RE: EPO Server busy...
                I do use SQL2005 SP2. Anyway it seems to be a rare problem and hasn't occurred again.