1 2 3 Previous Next 28 Replies Latest reply on Feb 18, 2009 9:36 AM by glen8

    Please help me, Agents not talking to EPO 4

      Hi,

      I was wondering if some kind sole out there could give me a few pointers please.

      Lucky we only have a small PC user base but 25% refuse to do what I tell them to :D

      The machines in question are listed in EPO, they have AntiVirus 8.7 and Agent 4 installed and I can see the logs on port 8081. So far, so good then you might think.

      I can click on one of the machines and view the tasks I have configured but the machine will refuse to run the tasks. Last night I deployed (again) the agents from EPO and this morning ran an agent wakup call. No errors in the EPO server logs so I can only assume everything worked ok.

      Three hours later and the logs are still not showing the tasks? I do see quite often 'No package recieved from ePO server'




      This is only one of my problems, I have a few machines which I can't communiate over 8081 so I have no idea about those. Since 75% of our machines are working ok I can only assume EPO is configured correctly and it's a client issue but where on earth do I start.

      We did have an old EPO server running using a different servername and IP address and I'm wondering if those few machines seem to have got confused? That server has now been removed from the network and formatted ready for another project.

      Those machine have the message 'No McAfee Agent properties available at this time.' and when I try and view the remote agent logs get the 'You are not Authorized to view this page' message in the browser.

      Thanks very much,
      Glen.
        • 1. Hi
          What kind of Task have you set at the ePo Server?

          Give some more details about the task.
          • 2. RE: Hi


            The three tasks are in the pic above

            DAT Updates at 12 Noon
            PC Disk Scan at 1

            Then I added an immediate task as a test (two days ago) which was the DAT updates. It doesn't matter what tasks I put in, even an agent wake up call won't wake up those 25% machines.

            More worrying is when I click on the red area of the pie chart on the dashboard (non-compliance machines) I can see the engine and DAT version but no agent version numbers. On all these machines I am unable to view the agent logs. I have tried over 10 times to deploy agents, wake up calls and even manually installed the framepkg.exe from the clients local disk.

            Next step is I am going to remote onto one of them to see if I can see the agents gui. If I can I'll post the results.

            Thanks for helping me, much appreciated.
            • 3. RE: Hi
              ok small update

              I have remote controlled onto one of the problem machines. I opened the agent GUI monitor screen and tried looking at the log from the EPO server.

              The message 'Remote access to log is disabled through policy' came up on the client.

              Now, I orginally thought the tick wasn't in the agents policy but I have double checked and I definately have the tick on 'Enable remote access to log'

              Now I'm stumped :mad:
              • 4. RE: Hi
                How did you deployed the Agent?
                Is it Version 4?
                Also look at Firewall blocks in XP.
                Agent needs 3 ports!
                TCP 82
                TCP 8081
                TCP 8082

                Look in the %Systemroot%\pfirewall.log
                • 5. RE: Hi
                  There's no firewall running on this machine, Agent is V4 downloaded from mcafee only a couple of weeks ago and then integrated into EPO.

                  I would assume that originally the agent was installed from the old EPO server and then re-installed at a later date when the new Virus server came online.

                  We do have a support team and its possible they could have installed the framepkg.exe from a cd (the .exe file came from the new EPO server)

                  This has been the case with all our machines and only....I say only wink 25% have a problem
                  • 6. RE: Hi
                    ok, this may help understand my problem

                    Click on the red area of the pie chart at the dashboard :-



                    click on say JODIEJOHNSON machine name :-



                    When I look on her desktop, cmdagent /s /p

                    • 7. RE: Hi
                      Tasks are never delivered as packages.

                      Look at policy: VirusScan Enterprise 8.7.0 > User Interface Policies >
                      Have you turned the "Display managed tasks in the client console" on?

                      :o
                      • 8. RE: Hi
                        Yes already done that, like I said 75% of machines are working fine and showing tasks etc etc

                        I may have found something not quite right

                        Checking a working machine against this one has turned up a missing registry key, I have made a .reg file and imported it

                        Windows Registry Editor Version 5.00

                        [HKEY_LOCAL_MACHINE\Software\Network Associates\ePolicy Orchestrator\Application Plugins\CMNUPD__3000]
                        "Plugin Path"="C:\Program Files\Network Associates\Common Framework\FrmPlugin.dll"
                        "Software ID"="CMNUPD__3000"
                        "Uninstall Command"=""
                        "Language"="0409"
                        "Product Name"="McAfee AutoUpdate"
                        "Version"="4.0.0.1180"

                        No idea if I need to reboot or not but am doing one anyway
                        • 9. RE: Hi
                          Are the PC/Clients 'Ghosted' and SYSPREP installed?

                          Sometimes this gives problems with the agent
                          1 2 3 Previous Next