Who Me Too'd this topic

cancel
Showing results for 
Search instead for 
Did you mean: 

Who Me Too'd this topic

Cannot uninstall/update DLP on certain PCs due to a blocked service error

We have upgraded to DLP 11, and the client has gone out to most machines according to ePO.

Sadly on about 10% of machines (around 300) the update does not seem to be going out as they are still picking up the DLP 9.3 policies.  When I remote connected to one they are still indeed running the DLP 9.3 client.

The strange thing is, it is not under Add/Remove programs any more.  Therefore I just tried to run the DLP 11 MSI manually and it gets so far before the following error :-

"Service McAfee DLP Endpoint Service (McAfeeDLPAgentService) could not be stopped.  Verify that you have sufficient privileges to stop system services."

This is logged on as a full administrator, and running as administrator.  I have also tried to process kill the service but the problem is it reboots it back up several seconds later.

Any ideas?  I can run the McAfee removal tool but this is quite a long process to do on 300 PCs especially when they are in use, ideally I need a command I can run from ePO or via a batch script to sort.  I don't mind if it totally uninstalls DLP then I have to push out DLP11 again to them, I just need to get them off 9.3!

Who Me Too'd this topic

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community