cancel
Showing results for 
Search instead for 
Did you mean: 

"file catalog.z is corrupt" on Viruscan after upgrading EPO to 4.5.3.937

Hello all,

We did the upgrade of the EPO Server to 4.5.3.937 (Patch 3) and since this day, all updates

from Mcafee repositories don't work at all. We have the message on viruscan client update windows : File catalog.z is corrupt.

I tried to reinstall completely the definition files from mcafee (Stop services, delete Db\Software directory, restart services). All

files came back on the master repository and all the other repositories but on clients, it's always the same message and the update doesn't work.

Anyone has the same problem ? How can i resolved it ?

Thanks for your answers.

Regards

Francky

Server EPO 4.5.3.937

Viruscan 8.7.0i patch 3 (8.7.0.181)

Agent EPO 4.5.0.165

5 Replies
McAfee Employee JoeBidgood
McAfee Employee
Report Inappropriate Content
Message 2 of 6

Re: "file catalog.z is corrupt" on Viruscan after upgrading EPO to 4.5.3.937

I tried to reinstall completely the definition files from mcafee (Stop services, delete Db\Software directory, restart services).


That was not a good idea, I'm afraid   Did you back up the folder before deleting it? Can you restore it?

By deleting that folder you've removed your entire master repository, including any product install packages... if you can't restore it you're going to need to rebuild it manually, I'm afraid.

Regards -

Joe

Re: "file catalog.z is corrupt" on Viruscan after upgrading EPO to 4.5.3.937

I did a backup of the folder software and after restarting services, i did an "update by web".

All the packages came back from internet and everything seems fine.

but we've got always the same messages from clients 'File catalog.z is corrupt", strange, no ?

McAfee Employee JoeBidgood
McAfee Employee
Report Inappropriate Content
Message 4 of 6

Re: "file catalog.z is corrupt" on Viruscan after upgrading EPO to 4.5.3.937

francky59 wrote:

I did a backup of the folder software and after restarting services, i did an "update by web".

All the packages came back from internet and everything seems fine.

That will have restored the content packages, like DATs and engines - but it will not have replaced any point product packages that were checked in at install time or by you manually (for example VSE install packages, agent key updaters, and so on.)

but we've got always the same messages from clients 'File catalog.z is corrupt", strange, no ?

Can you post the agent log from a machine showing the problem?

Thanks -

Joe

Re: "file catalog.z is corrupt" on Viruscan after upgrading EPO to 4.5.3.937

Hello,

Sorry for the late. I send you an example of EPO Agent log. I saw it could be a certificate problem on some posts.

If you can find something with this...

Thanks in advance

Regards

Francky

McAfee Employee JoeBidgood
McAfee Employee
Report Inappropriate Content
Message 6 of 6

Re: "file catalog.z is corrupt" on Viruscan after upgrading EPO to 4.5.3.937

Thanks for this...

Unfortunately as you have noticed the agent is not able to communicate with the server... you really need to resolve this problem before anything else. I would recommend opening a case with support - there are a large number of problems that can cause this kind of failure, and it's a bit beyond the scope of this forum

Regards -

Joe

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community