cancel
Showing results for 
Search instead for 
Did you mean: 
yzerman10
Level 7

"The epo server must be upgraded first before the agent handler"

After the successful upgrade to 4.6.6 of my epo, all 3 agent handlers are having the same error mentioned in the subject..and cannot upgrade from 4.6.4 had double checked the server.ini of the epo is upgraded to 4.6.6

Each AH's has 1k managed nodes and now they cannot communicate to the epo.

Please direct what to do next. Thanks

Yzerman

0 Kudos
3 Replies
ajha1
Level 9

Re: "The epo server must be upgraded first before the agent handler"

Hi yzerman10,

As you have upgraded the EPO to version, 4.6.6, you need to upgrade the Agent Handler as well to work properly with current version of EPO. Copy the Agent Handler folder from the EPO Installation Pacakge of EPO 4.6.6 to Agent Handler Machine and run the setup file inside it and upgrade the Agent Handler version to 4.6.6 and see whether the managed machines are communicating or not.

Please revert if my understanding for the issue is different.


0 Kudos
yzerman10
Level 7

Re: "The epo server must be upgraded first before the agent handler"

Thanks AJ! I am aware of that procedure. the error came accross while upgrading the AH's in 4.6.6 after upgrading the epo using the 4.6.6 Agent handler installation package.. To make it clear I used the same Installation package that were used in upgrading epo and tried also the newly downloaded package from mcafee..but still having the same error.

Regards

0 Kudos
ajha1
Level 9

Re: "The epo server must be upgraded first before the agent handler"

Hi yzerman10,

Could you please check, whether the Agent Hanlder is disabled at EPO Console or not, if it is disabled then enable it and restart the McAfee Services at the Agent Handler End, Check if it is communicating and then try to upgrade and share the result.

- You can restart the McAfee Server at the Agent Handler, even if it is enabled and the try to upgrade.

0 Kudos