cancel
Showing results for 
Search instead for 
Did you mean: 
jxl
Level 7

"Failed to communicate with the target server" after upgrade to ePO 4.6

Hi

After what seems to be a successfully upgrade from ePO 4.5 patch 4 to ePO 4.6, I now receive an error message when I try to update the Master Repository.

The error message is "Failed to communicate with the target server".

Has anyone seen this error message before and maybe have a fix for it?

Which logfile have information regarding the master repository updates?

Thanks

John

0 Kudos
4 Replies
metalhead
Level 12

Re: "Failed to communicate with the target server" after upgrade to ePO 4.6

The Repository Update is logged in EPOAPSVR.LOG on your epo server (<epoinstalldir>\DB\Logs).

0 Kudos
jxl
Level 7

Re: "Failed to communicate with the target server" after upgrade to ePO 4.6

Thanks for helping with this issue, I finally found the problem.

In the logfile EPOAPSVR.LOG, was a error with unable to find or open a site config file or similar message.

It turns out to be the McAfee source distributation points that was the error. All I did to fix the problem was to modify the 2 McAfee source sites , http and ftp and saved the changes.

After that I was able to update the Master Repository.

I actually have more similar problems. Many of our Server tasks was in state "invalid" and I had to modify / save them to to fix the problem.

Also all our client tasks are gone, I have to recreate them all again now

Thanks

John

0 Kudos
wattspwr
Level 7

Re: "Failed to communicate with the target server" after upgrade to ePO 4.6

jxl,

I was getting the same error when trying to replicate or update master repository after I upgraded to 4.6.  After checking the EpoApSvr.log I noticed some lines referring to proxy:

20110401104213 I #05196 INETMGR  Starting download session for url myavert.avertlabs.com:8801

20110401104213 E #05196 INETMGR  Unable to identify algorithm for encrypted password x2mxxxxxxtnY6QNOsxxxxxz0HbZ2OkDTrFXsR/abAFPM9B3Q==

20110401104213 E #05196 INETMGR  CRepositoryProxyDAO:Smiley TongueroxyObjFromRecordSet failed decrypting proxy password

20110401104213 E #05196 INETMGR  Failed to get the local proxy config in StartGeneralPurposeSession()

20110401104213 E #05196 INETMGR  Start session for site download failed

20110401104213 e #05196 SITEMGR  GeneralInetRequestThreadProc: Failed to connect to myavert.avertlabs.com:8801

Here is what I did to correct the issue:

Open EPO console and go to Menu>Configuration>Server Settings

Click on Proxy settings.  (I am not using a proxy)

Click on Edit

(I am not using proxy) so I checked "Configure the proxy settings manually" and then select "Save"

Now go back and reset initial proxy settings ("Do not use proxy settings") and "Save".

My replication began to work and my log file looked like this:  (partial log but shows successful connection).

20110402181210 I #05196 INETMGR  Starting download session for url myavert.avertlabs.com:8801

20110402181210 I #05196 NAINET   HTTP Session initialized

20110402181210 I #05196 NAINET   Connecting to HTTP Server using Microsoft WinInet

20110402181210 I #05196 NAINET   Trying to connect to Real Server myavert.avertlabs.com using INTERNET_OPEN_TYPE_PRECONFIG

20110402181210 I #05196 NAINET   Connected to Server: myavert.avertlabs.com on Port: 8801 using WinInet

20110402181210 I #05196 INETMGR  Started download session 1 for site myavert.avertlabs.com:8801

20110402181210 I #05196 SITEMGR  GeneralInetRequestThreadProc: Downloading /reportservice.asmx

20110402181210 I #05196 INETMGR  Downloading file reportservice.asmx from session 1, LocalDir=C:\WINDOWS\TEMP\naiA0D.tmp\00000000, RemoteDir=

20110402181210 I #05196 NAINET   Open URL: http://myavert.avertlabs.com:8801/reportservice.asmx

20110402181210 I #05196 NAINET   Trying to download using Microsoft WinInet library

20110402181210 I #05196 NAINET   Connecting to Real Server myavert.avertlabs.com using INTERNET_OPEN_TYPE_DIRECT

20110402181210 I #05196 NAINET   No resume download needed, calling InternetOpenUrl

20110402181210 I #05196 NAINET   Downloading a file of total size: 9, content-length: 9

20110402181210 I #05196 NAINET   Downloaded 962 bytes this time

20110402181210 I #05196 NAINET   Downloaded 0 bytes this time

20110402181210 I #05196 INETMGR  Downloaded file reportservice.asmx successfully in session 1

20110402181210 I #05196 NAINET   HTTP Session closed

0 Kudos
metalhead
Level 12

Re: "Failed to communicate with the target server" after upgrade to ePO 4.6

0 Kudos