cancel
Showing results for 
Search instead for 
Did you mean: 

javascript error when creating new task

I am running a fresh eval of EPO 4.0 with latest download of VirusScan Enterprise.
Running on Windows Server 2003 Enterprise Edition with all latest security updates.
OS is running under VMWare Workstation 6.5, 1 GB of RAM.
Installed latest java runtime from Sun. (Not sure if I needed but it's there)
I deployed a couple of agents, all OK.
I went to create a new client task for a selected system.
Under "Client Tasks" .. "New Task" When clicking the "New Task" button at the bottom,
I get the following javascript error and the browser goes blank:

==============================
Message: Object required
Line: 115
Char: 9
Code: 0
URI: https://localhost:8443/PolicyMgmt/CreateClientTask.do
==============================

I also ran javascript console in FireFox and it dumped the following information:
(trimmed off the extraneous junk)
---------------

function fnSetupPage()
Line 115
$("inputhiddenID_ProductName").value = $("osID_Tasktype").options[$("osID_Tasktype").selectedIndex].text.split(":")[0];

Error: $("osID_Tasktype") is null

Source File: https://localhost:8443/PolicyMgmt/CreateClientTask.do?nodeID=5&nodeType=3

This happens 100% of the time, in both Firefox and IE

=========================================

After playing around some more, I found it works fine when running the console web page from another machine.
It appears to be a problem when running as 'localhost' only. A bug nevertheless... I will run things from remote consoles
in meantime.
4 Replies
Highlighted

RE: javascript error when creating new task

You must use the Internet Explorer. The console doesn`t work in firefox.

RE: javascript error when creating new task



Jim

RE: javascript error when creating new task

Oh sorry.

check your security settings in IE or firefox. Add the console to trusted sites. It`s look like your browser couldn`t start active java script. Row 115 generate a list from possible tasks.

RE: javascript error when creating new task

I was having the same problem, looks like a problem with IE8, reverted back to IE7 and it works now.


More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community