cancel
Showing results for 
Search instead for 
Did you mean: 
jctech
Level 7
Report Inappropriate Content
Message 1 of 7

help with sql express please(for epo 4.5 upgrade)...

Hello,

I was wondering if anyone could help with upgrading the version showing in my Microsoft SQL Server Management Studio Express. Even though I installed SQL 2005 express from SQL 2000 express....the server name under "Object Explorer" is showing "EDISON(SQL Server 8.0.760).  I have a compressed print screen for reference....

I'm trying to upgrade from epo 3.6.1 to epo 4.5 but cannot because I cannot get it to upgrade to 9.0. I'm receiving a sql server non-compatability error...

Is there anyone that could help with this as far as what I need to do? Any help would be appreciated....thank you.

-Jae

6 Replies
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 7

Re: help with sql express please(for epo 4.5 upgrade)...

You might have a named instance installed. You will need to launch the SQL Server Configuration manager to see if anything other than the default MSSQLSERVER instance is listed. If that is the case, you will need to point ePO to that instance (e.g. SERVERNAME\Instancename).

jctech
Level 7
Report Inappropriate Content
Message 3 of 7

Re: help with sql express please(for epo 4.5 upgrade)...

In SQL Server Configuration Manager, there are SQL Server 2005 Services, SQL Server 2005 Network Configuration, and a SQL Native Client Configuration. When I highlight the SQL Server 2005 Services.....there is a SQL Server(SQLEXPRESS) and a SQL Server Browser.

I do not believe there is any tie with the epo_EDISON in here....only in the SQL Server Management Studio Express....

Is that my problem?

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 7

Re: help with sql express please(for epo 4.5 upgrade)...

It looks like you do have a named instance. When you specify the SQL server, try specifying it as EDISON\SQLEXPRESS.

jctech
Level 7
Report Inappropriate Content
Message 5 of 7

Re: help with sql express please(for epo 4.5 upgrade)...

I'm a real newbie here...sorry. Where(what folder) would I go to change the path to specify the SQL server? In the ePO console?

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 7

Re: help with sql express please(for epo 4.5 upgrade)...

Actually this may be a mit more difficult than I anticipated. The problem is that it appears you may have installed SQL 2005 Express as a named instance, whil the ePO DB is still on the default instance of MSDE. The options you would have (if this truely is the case) are:

1. Backup the DB from MSDE and restore it to the SQL 2005 instance and point ePO 3.6.1 there and begin the upgrade.

2. Upgrade the default MSDE instance to SQL 2005 Express (make sure to backup the ePO DB before doing this just to be sure)

Here are some articles that may haelp with this:

DB Backup:

http://msdn.microsoft.com/en-us/library/ms191304.aspx

DB Restore

http://msdn.microsoft.com/en-us/library/ms186858(SQL.90).aspx

Upgrading MSDE to SQL 2005 Express

http://technet.microsoft.com/en-us/library/cc966393.aspx

Migrating ePO 3.6.1 and usage of CfgNaims.exe

https://kc.mcafee.com/corporate/index?page=content&id=KB58843&actp=search&searchid=1260317471841

jctech
Level 7
Report Inappropriate Content
Message 7 of 7

Re: help with sql express please(for epo 4.5 upgrade)...

Thanks for really looking into this Greg. I got it resolved now. =)

I had to detach the .mdf and copy it over to the new SQL 2005 folder and then add it to the new instance in Studio Express. Then open Cfgnaims.exe and change the settings there. Now I should be ready to upgrade to epo 4.5. Thanks for your inputs Greg. Much appreciated.